summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-09-20 16:25:32 +0200
committerMarek Szuba <marecki@gentoo.org>2020-09-20 16:33:59 +0200
commit6cbc8a7b3d4ef1ff93eaedfb2ea1b77acf002ec5 (patch)
tree10a023113df204778e1a09d646dec277dd4b7228
parentdev-python/ptyprocess: Remove python2 (diff)
downloadgentoo-6cbc8a7b3d4ef1ff93eaedfb2ea1b77acf002ec5.tar.gz
gentoo-6cbc8a7b3d4ef1ff93eaedfb2ea1b77acf002ec5.tar.bz2
gentoo-6cbc8a7b3d4ef1ff93eaedfb2ea1b77acf002ec5.zip
dev-util/intel-graphics-compiler-1.0.4111: only block llvm-10 in TC
Turns out this version is not going anywhere any time soon, in fact there is a stablereq for it now - so let's handle this properly. Specifically, pkg_pretend() now dies if the current compiler is clang-10+ (I think it is safe to assume that if 10 does not work nor will the newer versions). Bug: https://bugs.gentoo.org/738934 Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.4111.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.4111.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.4111.ebuild
index b5113c4912d..4b31c121d43 100644
--- a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.4111.ebuild
+++ b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.4111.ebuild
@@ -18,9 +18,7 @@ IUSE="debug"
LLVM_MAX_SLOT=10
-# Bug #738934
-#COMMON="<=sys-devel/llvm-${LLVM_MAX_SLOT}.9999:=[${MULTILIB_USEDEP}]
-COMMON="<sys-devel/llvm-10.0.1:=[${MULTILIB_USEDEP}]
+COMMON="<=sys-devel/llvm-${LLVM_MAX_SLOT}.9999:=[${MULTILIB_USEDEP}]
<=dev-libs/opencl-clang-${LLVM_MAX_SLOT}.9999:=[${MULTILIB_USEDEP}]"
DEPEND="${COMMON}"
RDEPEND="${COMMON}"
@@ -32,6 +30,14 @@ PATCHES=(
S="${WORKDIR}"/${PN}-igc-${PV}
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if tc-is-clang && [[ $(clang-major-version) -ge 10 ]] ; then
+ die "Building IGC with clang-10 and newer is presently not supported (see Bug #738934). Please use clang-9 or gcc instead."
+ fi
+ fi
+}
+
multilib_src_configure() {
# Select the same slot as the best opencl-clang
local ocl_clang_ver="$(best_version -d dev-libs/opencl-clang:=)"