summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marius.brehler+gentoo@googlemail.com>2019-07-11 11:39:31 +0200
committerBenda Xu <heroxbd@gentoo.org>2019-07-11 19:30:56 +0800
commit6d218decaacacd8464bcd42186786ca6351c5120 (patch)
tree9d9d77e6332aabbab91e7c395ccb01e164308433
parentsci-libs/openblas: bump to 0.3.6, solving problem with gcc-9.1.0 . (diff)
downloadgentoo-6d218decaacacd8464bcd42186786ca6351c5120.tar.gz
gentoo-6d218decaacacd8464bcd42186786ca6351c5120.tar.bz2
gentoo-6d218decaacacd8464bcd42186786ca6351c5120.zip
dev-python/jupyter_client: Version bump to 5.2.4
Closes: https://github.com/gentoo/gentoo/pull/12370 Signed-off-by: Marius Brehler <marius.brehler+gentoo@googlemail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-5.2.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index 8520968e679d..52b60a9a5011 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1,2 +1,3 @@
DIST jupyter_client-5.1.0.tar.gz 265233 BLAKE2B 1f4533e1c6578e61b1a7591889805d5e324a3cd368cb3998131f2047056c87984ae26d83c9de0277aa6f19b61db4c4d9b39083b795e0891ef7d5394949b5fa44 SHA512 eca7adab1f8aae05743c341a257d4ca4338b0838cc3441939dda48229cdfa13b267bdc338b951bc4e6e139d03d26b40a1294140218f84ab800d211f7e0d8bfc7
DIST jupyter_client-5.2.3.tar.gz 271787 BLAKE2B 36761e53050874c141c38f545f8f6fb53c144c30f686b3706594d124a65e410c205379b7ecbeed12f1520f0f568c7db3c802223f6fdb8f76407074beacc21918 SHA512 89b980ecc281bc1512e1fc4ba35862cc6e541f825ee07a1382d300c8088f24611225ab415d6a7c1e4209c47a74c113ec95f863e8fb0b33c6db9eb9c3521fc0ae
+DIST jupyter_client-5.2.4.tar.gz 273397 BLAKE2B a63e13fea7bf121cfe0191d702bf5398a72902e075d560ec235eec6c28492a89753a90efe642fc207ab23357e74aac566bbfbeeb7970b765bf53641caa7ac95f SHA512 a8bb322e4cbcfa5ab9ffbcfdbf2e2ea60e7923f415d7574a93866e99c03a8c5b0a11d7c82e9c4c1c69f4da1261563f419877dffd5347294a58a744c445271a53
diff --git a/dev-python/jupyter_client/jupyter_client-5.2.4.ebuild b/dev-python/jupyter_client/jupyter_client-5.2.4.ebuild
new file mode 100644
index 000000000000..fb9e7603b74d
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-5.2.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ pytest -vv jupyter_client || die
+}