summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortoshokan <toshokan@shojigate.net>2020-07-09 11:43:30 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-07-11 11:18:37 +0300
commit6d4cf4dbe1e99ecf5cc13e65d41cf7445455a8b3 (patch)
tree6871bcf8fc9b3b81b850758fe5d5e319d5e4552b
parentwww-client/firefox-bin: remove unused files (diff)
downloadgentoo-6d4cf4dbe1e99ecf5cc13e65d41cf7445455a8b3.tar.gz
gentoo-6d4cf4dbe1e99ecf5cc13e65d41cf7445455a8b3.tar.bz2
gentoo-6d4cf4dbe1e99ecf5cc13e65d41cf7445455a8b3.zip
app-misc/physlock: Use upstream PAM config
Following the recommendation at https://github.com/muennich/physlock/commit/66957ee48384dd2e0fa6477b8276e9f6b3842bc5 Also more closely follow the configuration format the build system expects. Package-Manager: Portage-2.3.103, Repoman-2.3.23 Closes: https://bugs.gentoo.org/731824 Signed-off-by: Jason Pizzuco <toshokan@shojigate.net> Closes: https://github.com/gentoo/gentoo/pull/16649 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-misc/physlock/physlock-13-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/physlock/physlock-13-r1.ebuild b/app-misc/physlock/physlock-13-r1.ebuild
new file mode 100644
index 000000000000..b817bc5f5665
--- /dev/null
+++ b/app-misc/physlock/physlock-13-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs pam
+
+DESCRIPTION="Lightweight Linux console locking tool"
+HOMEPAGE="https://github.com/muennich/physlock"
+SRC_URI="https://github.com/muennich/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+IUSE="elogind systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+RDEPEND="sys-libs/pam"
+DEPEND="${RDEPEND}
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+"
+
+pkg_setup() {
+ export MY_CONF="HAVE_SYSTEMD=$(usex systemd 1 0) HAVE_ELOGIND=$(usex elogind 1 0)"
+}
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_compile() {
+ emake ${MY_CONF}
+}
+
+src_install() {
+ emake ${MY_CONF} DESTDIR="${D}" PREFIX=/usr install
+ newpamd physlock.pam ${PN}
+}