summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2019-01-29 21:16:16 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2019-01-29 21:18:21 +0100
commit6db1cfeb695624be1aea007bc691c7252f74a95b (patch)
treea7458a05fdf49ad1ca6884beb709ef53f32dbf75
parentmedia-libs/taglib: stable 1.11.1_p20181028 for sparc, bug #676614 (diff)
downloadgentoo-6db1cfeb695624be1aea007bc691c7252f74a95b.tar.gz
gentoo-6db1cfeb695624be1aea007bc691c7252f74a95b.tar.bz2
gentoo-6db1cfeb695624be1aea007bc691c7252f74a95b.zip
gnome-extra/gtkhtml: added revision with enchant-2 compatibility
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
-rw-r--r--gnome-extra/gtkhtml/files/enchant-2.patch35
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-4.10.0-r1.ebuild52
-rw-r--r--profiles/package.mask4
3 files changed, 91 insertions, 0 deletions
diff --git a/gnome-extra/gtkhtml/files/enchant-2.patch b/gnome-extra/gtkhtml/files/enchant-2.patch
new file mode 100644
index 00000000000..c1afe677c66
--- /dev/null
+++ b/gnome-extra/gtkhtml/files/enchant-2.patch
@@ -0,0 +1,35 @@
+diff --git a/components/editor/gtkhtml-spell-checker.c b/components/editor/gtkhtml-spell-checker.c
+index 0927f57..89e9873 100644
+--- a/components/editor/gtkhtml-spell-checker.c
++++ b/components/editor/gtkhtml-spell-checker.c
+@@ -375,7 +375,7 @@ gtkhtml_spell_checker_add_word (GtkhtmlSpellChecker *checker,
+ if ((dict = spell_checker_request_dict (checker)) == NULL)
+ return;
+
+- enchant_dict_add_to_pwl (dict, word, length);
++ enchant_dict_add (dict, word, length);
+ g_signal_emit (G_OBJECT (checker), signals[ADDED], 0, word, length);
+ }
+
+diff --git a/configure.ac b/configure.ac
+index e4946aa..e5771e3 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -10,7 +10,7 @@ PACKAGE=gtkhtml
+
+ dnl Required Package Versions
+ m4_define([gtk_minimum_version], [3.2.0])
+-m4_define([enchant_minimum_version], [1.1.7])
++m4_define([enchant_minimum_version], [2.0.0])
+ m4_define([cairo_minimum_version], [1.10.0])
+
+ GTKHTML_API_VERSION=4.0
+@@ -140,7 +140,7 @@ AC_SUBST(GAIL_MODULES)
+ dnl **********************************
+ dnl GTKHTML modules
+ dnl **********************************
+-GTKHTML_MODULES="gtk+-3.0 >= gtk_minimum_version enchant >= enchant_minimum_version gsettings-desktop-schemas iso-codes cairo >= cairo_minimum_version"
++GTKHTML_MODULES="gtk+-3.0 >= gtk_minimum_version enchant-2 >= enchant_minimum_version gsettings-desktop-schemas iso-codes cairo >= cairo_minimum_version"
+ PKG_CHECK_MODULES(GTKHTML, $GTKHTML_MODULES)
+ AC_SUBST(GTKHTML_CFLAGS)
+ AC_SUBST(GTKHTML_LIBS)
diff --git a/gnome-extra/gtkhtml/gtkhtml-4.10.0-r1.ebuild b/gnome-extra/gtkhtml/gtkhtml-4.10.0-r1.ebuild
new file mode 100644
index 00000000000..50c27673527
--- /dev/null
+++ b/gnome-extra/gtkhtml/gtkhtml-4.10.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools gnome2
+
+DESCRIPTION="Lightweight HTML rendering/printing/editing engine"
+HOMEPAGE="https://git.gnome.org/browse/gtkhtml"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="4.0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+# orbit is referenced in configure, but is not used anywhere else
+RDEPEND="
+ >=x11-libs/gtk+-3.2:3
+ >=x11-libs/cairo-1.10:=
+ x11-libs/pango
+ >=app-text/enchant-2.0.0
+ gnome-base/gsettings-desktop-schemas
+ >=app-text/iso-codes-0.49
+ >=net-libs/libsoup-2.26.0:2.4
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ sys-devel/gettext
+ dev-util/glib-utils
+ >=dev-util/intltool-0.40.0
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/enchant-2.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Don't collide with 3.14 slot
+ mv "${ED}"/usr/bin/gtkhtml-editor-test{,-${SLOT}} || die
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index e63e00e2ece..556e390f4e1 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -29,6 +29,10 @@
#--- END OF EXAMPLES ---
+# Dennis Lamm <expeditioneer@gentoo.org> (29 Jan 2019)
+# Depends on >=app-text/enchant-2.0.0 which is masked
+=gnome-extra/gtkhtml-4.10.0-r1
+
# Dennis Lamm <expeditioneer@gentoo.org> (28 Jan 2019)
# Depends on >=app-text/enchant-2.0.0 which is masked
>=app-text/gtkspell-3.0.10