summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-17 00:32:50 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-17 00:47:48 -0500
commit6df61f72e0ce19de0805416f84062bb0900e659b (patch)
treec9a582ec42778401feb944ccf30f7c4bc01bec6d
parentgnome-extra/gucharmap: Version bump to 14.0.1 (diff)
downloadgentoo-6df61f72e0ce19de0805416f84062bb0900e659b.tar.gz
gentoo-6df61f72e0ce19de0805416f84062bb0900e659b.tar.bz2
gentoo-6df61f72e0ce19de0805416f84062bb0900e659b.zip
dev-libs/fribidi: Version bump to 1.0.11
Closes: https://bugs.gentoo.org/818778 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-libs/fribidi/Manifest1
-rw-r--r--dev-libs/fribidi/fribidi-1.0.11.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/fribidi/Manifest b/dev-libs/fribidi/Manifest
index a785897cb8e0..ba465f4e4bb1 100644
--- a/dev-libs/fribidi/Manifest
+++ b/dev-libs/fribidi/Manifest
@@ -1 +1,2 @@
DIST fribidi-1.0.10.tar.xz 1147588 BLAKE2B e40e16b4b6167d0c7cc26b72ed21a7b4b2ba78dcce56eaf5dee94835cd2d4770401ac17bc2b5f13227e41e8f19513a0616f49edab07ea8fb2969eab30e24f653 SHA512 cb51920012c3c7507c17e2beb1dbbcfb8d7c6404e4cb54b260a332754a0d5b103d8834d77e8795651b3f38069c9bd2e9914c21b001411a72f9ffe1ec1ef2f360
+DIST fribidi-1.0.11.tar.xz 1077004 BLAKE2B 9de3e170e2b6cf90623c711e16f6595f6ca91e14707cbfd36dda7df92689ea79ec36c4b658199e9046eedd07c9ebfde18617525c83cf4b0e9e2ccb4d9f82ed84 SHA512 6afde86784de06759f18235ccb44f23261a975f7cce0021b16755065a6a8ed84d7d5fb7fdcaadd691b48011efb4bfc2ee67555e5133a294a418cca1a0c85476c
diff --git a/dev-libs/fribidi/fribidi-1.0.11.ebuild b/dev-libs/fribidi/fribidi-1.0.11.ebuild
new file mode 100644
index 000000000000..2022757529b3
--- /dev/null
+++ b/dev-libs/fribidi/fribidi-1.0.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+DESCRIPTION="A free implementation of the unicode bidirectional algorithm"
+HOMEPAGE="https://fribidi.org/"
+SRC_URI="https://github.com/fribidi/fribidi/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddeprecated=true
+ $(meson_native_use_bool doc docs)
+ -Dbin=true
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}