summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-10-22 02:15:25 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-10-22 02:15:25 +0200
commit6e531dc75208175273f93c05e404ba7b6ed01285 (patch)
tree81cf288cd8c858e7af61d9e150b6e7ae573d03e7
parentnet-libs/gloox: Drop back to ~arch, USE=gnutls broken (diff)
downloadgentoo-6e531dc75208175273f93c05e404ba7b6ed01285.tar.gz
gentoo-6e531dc75208175273f93c05e404ba7b6ed01285.tar.bz2
gentoo-6e531dc75208175273f93c05e404ba7b6ed01285.zip
net-print/hplip-plugin: Version bump to 3.17.10
Package-Manager: Portage-2.3.12, Repoman-2.3.3
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.17.10.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 0cc7f8f64884..92f157b9b882 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,2 +1,3 @@
DIST hplip-3.16.3-plugin.run 2084271 SHA256 b7edef2a1c5c0a5e001deb4a18c0ef7202e653596e97144b8908ae093818070f SHA512 2ae8aeb40c2604a2c6b9725700f9addf7a82e819d603631158a5d5feac931248e53e7533178100df1fc12b0dc2340cb3ae0d85f145cd023a311f77bbe67e7c7f WHIRLPOOL 928117f862030eca9c3e5813eb8c4db66570923695b0c7af17df1992f339d2478f42af67ca0e0eb8cfa1d7425b522082fde3b8c829c3f5167e1ec503c95a986b
+DIST hplip-3.17.10-plugin.run 2062947 SHA256 2fd26f6d5b437a4f1aa9f560e816ce094aea73becdf2f2b976ef46406d1b551d SHA512 98eef413b122527c4a7860b621baf11c04ec9d7f4e43ce4f36e7822a633c64b3d98cbc86cd7d305c74d9a49a4159ebd7280d652e1ba430cad4cc70f66d23ee07 WHIRLPOOL d087e7f857f8bc0a7a0b4f44f07ca15feaff6847cd719a2cb48240dd3aca7df93932eef7a849598ad313b4373e9f50b61bf3c0846c64d1002f1cfd9470a27717
DIST hplip-3.17.9-plugin.run 2059585 SHA256 98f717266340baa15e0385dc4928cc9c127a9403b72749f4899657cef8dfe883 SHA512 a7a9ee8b7edda3641b5c3aa403570aad72ce9cd42cdd4c64904a0be409cefa838712390c7f535482028ac2d494c711baef77f2f601835b01591fa673272c01ba WHIRLPOOL e6615652382d11ddbe646b793d1f5aff61872ab4f30925855be66faa4d8ebace113a43e369e1b4d199bb65d3bd0315de32cd49d264c52f6d47e7f17990f0263f
diff --git a/net-print/hplip-plugin/hplip-plugin-3.17.10.ebuild b/net-print/hplip-plugin/hplip-plugin-3.17.10.ebuild
new file mode 100644
index 000000000000..8617df53c8dc
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.17.10.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit udev unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="http://hplipopensource.com/hplip-web/index.html"
+#SRC_URI="http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-${PV}-plugin.run"
+SRC_URI="http://hplipopensource.com/hplip-web/plugin/hplip-${PV}-plugin.run"
+
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PRESTRIPPED="
+ /usr/share/hplip/fax/plugins/fax_marvell.so
+ /usr/share/hplip/prnt/plugins/hbpl1.so
+ /usr/share/hplip/prnt/plugins/lj.so
+ /usr/share/hplip/scan/plugins/bb_escl.so
+ /usr/share/hplip/scan/plugins/bb_marvell.so
+ /usr/share/hplip/scan/plugins/bb_soapht.so
+ /usr/share/hplip/scan/plugins/bb_soap.so
+"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack_makeself "hplip-${PV}-plugin.run"
+}
+
+src_install() {
+ local hplip_arch=$(use amd64 && echo 'x86_64' || echo 'x86_32')
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ fax_*) plugin_type=fax ;;
+ bb_*) plugin_type=scan ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ mkdir -p "${ED}/var/lib/hp/"
+ cat >> "${ED}/var/lib/hp/hplip.state" <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}