summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-02-15 16:41:10 -0500
committerBrian Evans <grknight@gentoo.org>2019-02-15 16:41:10 -0500
commit6f00392fa62e299259ba2b88e92ce42e49bcfaa6 (patch)
treeba3a59f391ecf13c43f02287cad193b142893ab5
parentapp-emulation/open-vm-tools: remove old patches (diff)
downloadgentoo-6f00392fa62e299259ba2b88e92ce42e49bcfaa6.tar.gz
gentoo-6f00392fa62e299259ba2b88e92ce42e49bcfaa6.tar.bz2
gentoo-6f00392fa62e299259ba2b88e92ce42e49bcfaa6.zip
sys-cluster/csync2: Revbump for upstream source change and dependencies
Non-maintainer commit Bug: https://bugs.gentoo.org/show_bug.cgi?id=666070 Closes: https://bugs.gentoo.org/show_bug.cgi?id=673078 Signed-off-by: Brian Evans <grknight@gentoo.org>
-rw-r--r--sys-cluster/csync2/Manifest1
-rw-r--r--sys-cluster/csync2/csync2-2.0-r2.ebuild (renamed from sys-cluster/csync2/csync2-2.0-r1.ebuild)20
2 files changed, 15 insertions, 6 deletions
diff --git a/sys-cluster/csync2/Manifest b/sys-cluster/csync2/Manifest
index 41f1ba82409d..84048b643a72 100644
--- a/sys-cluster/csync2/Manifest
+++ b/sys-cluster/csync2/Manifest
@@ -1 +1,2 @@
+DIST csync2-2.0-github.tar.gz 108299 BLAKE2B ec06cf1284adfe63abd6c329deb4e53474d8f97998e4e6f7f6404321a6970f783d38e9feb46c02925c947834227516d40c928a457d2b43bd2b353ab3385fd150 SHA512 7555e2d958d6213e29cfa8b3b7415eea9a9868036865c519d724ae404006d913fba4aeeb61a916d3fc95669a6ca12160d4f52dc7d15bd59403e8a7de50ee8094
DIST csync2-2.0.tar.gz 411013 BLAKE2B b5c3da3a46168f8b9835e349a8d56070cd0e5aef3b951ba1cfe7e958f6c830336141a2d1eca6a2485d23f745b9ae907d46282aa8cc3078a60582dac8c3f286b8 SHA512 f91fd222f67affe9634471d341b43ff67854a6ed25b620301a454e98a79a9fb80b2a66eb8713546758fd08300d52751e5ca7472c696daa20ee11779b87a830f8
diff --git a/sys-cluster/csync2/csync2-2.0-r1.ebuild b/sys-cluster/csync2/csync2-2.0-r2.ebuild
index 29663af4b3f1..f66a66ac0db5 100644
--- a/sys-cluster/csync2/csync2-2.0-r1.ebuild
+++ b/sys-cluster/csync2/csync2-2.0-r2.ebuild
@@ -1,11 +1,13 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit autotools
DESCRIPTION="Cluster synchronization tool"
-HOMEPAGE="http://oss.linbit.com/csync2/"
-SRC_URI="http://oss.linbit.com/${PN}/${P}.tar.gz"
+HOMEPAGE="https://github.com/LINBIT/csync2"
+SRC_URI="https://github.com/LINBIT/${PN}/archive/${P}.tar.gz -> ${P}-github.tar.gz"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~arm ~x86"
@@ -13,7 +15,7 @@ KEYWORDS="~amd64 ~arm ~x86"
IUSE="mysql postgres sqlite ssl xinetd"
RDEPEND=">=net-libs/librsync-0.9.5
- mysql? ( virtual/mysql )
+ mysql? ( dev-db/mysql-connector-c:0= )
postgres? ( dev-db/postgresql:= )
sqlite? ( >=dev-db/sqlite-3.0 )
ssl? ( >=net-libs/gnutls-2.7.3 )
@@ -24,9 +26,15 @@ DEPEND="${RDEPEND}
REQUIRED_USE="|| ( mysql postgres sqlite )"
SLOT="0"
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf \
- --docdir=/usr/share/doc/${P} \
--localstatedir=/var \
--sysconfdir=/etc/csync2 \
$(use_enable mysql) \