summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-03 21:49:13 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-03 22:03:37 +0200
commit6f3ce9bb87dae9eca368a404c9cd30f13ffd2b21 (patch)
tree4988abeb493baadd1f4a4da46dfe8ed89dcaed56
parentdev-python/pytest-shutil: Block py2 pytest-virtualenv (diff)
downloadgentoo-6f3ce9bb87dae9eca368a404c9cd30f13ffd2b21.tar.gz
gentoo-6f3ce9bb87dae9eca368a404c9cd30f13ffd2b21.tar.bz2
gentoo-6f3ce9bb87dae9eca368a404c9cd30f13ffd2b21.zip
dev-python/pytest-fixture-config: Block py2 pytest-virtualenv
Since dev-python/pytest normally loads all plugins, and PMs don't necessarily enforce dependencies of these that are not part of @world, it is possible to break their depgraph and break pytest on py2.7 completely. Add a blocker to make that harder. Closes: https://bugs.gentoo.org/720828 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r1.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r1.ebuild b/dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r1.ebuild
index 123812aa6d1..83b350fe07a 100644
--- a/dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r1.ebuild
+++ b/dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r1.ebuild
@@ -17,6 +17,10 @@ KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ~ppc ppc64 ~s390 sparc x86"
RDEPEND="
dev-python/pytest[${PYTHON_USEDEP}]
"
+# block pytest plugins that will be broken by the upgrade
+RDEPEND+="
+ !<dev-python/pytest-virtualenv-1.7.0-r1[python_targets_python2_7(-)]
+"
BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/setuptools-git[${PYTHON_USEDEP}]