summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-01-29 12:04:15 -0500
committerAnthony G. Basile <blueness@gentoo.org>2017-01-29 13:39:42 -0500
commit707768839a4b285a0be7f7c5515db84b42615122 (patch)
tree4476d854df43d0c6801a0ce7de28308a3505a3b9
parentgames-misc/sex: dropped ~x86-freebsd (diff)
downloadgentoo-707768839a4b285a0be7f7c5515db84b42615122.tar.gz
gentoo-707768839a4b285a0be7f7c5515db84b42615122.tar.bz2
gentoo-707768839a4b285a0be7f7c5515db84b42615122.zip
dev-libs/xapian: version bump to 1.4.3
Package-Manager: portage-2.3.3
-rw-r--r--dev-libs/xapian/Manifest1
-rw-r--r--dev-libs/xapian/xapian-1.4.3.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-libs/xapian/Manifest b/dev-libs/xapian/Manifest
index df0ed80eb836..17c55fdfb790 100644
--- a/dev-libs/xapian/Manifest
+++ b/dev-libs/xapian/Manifest
@@ -2,3 +2,4 @@ DIST xapian-core-1.2.22.tar.xz 3204096 SHA256 269b87ca3faf79d444e8bb82ed58a96f19
DIST xapian-core-1.2.24.tar.xz 3210192 SHA256 57a82717ba07e9777958b6ef48d94b81ea41ac4c74d544f74da597fab1e1f87b SHA512 1f8ae5848f94b5f0bee03024f12ae8c336b6d85e58f7b36e885fe604f9fb962c0525e1f44e6cfcd183e811226c61b23f0f2fcc35c7d2e63544b19347a0f96c80 WHIRLPOOL fef6db7f393d4563828e1650eecd02e30d37f5837042b6a8992cfddb962593675f9c3af4eb5d387db71f99468235905bdbe5666f91975b260cb649fd422425ae
DIST xapian-core-1.4.1.tar.xz 2793644 SHA256 c5f2534de73c067ac19eed6d6bec65b7b2c1be00131c8867da9e1dfa8bce70eb SHA512 b1bb28e78609565a2690ef147231237dcfdd3b7f6108964962260a2678ab6483a4e1f2a795d2a3595e9d0a1567d6223b0cbe6ed9d95a455437f7f5c40e49389d WHIRLPOOL ebca0a39a1f60aa1dbe09d3e3ccb7d53a23f0ef78c0ed6b7723d1c73079426003c59388ec9138b27f30d84ed5169c4d88df5de771e85efeccaec7228b28dbbc1
DIST xapian-core-1.4.2.tar.xz 2799492 SHA256 aec2c4352998127a2f2316218bf70f48cef0a466a87af3939f5f547c5246e1ce SHA512 2ea189068837c295b9c2065f06bdf5c4078114c0a07d5ea94f396baab806c038e0e8e8ae6b7702322255b2bc8a84025c0c03d20b87dd3de7c6854666b1c753a3 WHIRLPOOL 9cda96c0317dfe9206155815ba66c20780ad2c40500710f9fd66848f76f9893d35459b0c29dbacdbdc8426ee0dcdf63524b299a82146a01ef58bcae6c22e5201
+DIST xapian-core-1.4.3.tar.xz 2805964 SHA256 7d5295511ca2de70463a29e75f6a2393df5dc1485bf33074b778c66e1721e475 SHA512 f8da535c298a07828998d12a10c049eadcfbc36adf93c0744565bd6b4c7c49f4df3f402e50fb4abbe9384ccaeaf3499cce53bea90bf57d677ee5124e8621c74c WHIRLPOOL c36c97018ca7488229494583c42faea49a85d3b956947d7f0c0a106a1f870ef5458d45a37ddad7a96157a71d3bea0403f3c10a0c36f931c0ee0395e18c34fd1c
diff --git a/dev-libs/xapian/xapian-1.4.3.ebuild b/dev-libs/xapian/xapian-1.4.3.ebuild
new file mode 100644
index 000000000000..9ead7d81d669
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.4.3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit eutils multilib-minimal
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/30" # ABI version of libxapian.so
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +glass +chert +inmemory"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="inmemory? ( chert )"
+
+S="${WORKDIR}/${MY_P}"
+
+multilib_src_configure() {
+ local myconf=""
+
+ if use cpu_flags_x86_sse2; then
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use cpu_flags_x86_sse; then
+ myconf="${myconf} --enable-sse=sse"
+ else
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use glass || myconf="${myconf} --disable-backend-glass"
+ use chert || myconf="${myconf} --disable-backend-chert"
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+
+ myconf="${myconf} --enable-backend-remote --program-suffix="
+
+ ECONF_SOURCE=${S} econf $myconf
+}
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/xapian/postingsource.h
+ /usr/include/xapian/attributes.h
+ /usr/include/xapian/valuesetmatchdecider.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/types.h
+ /usr/include/xapian/positioniterator.h
+ /usr/include/xapian/registry.h
+)
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ # bug #573466
+ ln -sf "${D}usr/bin/xapian-config" "${D}usr/bin/xapian-config-1.3"
+
+ use doc || rm -rf "${D}usr/share/doc/xapian-core-${PV}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+
+ prune_libtool_files --all
+}
+
+multilib_src_test() {
+ emake check VALGRIND=
+}