summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-08-16 23:54:31 +0300
committerMart Raudsepp <leio@gentoo.org>2020-08-17 00:01:23 +0300
commit708dc351c4d23eb2b5ffaf7d01d2318f35ca59b5 (patch)
tree5f53444bf32a9e9689d464fd43e8dd618745197d
parentgui-libs/tepl: bump to 4.4.0 (diff)
downloadgentoo-708dc351c4d23eb2b5ffaf7d01d2318f35ca59b5.tar.gz
gentoo-708dc351c4d23eb2b5ffaf7d01d2318f35ca59b5.tar.bz2
gentoo-708dc351c4d23eb2b5ffaf7d01d2318f35ca59b5.zip
app-editors/gedit: bump to 3.36.2
Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--app-editors/gedit/Manifest1
-rw-r--r--app-editors/gedit/files/3.36-make-gspell-optional.patch62
-rw-r--r--app-editors/gedit/files/3.36-make-python-optional.patch90
-rw-r--r--app-editors/gedit/files/restore-overlay-scrollbars.patch26
-rw-r--r--app-editors/gedit/gedit-3.36.2.ebuild105
5 files changed, 284 insertions, 0 deletions
diff --git a/app-editors/gedit/Manifest b/app-editors/gedit/Manifest
index 20b7ca30105d..a226fc44cd02 100644
--- a/app-editors/gedit/Manifest
+++ b/app-editors/gedit/Manifest
@@ -1 +1,2 @@
DIST gedit-3.34.1.tar.xz 14797588 BLAKE2B 8dfaac4660575d67e3f8396dfed675a737fc69bc2b34866ee467a3464a338240133cab8d067db7b87fdc129f06a2450b91f4e0f70a73912d4a274cca980196d6 SHA512 22968c678a2f7ecf062f490d5eedc97aaa53b15932db801ea83eb336f01f41e7a6037a85508a40164f38dee406f8db097b7ef6f1481ab44ea82668766d24966d
+DIST gedit-3.36.2.tar.xz 14770004 BLAKE2B 505c01aa60e64e418a09c9fbd0c397a487c612117c3068e35a41b075a8d5440cf85daf6e011eeacee7b228306342cc5c4a3dc1af24d52583c9a896531355f6d0 SHA512 20c3592aaf08ad4a5842b14ecb1eb0c9ddbef190412dc3f70b60bbf6125c9c4791a48260c89402ce4773720ae65b36fab510f9d1e104f548e243d11bc49279b5
diff --git a/app-editors/gedit/files/3.36-make-gspell-optional.patch b/app-editors/gedit/files/3.36-make-gspell-optional.patch
new file mode 100644
index 000000000000..e891f98f0c00
--- /dev/null
+++ b/app-editors/gedit/files/3.36-make-gspell-optional.patch
@@ -0,0 +1,62 @@
+From d622460b08c7c13ce8e0c23e3afcbd1e4c65d019 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 16 Aug 2020 23:20:31 +0300
+Subject: [PATCH] build: Make gspell optional
+
+---
+ meson.build | 3 ++-
+ meson_options.txt | 4 ++++
+ plugins/spell/meson.build | 4 ++++
+ 3 files changed, 10 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index edb2896a6..b8707f33d 100644
+--- a/meson.build
++++ b/meson.build
+@@ -63,7 +63,7 @@ libpeas_gtk_dep = dependency('libpeas-gtk-1.0', version: libpeas_req)
+
+ libgd_dep = libgd_subproject.get_variable('libgd_dep')
+
+-gspell_dep = dependency('gspell-1', version: '>= 1.0', required: true)
++gspell_dep = dependency('gspell-1', version: '>= 1.0', required: get_option('spell'))
+ x11_dep = dependency('x11', required: false)
+
+ introspection_dep = dependency('gobject-introspection-1.0', required: false)
+@@ -154,6 +154,7 @@ summary = [
+ ' User documentation: @0@'.format(get_option('user_documentation')),
+ ' GObject Introspection: @0@'.format(generate_gir),
+ ' Vala API: @0@'.format(generate_vapi),
++ ' Spell checker plugin: @0@'.format(gspell_dep.found().to_string()),
+ '',
+ ]
+ message('\n'.join(summary))
+diff --git a/meson_options.txt b/meson_options.txt
+index d0cbf0720..03e07244e 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -10,6 +10,10 @@ option('gtk_doc',
+ type: 'boolean', value: false,
+ description: 'Build API reference for plugins (requires gtk-doc)')
+
++option('spell',
++ type: 'feature', value: 'enabled',
++ description: 'Build spell checking plugin')
++
+ # This option exists for the developers, to speed up the install.
+ option('user_documentation',
+ type: 'boolean', value: true,
+diff --git a/plugins/spell/meson.build b/plugins/spell/meson.build
+index 8ce7634b7..cccb42fc1 100644
+--- a/plugins/spell/meson.build
++++ b/plugins/spell/meson.build
+@@ -1,3 +1,7 @@
++if not gspell_dep.found()
++ subdir_done()
++endif
++
+ libspell_sources = files(
+ 'gedit-spell-app-activatable.c',
+ 'gedit-spell-plugin.c',
+--
+2.20.1
+
diff --git a/app-editors/gedit/files/3.36-make-python-optional.patch b/app-editors/gedit/files/3.36-make-python-optional.patch
new file mode 100644
index 000000000000..c27a0551f00b
--- /dev/null
+++ b/app-editors/gedit/files/3.36-make-python-optional.patch
@@ -0,0 +1,90 @@
+From d082ef03b9f545980ab77e6c0a20d5bf4893be69 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 16 Aug 2020 23:34:42 +0300
+Subject: [PATCH] build: Make python optional
+
+---
+ gedit/meson.build | 2 ++
+ meson.build | 4 +++-
+ meson_options.txt | 4 ++++
+ plugins/meson.build | 11 +++++++----
+ 4 files changed, 16 insertions(+), 5 deletions(-)
+
+diff --git a/gedit/meson.build b/gedit/meson.build
+index 075c001b2..174deba04 100644
+--- a/gedit/meson.build
++++ b/gedit/meson.build
+@@ -214,6 +214,7 @@ if generate_gir == true
+ install_dir_typelib: join_paths(pkglibdir, 'girepository-1.0'),
+ )
+
++if get_option('python')
+ python3.install_sources(
+ 'Gedit.py',
+ subdir: join_paths(
+@@ -221,6 +222,7 @@ if generate_gir == true
+ 'overrides',
+ )
+ )
++endif
+
+ libgedit_dep_sources += [
+ libgedit_gir,
+diff --git a/meson.build b/meson.build
+index b8707f33d..4e40833ec 100644
+--- a/meson.build
++++ b/meson.build
+@@ -69,7 +69,9 @@ x11_dep = dependency('x11', required: false)
+ introspection_dep = dependency('gobject-introspection-1.0', required: false)
+ vapigen_dep = dependency('vapigen', version: '>= 0.25.1', required: false)
+
+-python3 = python.find_installation('python3')
++if get_option('python')
++ python3 = python.find_installation('python3')
++endif
+
+ build_checkupdate_plugin = host_machine.system() == 'windows'
+ if build_checkupdate_plugin
+diff --git a/meson_options.txt b/meson_options.txt
+index 03e07244e..cdcec6165 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -10,6 +10,10 @@ option('gtk_doc',
+ type: 'boolean', value: false,
+ description: 'Build API reference for plugins (requires gtk-doc)')
+
++option('python',
++ type: 'boolean', value: true,
++ description: 'Install GIR python overrides and python plugins')
++
+ option('spell',
+ type: 'feature', value: 'enabled',
+ description: 'Build spell checking plugin')
+diff --git a/plugins/meson.build b/plugins/meson.build
+index a9167f8d6..97f1b1765 100644
+--- a/plugins/meson.build
++++ b/plugins/meson.build
+@@ -20,13 +20,16 @@ if build_checkupdate_plugin
+ endif
+
+ subdir('docinfo')
+-subdir('externaltools')
+ subdir('filebrowser')
+ subdir('modelines')
+-subdir('pythonconsole')
+ subdir('quickhighlight')
+-subdir('quickopen')
+-subdir('snippets')
+ subdir('sort')
+ subdir('spell')
+ subdir('time')
++
++if get_option('python')
++ subdir('externaltools')
++ subdir('pythonconsole')
++ subdir('quickopen')
++ subdir('snippets')
++endif
+--
+2.20.1
+
diff --git a/app-editors/gedit/files/restore-overlay-scrollbars.patch b/app-editors/gedit/files/restore-overlay-scrollbars.patch
new file mode 100644
index 000000000000..55a353a796bf
--- /dev/null
+++ b/app-editors/gedit/files/restore-overlay-scrollbars.patch
@@ -0,0 +1,26 @@
+From 189ee4514107e70a62d44766f8ca39d815d48581 Mon Sep 17 00:00:00 2001
+From: Michael Catanzaro <mcatanzaro@gnome.org>
+Date: Fri, 20 Mar 2020 11:32:59 -0500
+Subject: [PATCH] Revert "ViewFrame: disable overlay scrolling for the
+ GtkScrolledWindow"
+
+This reverts commit 5e0909c19f267b4023131881fac89c58a2a17453.
+---
+ gedit/resources/ui/gedit-view-frame.ui | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/gedit/resources/ui/gedit-view-frame.ui b/gedit/resources/ui/gedit-view-frame.ui
+index ebf70b013..4c783c711 100644
+--- a/gedit/resources/ui/gedit-view-frame.ui
++++ b/gedit/resources/ui/gedit-view-frame.ui
+@@ -11,7 +11,6 @@
+ <property name="visible">True</property>
+ <property name="hexpand">True</property>
+ <property name="vexpand">True</property>
+- <property name="overlay_scrolling">False</property>
+ <child>
+ <object class="GeditView" id="view">
+ <property name="visible">True</property>
+--
+2.25.1
+
diff --git a/app-editors/gedit/gedit-3.36.2.ebuild b/app-editors/gedit/gedit-3.36.2.ebuild
new file mode 100644
index 000000000000..d1b13e1d463b
--- /dev/null
+++ b/app-editors/gedit/gedit-3.36.2.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+VALA_MIN_API_VERSION="0.26"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="+introspection +python gtk-doc spell vala"
+REQUIRED_USE="python? ( introspection ${PYTHON_REQUIRED_USE} )"
+
+KEYWORDS="~amd64 ~x86"
+
+# X libs are not needed for OSX (aqua)
+DEPEND="
+ >=dev-libs/glib-2.52:2
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=x11-libs/gtk+-3.22.0:3[introspection?]
+ >=x11-libs/gtksourceview-4.0.2:4[introspection?]
+ >=gui-libs/tepl-4.4:4
+ x11-libs/libX11
+
+ spell? ( >=app-text/gspell-0.2.5:0= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+ gnome-base/gsettings-desktop-schemas
+ gnome-base/gvfs
+"
+BDEPEND="
+ ${vala_depend}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1 )
+ dev-util/itstool
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+"
+PATCHES=(
+ # Don't force off overlay scrollbars for dubious reasons that GNOME designers heavily
+ # disagree with; those wanting them off in general would set that globally for gtk
+ "${FILESDIR}"/restore-overlay-scrollbars.patch
+ # Make gspell and python optional
+ "${FILESDIR}"/3.36-make-gspell-optional.patch
+ "${FILESDIR}"/3.36-make-python-optional.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection)
+ $(meson_use vala vapi)
+ $(meson_use python)
+ $(meson_use gtk-doc gtk_doc)
+ -Duser_documentation=true
+ $(meson_feature spell)
+ )
+ meson_src_configure
+}
+
+# Only appdata and desktop file validation in v3.32.2
+src_test() { :; }
+
+src_install() {
+ meson_src_install
+ if use python; then
+ python_optimize
+ python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}