summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2018-06-29 18:11:10 -0500
committerErik Mackdanz <stasibear@gentoo.org>2018-07-01 12:10:39 -0500
commit7161056c6d309856b19fc23ede5e9995ec8ea910 (patch)
tree2eda73e86e378532f88ce4d08a148d4690f24677
parentapp-emulation/libvirt: add use-constraint (diff)
downloadgentoo-7161056c6d309856b19fc23ede5e9995ec8ea910.tar.gz
gentoo-7161056c6d309856b19fc23ede5e9995ec8ea910.tar.bz2
gentoo-7161056c6d309856b19fc23ede5e9995ec8ea910.zip
app-emulation/lxd: Bump to version 3.2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--app-emulation/lxd/Manifest1
-rw-r--r--app-emulation/lxd/files/de-translation-newline.patch20
-rw-r--r--app-emulation/lxd/lxd-3.2.ebuild181
3 files changed, 202 insertions, 0 deletions
diff --git a/app-emulation/lxd/Manifest b/app-emulation/lxd/Manifest
index 653ac15bf855..4e3d4b1ae5dc 100644
--- a/app-emulation/lxd/Manifest
+++ b/app-emulation/lxd/Manifest
@@ -97,3 +97,4 @@ DIST github.com-syndtr-gocapability-db04d3cc01c8b54962a58ec7e491717d06cfcc16.tar
DIST lxd-2.21.tar.gz 882352 BLAKE2B 80542bcc03c05667ee0207dfbfd2bf41c5a6ef69178aec06ad62fe3521ed012ed9b82c68c0254e0299e8e1dfd274a0622f32bde730480a950ab6ba15ddae5f4b SHA512 9a8ec3a97e4c861a80311dbdecbf5a485c0af85d6ba6b20680ca17e6ac877de3f27cfdcf0a111ba0db2b7c562dfe2f41336b562b7c13350c4543505b3c17357e
DIST lxd-3.0.0.tar.gz 1152282 BLAKE2B e84808c626064ba6985c08119905510c2a9659edca09887a55bfe006eaba4a624215d48978e18ab642f34e54e58fc1d2e04303c9db73c332df8c5d29568fb779 SHA512 b4de839d26080f2b14b1f6f04a92b000e1abaa0712377528b87ca79e01b9c46b7b6c7f7ce5365f37f7a0ae8a2459bcdc6010fcb2a238d78e34d090750ae070f3
DIST lxd-3.1.tar.gz 27979442 BLAKE2B 0b74e3f76a7ab835b042b52b469a6fe11e7077d567e0658d13fab2192fd25d99518d65ba319c981a2e4677319e280cccae26f70ef99e9911264dc028ca5628fd SHA512 61f64d08dd80f7f676f386912f4dfc0d0af38cce0287de7865123b9da667b54ab91d22b76ffe03480e04ae0fbd8dc837d7d519d0e34409377c3d7e6624bf636c
+DIST lxd-3.2.tar.gz 28183660 BLAKE2B 9aabc9fd0bd66d3b4e0178448a65ca39c69e4e7a14d01309e0e023501de1c17b2b7887a9da5b84fcfde27db3f521cce3451beace9955232da9bd5e5136bc0043 SHA512 82c37e87d75e328a29b1f2876a24fedec43a253bb72f3ea55fa9cdb928d11947eda723a01e758f90ef77ed4492f86ec6dd5f1f88240d05e771d926dfdc9888fb
diff --git a/app-emulation/lxd/files/de-translation-newline.patch b/app-emulation/lxd/files/de-translation-newline.patch
new file mode 100644
index 000000000000..9ef55ab2f0ee
--- /dev/null
+++ b/app-emulation/lxd/files/de-translation-newline.patch
@@ -0,0 +1,20 @@
+--- /po/de.po 2018-06-27 19:57:56.759130047 -0500
++++ /po/de.po 2018-06-27 20:01:09.694634346 -0500
+@@ -65,7 +65,7 @@
+ "### type: custom\n"
+ "### used_by: []\n"
+ "### config:\n"
+-"### size: \"61203283968\""
++"### size: \"61203283968\"\n"
+ msgstr ""
+ "### Dies ist eine Darstellung der Eigenschaften eines Abbildes in yaml.\n"
+ "### Jede Zeile die mit '# beginnt wird ignoriert.\n"
+@@ -167,7 +167,7 @@
+ "###\n"
+ "### Each property is represented by a single line:\n"
+ "### An example would be:\n"
+-"### description: My custom image"
++"### description: My custom image\n"
+ msgstr ""
+ "### Dies ist eine Darstellung der Eigenschaften eines Images in yaml.\n"
+ "### Jede Zeile die mit '# beginnt wird ignoriert.\n"
diff --git a/app-emulation/lxd/lxd-3.2.ebuild b/app-emulation/lxd/lxd-3.2.ebuild
new file mode 100644
index 000000000000..1f0f3db33a23
--- /dev/null
+++ b/app-emulation/lxd/lxd-3.2.ebuild
@@ -0,0 +1,181 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Fast, dense and secure container management"
+HOMEPAGE="https://linuxcontainers.org/lxd/introduction/"
+
+LICENSE="Apache-2.0 BSD BSD-2 LGPL-3 MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="+daemon +ipv6 +dnsmasq nls test"
+
+inherit bash-completion-r1 linux-info systemd user
+
+SRC_URI="https://linuxcontainers.org/downloads/${PN}/${P}.tar.gz"
+
+DEPEND="
+ >=dev-lang/go-1.9.4
+ dev-libs/protobuf
+ nls? ( sys-devel/gettext )
+ test? (
+ app-misc/jq
+ net-misc/curl
+ sys-devel/gettext
+ )
+"
+
+RDEPEND="
+ daemon? (
+ app-arch/xz-utils
+ >=app-emulation/lxc-2.0.7[seccomp]
+ dnsmasq? (
+ net-dns/dnsmasq[dhcp,ipv6?]
+ )
+ net-misc/rsync[xattr]
+ sys-apps/iproute2[ipv6?]
+ sys-fs/squashfs-tools
+ virtual/acl
+ )
+"
+
+CONFIG_CHECK="
+ ~BRIDGE
+ ~DUMMY
+ ~IP6_NF_NAT
+ ~IP6_NF_TARGET_MASQUERADE
+ ~IPV6
+ ~IP_NF_NAT
+ ~IP_NF_TARGET_MASQUERADE
+ ~MACVLAN
+ ~NETFILTER_XT_MATCH_COMMENT
+ ~NET_IPGRE
+ ~NET_IPGRE_DEMUX
+ ~NET_IPIP
+ ~NF_NAT_MASQUERADE_IPV4
+ ~NF_NAT_MASQUERADE_IPV6
+ ~VXLAN
+"
+
+ERROR_BRIDGE="BRIDGE: needed for network commands"
+ERROR_DUMMY="DUMMY: needed for network commands"
+ERROR_IP6_NF_NAT="IP6_NF_NAT: needed for network commands"
+ERROR_IP6_NF_TARGET_MASQUERADE="IP6_NF_TARGET_MASQUERADE: needed for network commands"
+ERROR_IPV6="IPV6: needed for network commands"
+ERROR_IP_NF_NAT="IP_NF_NAT: needed for network commands"
+ERROR_IP_NF_TARGET_MASQUERADE="IP_NF_TARGET_MASQUERADE: needed for network commands"
+ERROR_MACVLAN="MACVLAN: needed for network commands"
+ERROR_NETFILTER_XT_MATCH_COMMENT="NETFILTER_XT_MATCH_COMMENT: needed for network commands"
+ERROR_NET_IPGRE="NET_IPGRE: needed for network commands"
+ERROR_NET_IPGRE_DEMUX="NET_IPGRE_DEMUX: needed for network commands"
+ERROR_NET_IPIP="NET_IPIP: needed for network commands"
+ERROR_NF_NAT_MASQUERADE_IPV4="NF_NAT_MASQUERADE_IPV4: needed for network commands"
+ERROR_NF_NAT_MASQUERADE_IPV6="NF_NAT_MASQUERADE_IPV6: needed for network commands"
+ERROR_VXLAN="VXLAN: needed for network commands"
+
+EGO_PN="github.com/lxc/lxd"
+
+PATCHES=(
+ "${FILESDIR}/ja-translation-newline.patch" # https://github.com/lxc/lxd/pull/4572
+ "${FILESDIR}/de-translation-newline.patch"
+)
+
+# LXD tarball is packaged with a nice "dist" folder containing all dependencies
+# that were vendored by upstream at release time. That saves us the trouble of
+# vendoring the dependencies ourselves. This is why there was this drastic drop
+# in ebuild complexity compared to pre 3.0.0-r2 ebuilds.
+src_compile() {
+ export GOPATH="${S}/dist"
+
+ # We don't use the Makefile here because it builds targets with the
+ # assumption that `pwd` is in a deep gopath namespace, which we're not.
+ # It's simpler to manually call "go install" than patching the Makefile.
+ #
+ # ABOUT "-tags libsqlite3": we used to link to the system's sqlite3 library
+ # but since v3.0.0, LXD depends on github.com/CanonicalLtd/dqlite which
+ # at the time of this writing, depends on patched version of sqlite with
+ # replication capabilities added. We don't have that patch in dev-db/sqlite.
+ # Therefore, we let LXD use its own private copy of sqlite.
+ go install -v -x ${EGO_PN}/lxc || die "Failed to build the client"
+
+ if use daemon; then
+ go install -v -x ${EGO_PN}/fuidshift || die "Failed to build fuidshift"
+ go install -v -x ${EGO_PN}/lxd || die "Failed to build the daemon"
+ fi
+
+ use nls && emake build-mo
+}
+
+src_test() {
+ if use daemon; then
+ export GOPATH="${S}/dist"
+ # This is mostly a copy/paste from the Makefile's "check" rule, but
+ # patching the Makefile to work in a non "fully-qualified" go namespace
+ # was more complicated than this modest copy/paste.
+ # Also: sorry, for now a network connection is needed to run tests.
+ # Will properly bundle test dependencies later.
+ go get -v -x github.com/rogpeppe/godeps
+ go get -v -x github.com/remyoudompheng/go-misc/deadcode
+ go get -v -x github.com/golang/lint/golint
+ go test -v ${EGO_PN}/lxd
+ else
+ einfo "No tests to run for client-only builds"
+ fi
+}
+
+src_install() {
+ local bindir="dist/bin"
+ dobin ${bindir}/lxc
+ if use daemon; then
+ dosbin ${bindir}/lxd
+ dobin ${bindir}/fuidshift
+ fi
+
+ if use nls; then
+ domo po/*.mo
+ fi
+
+ if use daemon; then
+ newinitd "${FILESDIR}"/${PN}.initd lxd
+ newconfd "${FILESDIR}"/${PN}.confd.1 lxd
+
+ systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
+ fi
+
+ newbashcomp scripts/bash/lxd-client lxc
+
+ dodoc AUTHORS README.md doc/*
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Consult https://wiki.gentoo.org/wiki/LXD for more information,"
+ einfo "including a Quick Start."
+
+ # The messaging below only applies to daemon installs
+ use daemon || return 0
+
+ # The control socket will be owned by (and writeable by) this group.
+ enewgroup lxd
+
+ # Ubuntu also defines an lxd user but it appears unused (the daemon
+ # must run as root)
+
+ einfo
+ einfo "Though not strictly required, some features are enabled at run-time"
+ einfo "when the relevant helper programs are detected:"
+ einfo "- sys-apps/apparmor"
+ einfo "- sys-fs/btrfs-progs"
+ einfo "- sys-fs/lvm2"
+ einfo "- sys-fs/lxcfs"
+ einfo "- sys-fs/zfs"
+ einfo "- sys-process/criu"
+ einfo
+ einfo "Since these features can't be disabled at build-time they are"
+ einfo "not USE-conditional."
+ einfo
+ einfo "Networks with bridge.mode=fan are unsupported due to requiring"
+ einfo "a patched kernel and iproute2."
+}