summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-16 18:07:28 +0100
committerSam James <sam@gentoo.org>2022-06-16 18:07:46 +0100
commit71868b05b9ec0054659eaea73c0695695d804ddb (patch)
treeb8ff9d15792ccf22215eb71e30673e973855fd66
parentmedia-tv/kodi: Updated bundled libraries (diff)
downloadgentoo-71868b05b9ec0054659eaea73c0695695d804ddb.tar.gz
gentoo-71868b05b9ec0054659eaea73c0695695d804ddb.tar.bz2
gentoo-71868b05b9ec0054659eaea73c0695695d804ddb.zip
sys-apps/kbd: add 2.5.1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/kbd/Manifest1
-rw-r--r--sys-apps/kbd/kbd-2.5.1.ebuild83
-rw-r--r--sys-apps/kbd/kbd-9999.ebuild25
3 files changed, 88 insertions, 21 deletions
diff --git a/sys-apps/kbd/Manifest b/sys-apps/kbd/Manifest
index 01c0afbdec91..5ef0f4c45812 100644
--- a/sys-apps/kbd/Manifest
+++ b/sys-apps/kbd/Manifest
@@ -1,2 +1,3 @@
DIST kbd-2.4.0.tar.xz 1120700 BLAKE2B aa5fc1067d3414b9fa18f35dd81dcc050cdf10bd8692221b6e5304e94c4f90055386ce1f79d2bd092241f9ce15ffd36d5c00d1a15725166d16183f475be4a2e3 SHA512 c3823e40878ed4cb5b90edf753dba37a7fc3189b7b08a2e59a7830cac23a7a7daf31dedef1fcc130698c7508bc2a037c8ab54e749d0cdbf51756e346f2ed5abb
DIST kbd-2.5.0.tar.xz 1490112 BLAKE2B c123982d5c80fa3996f6328d7151a9dcc8c969e7beeb65e83204857b044355a3531dd1efe5634d844bc43f8d5715ec63e41120679a3d34888766ef7bf6014f2b SHA512 740c4c7b8a2729f5d0539399f691d4201dab97c6eec554b82cc8c80935e956072e9735a739f8f4febc9849c1e8d9d195318b1d0d4e10dce4d34b5fb6d84111d7
+DIST kbd-2.5.1.tar.xz 1491952 BLAKE2B aab4c3d78c28709bf562b54fe94c0533d5c33185e183bf3eb944f89147b250d9df9b30b64a06eb4742feafe8c05a6aa491a7f007b4d6d9077bc19a4628ba05ae SHA512 74855f486aff5fc2f93a6cb29460a590c94eac653b001574e1b4eb1300ea99dfed9222f9e5d1d3a05a112a6880591d5c44ed6e76b8a64edf744ecb0892f562d0
diff --git a/sys-apps/kbd/kbd-2.5.1.ebuild b/sys-apps/kbd/kbd-2.5.1.ebuild
new file mode 100644
index 000000000000..a8607b2c1f1d
--- /dev/null
+++ b/sys-apps/kbd/kbd-2.5.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/legionus/kbd.git https://git.kernel.org/pub/scm/linux/kernel/git/legion/kbd.git"
+ EGIT_BRANCH="master"
+else
+ if [[ $(ver_cut 3) -lt 90 ]] ; then
+ SRC_URI="https://www.kernel.org/pub/linux/utils/kbd/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ else
+ inherit autotools
+ SRC_URI="https://github.com/legionus/kbd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ fi
+fi
+
+DESCRIPTION="Keyboard and console utilities"
+HOMEPAGE="https://kbd-project.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls pam test"
+RESTRICT="!test? ( test )"
+
+# Testsuite's Makefile.am calls missing(!)
+# ... but this seems to be consistent with the autoconf docs?
+# Needs more investigation: https://www.gnu.org/software/autoconf/manual/autoconf-2.67/html_node/autom4te-Invocation.html
+QA_AM_MAINTAINER_MODE=".*--run autom4te --language=autotest.*"
+
+RDEPEND="
+ app-arch/gzip
+ pam? (
+ !app-misc/vlock
+ sys-libs/pam
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+"
+
+src_prepare() {
+ default
+
+ # Rename conflicting keymaps to have unique names, bug #293228
+ # See also https://github.com/legionus/kbd/issues/76.
+ pushd "${S}"/data/keymaps/i386 &> /dev/null || die
+ mv fgGIod/trf.map fgGIod/trf-fgGIod.map || die
+ mv olpc/es.map olpc/es-olpc.map || die
+ mv olpc/pt.map olpc/pt-olpc.map || die
+ mv qwerty/cz.map qwerty/cz-qwerty.map || die
+ popd &> /dev/null || die
+
+ if [[ ${PV} == 9999 ]] || [[ $(ver_cut 3) -ge 90 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-werror
+
+ $(use_enable nls)
+ $(use_enable pam vlock)
+ $(use_enable test tests)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc docs/doc/*.html
+
+ # USE="test" installs .la files
+ find "${ED}" -type f -name "*.la" -delete || die
+}
diff --git a/sys-apps/kbd/kbd-9999.ebuild b/sys-apps/kbd/kbd-9999.ebuild
index d0f3a2573fa7..a8607b2c1f1d 100644
--- a/sys-apps/kbd/kbd-9999.ebuild
+++ b/sys-apps/kbd/kbd-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} == 9999 ]] ; then
inherit autotools git-r3
@@ -43,24 +43,17 @@ BDEPEND="
test? ( dev-libs/check )
"
-src_unpack() {
- if [[ ${PV} == 9999 ]] ; then
- git-r3_src_unpack
- else
- default
- fi
-}
-
src_prepare() {
default
# Rename conflicting keymaps to have unique names, bug #293228
# See also https://github.com/legionus/kbd/issues/76.
- cd "${S}"/data/keymaps/i386 || die
+ pushd "${S}"/data/keymaps/i386 &> /dev/null || die
mv fgGIod/trf.map fgGIod/trf-fgGIod.map || die
mv olpc/es.map olpc/es-olpc.map || die
mv olpc/pt.map olpc/pt-olpc.map || die
mv qwerty/cz.map qwerty/cz-qwerty.map || die
+ popd &> /dev/null || die
if [[ ${PV} == 9999 ]] || [[ $(ver_cut 3) -ge 90 ]] ; then
eautoreconf
@@ -69,9 +62,8 @@ src_prepare() {
src_configure() {
local myeconfargs=(
- # USE="test" installs .a files
- --disable-static
--disable-werror
+
$(use_enable nls)
$(use_enable pam vlock)
$(use_enable test tests)
@@ -80,15 +72,6 @@ src_configure() {
econf "${myeconfargs[@]}"
}
-src_test() {
- # Cheesy hack for now for https://github.com/legionus/kbd/issues/76
- mv "${S}"/data/keymaps/i386/qwerty/cz-qwerty.map "${S}"/data/keymaps/i386/qwerty/cz.map || die
-
- default
-
- mv "${S}"/data/keymaps/i386/qwerty/cz.map "${S}"/data/keymaps/i386/qwerty/cz-qwerty.map || die
-}
-
src_install() {
default