summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-27 21:57:03 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-27 22:08:36 +0300
commit71ce93620a7c0555214f50f7b4d2f1903657e6b1 (patch)
treeda631dc59caab19f0e6c6163a395a30a97eb2513
parentdev-python/hypothesis: add 6.48.0 (diff)
downloadgentoo-71ce93620a7c0555214f50f7b4d2f1903657e6b1.tar.gz
gentoo-71ce93620a7c0555214f50f7b4d2f1903657e6b1.tar.bz2
gentoo-71ce93620a7c0555214f50f7b4d2f1903657e6b1.zip
dev-python/numexpr: add 2.8.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/numexpr/Manifest1
-rw-r--r--dev-python/numexpr/numexpr-2.8.3.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/numexpr/Manifest b/dev-python/numexpr/Manifest
index 8da6ec40ced0..3c4e3b144f8d 100644
--- a/dev-python/numexpr/Manifest
+++ b/dev-python/numexpr/Manifest
@@ -1 +1,2 @@
DIST numexpr-2.8.1.tar.gz 111984 BLAKE2B b5d0b5bd5507c8c513db6404917b6256d9c8d232ea5d2f027f42cdac4a5e5c5f8c2db3d2283734f80d0ae7df2551314d088ccd2ed8e2c7401cc04a15ad61751d SHA512 243cddcb1fece9410e35c87a4c3f794ac0963ddfcc054b9a9c9842a2bb4e782d6c939f532d00d724d4b447d915764c3c8bbb87a99c71a22951798329aa7494bd
+DIST numexpr-2.8.3.gh.tar.gz 112551 BLAKE2B c433e27dafe14e0760cd825992a4dcf3e35ae7a32c1bb768c6f5632e8505be5b10dc08a89c97836f019e53d77cf4aa811cc0822832d605934e35ae93e1cbb661 SHA512 4753159f8247ed18dba01d4db21e8e0a149a253cfc064719c9ccdcdd779d109aca64d2306820d912c274b5b6037a9dc849285ef015fec1e1dc9f0c8bad246393
diff --git a/dev-python/numexpr/numexpr-2.8.3.ebuild b/dev-python/numexpr/numexpr-2.8.3.ebuild
new file mode 100644
index 000000000000..cbfed545e678
--- /dev/null
+++ b/dev-python/numexpr/numexpr-2.8.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
+HOMEPAGE="https://github.com/pydata/numexpr"
+SRC_URI="https://github.com/pydata/numexpr/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-python/numpy-1.13.3[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ pushd "${BUILD_DIR}/install/usr/lib/${EPYTHON}/site-packages" >/dev/null || die
+ "${EPYTHON}" - <<-EOF || die "Tests failed with ${EPYTHON}"
+ import sys,numexpr
+ sys.exit(0 if numexpr.test().wasSuccessful() else 1)
+ EOF
+ pushd >/dev/null || die
+}