summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-08 19:12:14 +0000
committerSam James <sam@gentoo.org>2023-02-08 19:12:35 +0000
commit726e8ac1afece6692ca623b7e68b60fd7b7dfc7f (patch)
treee02951e778eef8bed902f59c310daedf7b304362
parentapp-emacs/mew: add 6.8_p20230203 (diff)
downloadgentoo-726e8ac1afece6692ca623b7e68b60fd7b7dfc7f.tar.gz
gentoo-726e8ac1afece6692ca623b7e68b60fd7b7dfc7f.tar.bz2
gentoo-726e8ac1afece6692ca623b7e68b60fd7b7dfc7f.zip
Revert "app-editors/neovim: fixes (see commit details)"
This reverts commit fca327914eac530d8b37251ba459ae8a454de0e1. Breaks applying patches to 0.8.2/0.8.3. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-editors/neovim/files/neovim-9999-cmake-darwin.patch62
-rw-r--r--app-editors/neovim/files/neovim-9999-cmake_lua_version.patch12
-rw-r--r--app-editors/neovim/neovim-9999.ebuild9
3 files changed, 69 insertions, 14 deletions
diff --git a/app-editors/neovim/files/neovim-9999-cmake-darwin.patch b/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
index b2920451743d..ad47a46e1a7a 100644
--- a/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
+++ b/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
@@ -1,13 +1,65 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -80,33 +80,6 @@ set(ENV{PKG_CONFIG_PATH} "$ENV{PKG_CONFIG_PATH}:${DEPS_PREFIX}/lib/pkgconfig")
+ # used for check_c_compiler_flag
+ include(CheckCCompilerFlag)
+
+-if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
+- # CMake tries to treat /sw and /opt/local as extension of the system path, but
+- # that doesn't really work out very well. Once you have a dependency that
+- # resides there and have to add it as an include directory, then any other
+- # dependency that could be satisfied from there must be--otherwise you can end
+- # up with conflicting versions. So, let's make them more of a priority having
+- # them be included as one of the first places to look for dependencies.
+- list(APPEND CMAKE_PREFIX_PATH /sw /opt/local)
+-
+- # If the macOS deployment target is not set manually (via $MACOSX_DEPLOYMENT_TARGET),
+- # fall back to local system version. Needs to be done both here and in cmake.deps.
+- if(NOT CMAKE_OSX_DEPLOYMENT_TARGET)
+- execute_process(COMMAND sw_vers -productVersion
+- OUTPUT_VARIABLE MACOS_VERSION
+- OUTPUT_STRIP_TRAILING_WHITESPACE)
+- set(CMAKE_OSX_DEPLOYMENT_TARGET "${MACOS_VERSION}")
+- endif()
+- message("Using deployment target ${CMAKE_OSX_DEPLOYMENT_TARGET}")
+-
+- # Work around some old, broken detection by CMake for knowing when to use the
+- # isystem flag. Apple's compilers have supported this for quite some time
+- # now.
+- if(CMAKE_C_COMPILER_ID MATCHES "GNU")
+- set(CMAKE_INCLUDE_SYSTEM_FLAG_C "-isystem ")
+- endif()
+-endif()
+-
+ if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL "Darwin")
+ # Ignore case when comparing filenames on Windows and Mac.
+ set(CASE_INSENSITIVE_FILENAME TRUE)
+--- a/cmake.deps/CMakeLists.txt
++++ b/cmake.deps/CMakeLists.txt
+@@ -112,13 +112,6 @@ if(CMAKE_CXX_COMPILER)
+ set(DEPS_CXX_COMPILER "${CMAKE_CXX_COMPILER}")
+ endif()
+
+-if(CMAKE_OSX_SYSROOT)
+- set(DEPS_C_COMPILER "${DEPS_C_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
+- if(DEPS_CXX_COMPILER)
+- set(DEPS_CXX_COMPILER "${DEPS_CXX_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
+- endif()
+-endif()
+-
+ if(CMAKE_OSX_ARCHITECTURES)
+ string(REPLACE ";" "|" CMAKE_OSX_ARCHITECTURES_ALT_SEP "${CMAKE_OSX_ARCHITECTURES}")
+ # The LuaJIT build does not like being passed multiple `-arch` flags
--- a/src/nvim/CMakeLists.txt
+++ b/src/nvim/CMakeLists.txt
-@@ -440,10 +440,6 @@ get_directory_property(gen_includes INCLUDE_DIRECTORIES)
- foreach(gen_include ${prop})
+@@ -181,10 +181,6 @@ get_directory_property(gen_includes INCLUDE_DIRECTORIES)
+ foreach(gen_include ${gen_includes} ${LUA_PREFERRED_INCLUDE_DIRS})
list(APPEND gen_cflags "-I${gen_include}")
endforeach()
-if(CMAKE_SYSTEM_NAME STREQUAL "Darwin" AND CMAKE_OSX_SYSROOT)
- list(APPEND gen_cflags "-isysroot")
- list(APPEND gen_cflags "${CMAKE_OSX_SYSROOT}")
-endif()
- set(gen_cflags ${gen_cflags} -O2)
-
- set(NVIM_VERSION_GIT_H ${PROJECT_BINARY_DIR}/cmake.config/auto/versiondef_git.h)
+ string(TOUPPER "${CMAKE_BUILD_TYPE}" build_type)
+ separate_arguments(C_FLAGS_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS})
+ separate_arguments(C_FLAGS_${build_type}_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS_${build_type}})
diff --git a/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch b/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch
index b14b3b992349..87a898032493 100644
--- a/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch
+++ b/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch
@@ -1,11 +1,11 @@
---- a/src/nvim/CMakeLists.txt
-+++ b/src/nvim/CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
@@ -464,7 +464,7 @@ endif()
- # The unit test lib requires LuaJIT; it will be skipped if LuaJIT is missing.
option(PREFER_LUA "Prefer Lua over LuaJIT in the nvim executable." OFF)
+
if(PREFER_LUA)
- find_package(Lua 5.1 EXACT REQUIRED)
+ find_package(Lua ${PREFER_LUA} EXACT REQUIRED)
- target_include_directories(main_lib SYSTEM BEFORE INTERFACE ${LUA_INCLUDE_DIR})
- target_link_libraries(main_lib INTERFACE ${LUA_LIBRARIES})
- # Passive (not REQUIRED): if LUAJIT_FOUND is not set, fixtures for unittests is skipped.
+ set(LUA_PREFERRED_INCLUDE_DIRS ${LUA_INCLUDE_DIR})
+ set(LUA_PREFERRED_LIBRARIES ${LUA_LIBRARIES})
+ # Passive (not REQUIRED): if LUAJIT_FOUND is not set, nvim-test is skipped.
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index c35d1e3b8870..6083e311ff39 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -21,7 +21,7 @@ fi
LICENSE="Apache-2.0 vim"
SLOT="0"
-IUSE="+lto +nvimpager test"
+IUSE="+lto +nvimpager test +tui"
REQUIRED_USE="${LUA_REQUIRED_USE}"
# Upstream say the test library needs LuaJIT
@@ -53,8 +53,10 @@ DEPEND="${LUA_DEPS}
>=dev-libs/libvterm-0.3
>=dev-libs/msgpack-3.0.0:=
>=dev-libs/tree-sitter-0.20.2:=
- >=dev-libs/libtermkey-0.22
- >=dev-libs/unibilium-2.0.0:0=
+ tui? (
+ >=dev-libs/libtermkey-0.22
+ >=dev-libs/unibilium-2.0.0:0=
+ )
"
RDEPEND="
${DEPEND}
@@ -96,6 +98,7 @@ src_configure() {
# TODO: Investigate USE_BUNDLED, doesn't seem to be needed right now
local mycmakeargs=(
-DENABLE_LTO=$(usex lto)
+ -DFEAT_TUI=$(usex tui)
-DPREFER_LUA=$(usex lua_single_target_luajit no "$(lua_get_version)")
-DLUA_PRG="${ELUA}"
-DMIN_LOG_LEVEL=3