summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2018-06-14 14:39:27 -0500
committerMarc Schiffbauer <mschiff@gentoo.org>2018-06-14 22:24:50 +0200
commit732381afb5b3fd6461dfb6833613cf2c73c511e9 (patch)
treee80f3e1f7b80b7e03a338baf83cc03ef17efc2ee
parentmedia-sound/pnmixer: keyworded 0.7.1 for ppc, bug #657232 (diff)
downloadgentoo-732381afb5b3fd6461dfb6833613cf2c73c511e9.tar.gz
gentoo-732381afb5b3fd6461dfb6833613cf2c73c511e9.tar.bz2
gentoo-732381afb5b3fd6461dfb6833613cf2c73c511e9.zip
Create dehydrated-0.6.2-r1.ebuild
Closes: https://github.com/gentoo/gentoo/pull/8844
-rw-r--r--app-crypt/dehydrated/dehydrated-0.6.2-r1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/app-crypt/dehydrated/dehydrated-0.6.2-r1.ebuild b/app-crypt/dehydrated/dehydrated-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..328af1a4cfb7
--- /dev/null
+++ b/app-crypt/dehydrated/dehydrated-0.6.2-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit user
+
+DESCRIPTION="a client for signing certificates with an ACME-server"
+HOMEPAGE="https://github.com/lukas2511/dehydrated"
+SRC_URI="https://github.com/lukas2511/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cron"
+
+DEPEND="cron? ( virtual/cron )"
+RDEPEND="
+ ${DEPEND}
+ app-shells/bash
+ net-misc/curl
+"
+
+src_configure() {
+ default
+ sed -i 's,^#CONFIG_D=.*,CONFIG_D="/etc/dehydrated/config.d",' docs/examples/config || die "could not set config (CONFIG_D)"
+}
+
+src_install() {
+ dobin "${PN}"
+ insinto "/etc/${PN}"
+ doins docs/examples/{config,domains.txt,hook.sh}
+ dodoc docs/*.md
+
+ insinto /etc/"${PN}"/config.d
+ doins "${FILESDIR}"/00_gentoo.sh
+
+ if use cron ; then
+ insinto "/etc/cron.d"
+ newins "${FILESDIR}"/cron "${PN}"
+ fi
+
+ dodir /etc/"${PN}"/config.d
+ keepdir /etc/"${PN}"/config.d
+
+ default
+}
+
+pkg_preinst() {
+ enewgroup "${PN}"
+ enewuser "${PN}" -1 -1 /var/lib/"${PN}" "${PN}"
+}
+
+pkg_postinst() {
+ if [[ "${REPLACING_VERSIONS}" =~ (0\.3\.1|0\.4\.0) ]]; then
+ ewarn ""
+ ewarn "The new default BASEDIR is now '/var/lib/dehydrated'"
+ ewarn "Please consider migrating your data with a command like"
+ ewarn ""
+ ewarn " 'mv -v /etc/dehydrated/{accounts,archive,certs,lock} /var/lib/dehydrated'"
+ ewarn ""
+ ewarn "and make sure BASEDIR is set to '/var/lib/dehydrated'"
+ ewarn ""
+ fi
+ einfo "See /etc/dehydrated/config for configuration."
+ use cron && einfo "After finishing setup you should enable the cronjob in /etc/cron.d/dehydrated."
+}