summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-05-03 11:27:50 +0200
committerPacho Ramos <pacho@gentoo.org>2020-05-03 11:49:06 +0200
commit73581e1095aa6df83f46de376faeb962c08254ba (patch)
treefdc92819b32d00d4d14fbe689de09433f833082d
parentx11-base/xorg-drivers: Dropping xf86-input-{keyboard,mouse} deps (diff)
downloadgentoo-73581e1095aa6df83f46de376faeb962c08254ba.tar.gz
gentoo-73581e1095aa6df83f46de376faeb962c08254ba.tar.bz2
gentoo-73581e1095aa6df83f46de376faeb962c08254ba.zip
media-sound/cdparanoia: Fix missing musl includes
Thanks-to: Toralf Förster Thanks-to: Michael 'veremitz' Everitt Closes: https://bugs.gentoo.org/713740 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--media-sound/cdparanoia/cdparanoia-3.10.2-r7.ebuild4
-rw-r--r--media-sound/cdparanoia/files/cdparanoia-missing-sys_types_h.patch24
2 files changed, 27 insertions, 1 deletions
diff --git a/media-sound/cdparanoia/cdparanoia-3.10.2-r7.ebuild b/media-sound/cdparanoia/cdparanoia-3.10.2-r7.ebuild
index 38d07ee8cf0f..afbbe92e3f8d 100644
--- a/media-sound/cdparanoia/cdparanoia-3.10.2-r7.ebuild
+++ b/media-sound/cdparanoia/cdparanoia-3.10.2-r7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -27,6 +27,8 @@ src_prepare() {
# Patches from previus patchset + Fedora + Debian
eapply "${WORKDIR}"/patches/*.patch
+ eapply "${FILESDIR}"/${PN}-missing-sys_types_h.patch #713740
+
mv configure.guess config.guess
mv configure.sub config.sub
diff --git a/media-sound/cdparanoia/files/cdparanoia-missing-sys_types_h.patch b/media-sound/cdparanoia/files/cdparanoia-missing-sys_types_h.patch
new file mode 100644
index 000000000000..010ed4a844cc
--- /dev/null
+++ b/media-sound/cdparanoia/files/cdparanoia-missing-sys_types_h.patch
@@ -0,0 +1,24 @@
+diff -Naur cdparanoia-III-10.2.orig/interface/utils.h cdparanoia-III-10.2/interface/utils.h
+--- cdparanoia-III-10.2.orig/interface/utils.h 2008-08-14 06:56:20.000000000 -0700
++++ cdparanoia-III-10.2/interface/utils.h 2016-05-30 14:35:57.071615252 -0700
+@@ -3,6 +3,8 @@
+ #include <errno.h>
+ #include <string.h>
+
++#include <sys/types.h>
++
+ /* I wonder how many alignment issues this is gonna trip in the
+ future... it shouldn't trip any... I guess we'll find out :) */
+
+diff -Naur cdparanoia-III-10.2.orig/utils.h cdparanoia-III-10.2/utils.h
+--- cdparanoia-III-10.2.orig/utils.h 2008-08-22 02:39:06.000000000 -0700
++++ cdparanoia-III-10.2/utils.h 2016-05-30 14:35:33.101409747 -0700
+@@ -4,6 +4,8 @@
+ #include <errno.h>
+ #include <string.h>
+
++#include <sys/types.h>
++
+ extern long buffering_write(int outf, char *buffer, long num);
+ extern int buffering_close(int fd);
+