summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Campbell <zlg@gentoo.org>2017-11-13 12:45:27 -0800
committerDaniel Campbell <zlg@gentoo.org>2017-11-13 12:45:53 -0800
commit73638c2c82b42bfa0eead47420de1cf6941fd19e (patch)
treeeb3afef950921d7836f63219380f37495a22818f
parentapp-backup/amanda: fix ownership of /etc/amanda/amanda-security.conf (diff)
downloadgentoo-73638c2c82b42bfa0eead47420de1cf6941fd19e.tar.gz
gentoo-73638c2c82b42bfa0eead47420de1cf6941fd19e.tar.bz2
gentoo-73638c2c82b42bfa0eead47420de1cf6941fd19e.zip
app-misc/grc: Install all shell-specific config
This commit fixes a regression in the previous ebuild that was installing grc.bashrc into /etc/profile.d unconditionally. The new version installs them all to /usr/share/grc and lets the user decide how to integrate it with their system. Thanks to Torbjörn Lönnemark, poncho, Andreas Porteus. Closes: https://bugs.gentoo.org/620138 Package-Manager: Portage-2.3.13, Repoman-2.3.4
-rw-r--r--app-misc/grc/grc-1.11-r1.ebuild20
1 files changed, 17 insertions, 3 deletions
diff --git a/app-misc/grc/grc-1.11-r1.ebuild b/app-misc/grc/grc-1.11-r1.ebuild
index dd4b617a6298..516d79b6b948 100644
--- a/app-misc/grc/grc-1.11-r1.ebuild
+++ b/app-misc/grc/grc-1.11-r1.ebuild
@@ -35,9 +35,10 @@ src_install() {
insinto /usr/share/grc
doins \
contrib/mrsmith/conf.* \
- colourfiles/conf.*
- insinto /etc/profile.d
- newins grc.bashrc grc.sh
+ colourfiles/conf.* \
+ grc.bashrc \
+ grc.fish \
+ grc.zsh
insinto /etc
doins grc.conf
@@ -45,3 +46,16 @@ src_install() {
dodoc README.markdown INSTALL TODO debian/changelog CREDITS Regexp.txt
doman *.1
}
+
+pkg_postinst() {
+ elog
+ elog "Shell specific configurations can be found in ${ROOT}usr/share/grc"
+ elog "Be sure to symlink one to use grc globally:"
+ elog
+ elog " ln -s ${ROOT}usr/share/grc.SHELL ${ROOT}etc/profile.d/grc.sh"
+ elog
+ elog "Replace 'SHELL' in the above command with one of: bashrc, fish, zsh."
+ elog "Afterwards, use '. ${ROOT}etc/profile' to activate grc in existing"
+ elog "shell sessions."
+ elog
+}