summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-31 04:02:34 +0100
committerSam James <sam@gentoo.org>2021-07-31 23:13:36 +0100
commit739734a4794a5f183b60a79dcdb2fa35ad090ff2 (patch)
treedafb808e09a3fe2ac6182189b0697e1c64e56c0d
parentgnome-base/gvfs: [QA] call tmpfiles_process in pkg_postinst (conditionally) (diff)
downloadgentoo-739734a4.tar.gz
gentoo-739734a4.tar.bz2
gentoo-739734a4.zip
net-vpn/libreswan: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Revbump because the new tmpfiles inherit adds a new dependency (virtual/tmpfiles). Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-vpn/libreswan/libreswan-3.32-r4.ebuild (renamed from net-vpn/libreswan/libreswan-3.32-r2.ebuild)4
-rw-r--r--net-vpn/libreswan/libreswan-3.32-r5.ebuild (renamed from net-vpn/libreswan/libreswan-3.32-r3.ebuild)4
-rw-r--r--net-vpn/libreswan/libreswan-4.2-r2.ebuild (renamed from net-vpn/libreswan/libreswan-4.2-r1.ebuild)4
-rw-r--r--net-vpn/libreswan/libreswan-4.3-r2.ebuild (renamed from net-vpn/libreswan/libreswan-4.3-r1.ebuild)4
-rw-r--r--net-vpn/libreswan/libreswan-4.4-r4.ebuild (renamed from net-vpn/libreswan/libreswan-4.4-r2.ebuild)4
-rw-r--r--net-vpn/libreswan/libreswan-4.4-r5.ebuild (renamed from net-vpn/libreswan/libreswan-4.4-r3.ebuild)4
6 files changed, 18 insertions, 6 deletions
diff --git a/net-vpn/libreswan/libreswan-3.32-r2.ebuild b/net-vpn/libreswan/libreswan-3.32-r4.ebuild
index a2dd7437d923..6d019790c6e4 100644
--- a/net-vpn/libreswan/libreswan-3.32-r2.ebuild
+++ b/net-vpn/libreswan/libreswan-3.32-r4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit systemd toolchain-funcs
+inherit systemd toolchain-funcs tmpfiles
DESCRIPTION="IPsec implementation for Linux, fork of Openswan"
HOMEPAGE="https://libreswan.org/"
@@ -107,6 +107,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process libreswan.conf
+
local IPSEC_CONFDIR=${ROOT}/etc/ipsec.d
if [[ ! -f ${IPSEC_CONFDIR}/cert8.db && ! -f ${IPSEC_CONFDIR}/cert9.db ]] ; then
ebegin "Setting up NSS database in ${IPSEC_CONFDIR} with empty password"
diff --git a/net-vpn/libreswan/libreswan-3.32-r3.ebuild b/net-vpn/libreswan/libreswan-3.32-r5.ebuild
index 0cae2c0bd2c0..fbf53aa5227f 100644
--- a/net-vpn/libreswan/libreswan-3.32-r3.ebuild
+++ b/net-vpn/libreswan/libreswan-3.32-r5.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit systemd toolchain-funcs
+inherit systemd toolchain-funcs tmpfiles
DESCRIPTION="IPsec implementation for Linux, fork of Openswan"
HOMEPAGE="https://libreswan.org/"
@@ -107,6 +107,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process libreswan.conf
+
local IPSEC_CONFDIR=${ROOT}/etc/ipsec.d
if [[ ! -f ${IPSEC_CONFDIR}/cert8.db && ! -f ${IPSEC_CONFDIR}/cert9.db ]] ; then
ebegin "Setting up NSS database in ${IPSEC_CONFDIR} with empty password"
diff --git a/net-vpn/libreswan/libreswan-4.2-r1.ebuild b/net-vpn/libreswan/libreswan-4.2-r2.ebuild
index d22b2acaad21..ef6abcc59657 100644
--- a/net-vpn/libreswan/libreswan-4.2-r1.ebuild
+++ b/net-vpn/libreswan/libreswan-4.2-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit systemd toolchain-funcs
+inherit systemd toolchain-funcs tmpfiles
DESCRIPTION="IPsec implementation for Linux, fork of Openswan"
HOMEPAGE="https://libreswan.org/"
@@ -110,6 +110,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process libreswan.conf
+
local IPSEC_CONFDIR=${ROOT}/var/lib/ipsec/nss
if [[ ! -f ${IPSEC_CONFDIR}/cert8.db && ! -f ${IPSEC_CONFDIR}/cert9.db ]] ; then
ebegin "Setting up NSS database in ${IPSEC_CONFDIR} with empty password"
diff --git a/net-vpn/libreswan/libreswan-4.3-r1.ebuild b/net-vpn/libreswan/libreswan-4.3-r2.ebuild
index 8e5ba4775e4d..b796e7383a4a 100644
--- a/net-vpn/libreswan/libreswan-4.3-r1.ebuild
+++ b/net-vpn/libreswan/libreswan-4.3-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit systemd toolchain-funcs
+inherit systemd toolchain-funcs tmpfiles
DESCRIPTION="IPsec implementation for Linux, fork of Openswan"
HOMEPAGE="https://libreswan.org/"
@@ -110,6 +110,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process libreswan.conf
+
local IPSEC_CONFDIR=${ROOT}/var/lib/ipsec/nss
if [[ ! -f ${IPSEC_CONFDIR}/cert8.db && ! -f ${IPSEC_CONFDIR}/cert9.db ]] ; then
ebegin "Setting up NSS database in ${IPSEC_CONFDIR} with empty password"
diff --git a/net-vpn/libreswan/libreswan-4.4-r2.ebuild b/net-vpn/libreswan/libreswan-4.4-r4.ebuild
index 5ab87e049ce3..cf531fec3296 100644
--- a/net-vpn/libreswan/libreswan-4.4-r2.ebuild
+++ b/net-vpn/libreswan/libreswan-4.4-r4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit systemd toolchain-funcs
+inherit systemd toolchain-funcs tmpfiles
DESCRIPTION="IPsec implementation for Linux, fork of Openswan"
HOMEPAGE="https://libreswan.org/"
@@ -110,6 +110,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process libreswan.conf
+
local IPSEC_CONFDIR=${ROOT}/var/lib/ipsec/nss
if [[ ! -f ${IPSEC_CONFDIR}/cert8.db && ! -f ${IPSEC_CONFDIR}/cert9.db ]] ; then
ebegin "Setting up NSS database in ${IPSEC_CONFDIR} with empty password"
diff --git a/net-vpn/libreswan/libreswan-4.4-r3.ebuild b/net-vpn/libreswan/libreswan-4.4-r5.ebuild
index 36d74c43e4f4..06f4baa533ab 100644
--- a/net-vpn/libreswan/libreswan-4.4-r3.ebuild
+++ b/net-vpn/libreswan/libreswan-4.4-r5.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit systemd toolchain-funcs
+inherit systemd toolchain-funcs tmpfiles
DESCRIPTION="IPsec implementation for Linux, fork of Openswan"
HOMEPAGE="https://libreswan.org/"
@@ -110,6 +110,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process libreswan.conf
+
local IPSEC_CONFDIR=${ROOT}/var/lib/ipsec/nss
if [[ ! -f ${IPSEC_CONFDIR}/cert8.db && ! -f ${IPSEC_CONFDIR}/cert9.db ]] ; then
ebegin "Setting up NSS database in ${IPSEC_CONFDIR} with empty password"