summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-04 14:34:45 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-04 15:48:40 +0200
commit74072da9ff8ac80a95dd073d54711de212ab5c23 (patch)
tree6cfa43d24d1727933880c6cc014632d29a6cecd9
parentdev-python/PyGithub: Bump to 1.52 (diff)
downloadgentoo-74072da9ff8ac80a95dd073d54711de212ab5c23.tar.gz
gentoo-74072da9ff8ac80a95dd073d54711de212ab5c23.tar.bz2
gentoo-74072da9ff8ac80a95dd073d54711de212ab5c23.zip
dev-python/tqdm: Bump to 4.48.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.48.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index e39d78c5a684..e8dcea048d39 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,3 +1,4 @@
DIST tqdm-4.47.0.tar.gz 145749 BLAKE2B 77a5efec763a8e58e071ee571077ee0db72d9243308592519ecd2c38f60d6b621fd7362dd87bdd0759a39f25c19cc3cc889e9a8376dc658ed565ca7e19fc68cd SHA512 4023988cef757f43a6f59f7eddc8f40246cbca4994cea91dbb4a788385c0706f376f4c0fd5c8c47146c10eb8c52be2c9d4855b7bea0a5036162c55447aac95d7
DIST tqdm-4.48.0.tar.gz 148578 BLAKE2B 95ce438cc14cad5a4ad7b9b2b89b38d5a5c49e27a4ed797ae1a05d7eb3d9539dfaaee72f6330cd5f3f18721ca4259c5ee3f643ae8dd509f1e2261566ee9c3f02 SHA512 9c23b103603c5f56f9cc84d04e68950a0e6431cf40db856918f6e2f21aea61fafbbf466eff6d80fc14c40bb2a11dd0be80e801c55adbab02762c36ce9bed31a9
DIST tqdm-4.48.1.tar.gz 148971 BLAKE2B 119b538dc9fadc1b38cb48d6169ecd647397883bbf26257cabe6d613e48fbcded3bebf74399f96ba69603b24589464b559da1f204fd38bd6d87e836539d6cc61 SHA512 fc47674c0c62d83d2bffb2ee46862b562517c4ceef21e1802db4a85006bee53f6a99fba87ebeb9e8ea5d34ae35a21378ae379ba159dd6aab16f28d1ed527f0c3
+DIST tqdm-4.48.2.tar.gz 148978 BLAKE2B 2423a3d23b86ec6b535a2157d0fbaea6921f95873fb2507a08ff57de0fdcf8fcbfb030210393f5410437ee9977da3ad2011f07a866b3f91a057e338082325976 SHA512 849e4dad4bd0819b328e906af8a8f7acf2ebfd559c9ae3ebf822bc64c1b1a5c96e44b9b69d3dedf6387c44cf9eed559f1377ea29f71fadfc8f056c52685425e9
diff --git a/dev-python/tqdm/tqdm-4.48.2.ebuild b/dev-python/tqdm/tqdm-4.48.2.ebuild
new file mode 100644
index 000000000000..27373f57ea4f
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.48.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tqdm/tqdm"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+ sed -r \
+ -e "s:'nose'(,[[:space:]]*|)::" \
+ -e "s:'flake8'(,[[:space:]]*|)::" \
+ -e "s:'coverage'(,[[:space:]]*|)::" \
+ -i setup.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # tests_main.py requires the package to be installed
+ distutils_install_for_testing
+ # Skip unpredictable performance tests
+ nosetests tqdm -v --ignore 'tests_perf.py' \
+ || die "tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
+ rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
+ distutils-r1_python_install --skip-build
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}