summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-27 18:41:41 +0200
committerMichał Górny <mgorny@gentoo.org>2023-03-27 18:48:43 +0200
commit74b9ca586ccd413d00b2a8757e43a63382813b43 (patch)
treef6a2e297736d95e45748baa59ca6d5147bf8dcb9
parentdev-python/furo: Bump to 2023.3.27 (diff)
downloadgentoo-74b9ca586ccd413d00b2a8757e43a63382813b43.tar.gz
gentoo-74b9ca586ccd413d00b2a8757e43a63382813b43.tar.bz2
gentoo-74b9ca586ccd413d00b2a8757e43a63382813b43.zip
dev-python/phonenumbers: Bump to 8.13.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/phonenumbers/Manifest1
-rw-r--r--dev-python/phonenumbers/phonenumbers-8.13.8.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/phonenumbers/Manifest b/dev-python/phonenumbers/Manifest
index 852290131308..c3052e39a179 100644
--- a/dev-python/phonenumbers/Manifest
+++ b/dev-python/phonenumbers/Manifest
@@ -1,2 +1,3 @@
DIST python-phonenumbers-8.13.6.gh.tar.gz 4906869 BLAKE2B b00fcd6085844a9465da15547f8b40ec741a350d24bb888a04dc5e7aee9b94ec1dae83a71548bc75b8cca29af3ee29cccdc5c49447c5b1bbf33a52db049835eb SHA512 7ca6b8872975fc2597b6ddb1b824feb05dd8819da1ac1f73b7ce831070210520700639dc44e1466e83d335453a5c70ed2fae6ae8100cb99f03f62961f38e6dd9
DIST python-phonenumbers-8.13.7.gh.tar.gz 4909229 BLAKE2B c1984c774670528005231984dd12160ff2259e96a5baec61cf0b85a5444d5af1565fdbee9dd17b81994dc5f186e32faa660c11ba4c07681cc513c1595c28c4d4 SHA512 3987e31c0cc0a7c2234b6e8a04714a2a0e015623ff36e6475df7189488d54e15dd23375c65a1b8f131331b32642bd94295dcd43df994dc16c2aad0b0529fac73
+DIST python-phonenumbers-8.13.8.gh.tar.gz 4910864 BLAKE2B 33babe7aa0f487398311817fa901a56ac8a7470f2e4338700529f35c7622cf9b663bd404f6c1087600c03fd2844a1c777ed81d2e61d9cc2f0ff78e68a0276624 SHA512 6e2ee96aa9c20188b276cdeac1365fddb339feb63e8d5e9f61ae82f6aa19cc6564a5f1dbf687d6cc69c2cfa21fbb14892f880677ac7ba734a949183711faca5a
diff --git a/dev-python/phonenumbers/phonenumbers-8.13.8.ebuild b/dev-python/phonenumbers/phonenumbers-8.13.8.ebuild
new file mode 100644
index 000000000000..20fb3f38daee
--- /dev/null
+++ b/dev-python/phonenumbers/phonenumbers-8.13.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Python port of Google's libphonenumber"
+HOMEPAGE="
+ https://github.com/daviddrysdale/python-phonenumbers/
+ https://pypi.org/project/phonenumbers/
+"
+SRC_URI="
+ https://github.com/daviddrysdale/python-phonenumbers/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}/python
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( ../README.md )
+
+python_test() {
+ "${EPYTHON}" testwrapper.py -v || die "Tests failed with ${EPYTHON}"
+}