summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2020-06-17 11:51:17 -0400
committerAnthony G. Basile <blueness@gentoo.org>2020-06-17 11:51:17 -0400
commit75205e97c0f733b2adda89c58adeb734dcaf9958 (patch)
tree05f0942615d59a39aee3d666dfd2b51bff5c620b
parentsys-libs/pam: fix test operator calls (diff)
downloadgentoo-75205e97c0f733b2adda89c58adeb734dcaf9958.tar.gz
gentoo-75205e97c0f733b2adda89c58adeb734dcaf9958.tar.bz2
gentoo-75205e97c0f733b2adda89c58adeb734dcaf9958.zip
dev-libs/libressl: version bump to 3.1.3
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--dev-libs/libressl/Manifest1
-rw-r--r--dev-libs/libressl/libressl-3.1.3.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/libressl/Manifest b/dev-libs/libressl/Manifest
index 58dfcd20f73e..fe269b65c8bf 100644
--- a/dev-libs/libressl/Manifest
+++ b/dev-libs/libressl/Manifest
@@ -4,4 +4,5 @@ DIST libressl-2.9.2.tar.gz 3607549 BLAKE2B 496e993e4f1c85167e0344afab61259d4e3f0
DIST libressl-3.0.2.tar.gz 3669468 BLAKE2B 84ad2c1fea8d2119f191ec8ab3f999fb0354636d48aabb76fa1786139c669c9d8ca105d79cc8416dd20683818eccc84490cdadc9ca94cb2b0e411644e923a3d6 SHA512 19226da3bc9776e1da40b8e94dfa53564d5e6acc80edee539ba12d7a75c1bb8c0603e7633f26a6ef8b12adc56bb677ccda448575aa6be2ad3df5447465a4b080
DIST libressl-3.1.1.tar.gz 3765769 BLAKE2B 8524a4d83e05b0f2992df8e3797cbf43220a8619431f4737887db2fa35419a925907691ac1aec5b3cc1660179d4ac5e44714540ae591c5aa4957db1f26068a7e SHA512 353a5c95bb0c160b698b95b91d6857ddb63a75b0685a233ed2515f46ad8369d40857aa1ff8407aa9bc78a5c3c29c25376e7a55a3c96fce40840633411944fb1d
DIST libressl-3.1.2.tar.gz 3765944 BLAKE2B b0181a1936af3aad3908668cae14aa87e8dca594ebb1effa354eb57529c21aca2052ce6bc85958dd83645c9026c84410939018d16c8e70a60f336145d45790e6 SHA512 b024c5661777daa73feff7085ce7be76a2e766d2f3cb5ca35c208c471e5651a365252758ca36782e20cdfb2bc8171919a08ad592420878a5c95fbe646f5288c8
+DIST libressl-3.1.3.tar.gz 3766345 BLAKE2B 4956fa0ae6030e9e9969d584db3bc0084c4b155207d1472ebfa40c8e68e925214b66ed1bc7e32d98a9a48de0b61909323a0380a973c724422c92bfe88b9fdfb2 SHA512 f9f497fe5d09b8b762175da038a8e67d9d2567462fefc49e434d306a3071ba3a4d369c89143d9d90e3bbcc7b9ba051c9c923a0dfc41d856edc08ae59fa727ee8
DIST libressl-3.2.0.tar.gz 3775925 BLAKE2B 99d74fad16e272be8e3b23b873c35970ce3693e088baf365670ad8e8cbb846e90f4232bbc6c65b70a35060da99b9b210b3debce1c78d531e810de26e3e2f05cb SHA512 e8bf95af4e4e855b0462eb12df8f802102a3bee5bb40fb1859e7c40d9e3ce89f0d2eb0acdd923e7c592b4aeb7ecc556f753c0a12d0dace05d2ef342bffdd9d07
diff --git a/dev-libs/libressl/libressl-3.1.3.ebuild b/dev-libs/libressl/libressl-3.1.3.ebuild
new file mode 100644
index 000000000000..ab31f2041689
--- /dev/null
+++ b/dev-libs/libressl/libressl-3.1.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal libtool
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
+# we'll try to use the max of either. However, if either change between
+# versions, we have to change the subslot to trigger rebuild of consumers.
+SLOT="0/48"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+asm static-libs test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( static-libs )"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ touch crypto/Makefile.in
+
+ sed -i \
+ -e '/^[ \t]*CFLAGS=/s#-g ##' \
+ -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+ -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+ configure || die "fixing CFLAGS failed"
+
+ if ! use test ; then
+ sed -i \
+ -e '/^[ \t]*SUBDIRS =/s#tests##' \
+ Makefile.in || die "Removing tests failed"
+ fi
+
+ eapply "${FILESDIR}"/${PN}-2.8.3-solaris10.patch
+ eapply_user
+
+ elibtoolize # for Solaris
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable asm) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+}