summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-11-25 18:10:37 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-11-25 18:10:51 -0800
commit754719bf31995aef24556009bc2a422262655bad (patch)
tree896d8bba69195074ac5ff37dfedfdee1a73f4c8d
parentvirtual/rust: x86 stable (bug #756769) (diff)
downloadgentoo-754719bf31995aef24556009bc2a422262655bad.tar.gz
gentoo-754719bf31995aef24556009bc2a422262655bad.tar.bz2
gentoo-754719bf31995aef24556009bc2a422262655bad.zip
net-vpn/openvpn-2.5.0-r1: Add patch to fix libressl (bug #651228)
Closes: https://bugs.gentoo.org/651228 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--net-vpn/openvpn/files/openvpn-2.5.0-auth-pam-missing-header.patch12
-rw-r--r--net-vpn/openvpn/openvpn-2.5.0-r1.ebuild5
2 files changed, 16 insertions, 1 deletions
diff --git a/net-vpn/openvpn/files/openvpn-2.5.0-auth-pam-missing-header.patch b/net-vpn/openvpn/files/openvpn-2.5.0-auth-pam-missing-header.patch
new file mode 100644
index 000000000000..2e48bd6b3870
--- /dev/null
+++ b/net-vpn/openvpn/files/openvpn-2.5.0-auth-pam-missing-header.patch
@@ -0,0 +1,12 @@
+diff --git a/src/plugins/auth-pam/auth-pam.c b/src/plugins/auth-pam/auth-pam.c
+index f537652e..29306310 100644
+--- a/src/plugins/auth-pam/auth-pam.c
++++ b/src/plugins/auth-pam/auth-pam.c
+@@ -47,6 +47,7 @@
+ #include <fcntl.h>
+ #include <signal.h>
+ #include <syslog.h>
++#include <limits.h>
+ #include "utils.h"
+
+ #include <openvpn-plugin.h>
diff --git a/net-vpn/openvpn/openvpn-2.5.0-r1.ebuild b/net-vpn/openvpn/openvpn-2.5.0-r1.ebuild
index 35f18565020d..575fb5764812 100644
--- a/net-vpn/openvpn/openvpn-2.5.0-r1.ebuild
+++ b/net-vpn/openvpn/openvpn-2.5.0-r1.ebuild
@@ -46,9 +46,12 @@ RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-openvpn )
"
-CONFIG_CHECK="~TUN"
+PATCHES=(
+ "${FILESDIR}/openvpn-2.5.0-auth-pam-missing-header.patch"
+)
pkg_setup() {
+ local CONFIG_CHECK="~TUN"
linux-info_pkg_setup
}