summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-06-25 14:49:22 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-06-25 14:49:22 -0700
commit75b2a1c9a789789d06b3a390b19d66804d37028b (patch)
treeeea17b0917250275e7cc0e23744ce27b3bbb14c2
parentdev-python/google-reauth-python: Add python3_7 (diff)
downloadgentoo-75b2a1c9a789789d06b3a390b19d66804d37028b.tar.gz
gentoo-75b2a1c9a789789d06b3a390b19d66804d37028b.tar.bz2
gentoo-75b2a1c9a789789d06b3a390b19d66804d37028b.zip
dev-python/retry-decorator: revbump: EAPI=7, python3_7
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/retry-decorator/retry-decorator-1.0.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/retry-decorator/retry-decorator-1.0.0-r1.ebuild b/dev-python/retry-decorator/retry-decorator-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..ca6ec3bfd7e9
--- /dev/null
+++ b/dev-python/retry-decorator/retry-decorator-1.0.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Decorator for retrying when exceptions occur"
+HOMEPAGE="https://github.com/pnpnpn/retry-decorator"
+SRC_URI="https://github.com/pnpnpn/retry-decorator/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( README.rst )