summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2016-10-24 09:35:36 +0900
committerBenda Xu <heroxbd@gentoo.org>2016-10-24 09:35:36 +0900
commit75b7af65f66102a800ade5383639e77c3b7f8d57 (patch)
treeb7699b0811f44b5f29b7950fb2965b71a2539671
parentmedia-video/totem: version bump 3.20.1 → 3.22.0 (diff)
downloadgentoo-75b7af65f66102a800ade5383639e77c3b7f8d57.tar.gz
gentoo-75b7af65f66102a800ade5383639e77c3b7f8d57.tar.bz2
gentoo-75b7af65f66102a800ade5383639e77c3b7f8d57.zip
app-shells/bash: prefixify hard-coded path names.
Bug: 595142 Package-Manager: portage-2.3.0
-rw-r--r--app-shells/bash/bash-4.4-r1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-shells/bash/bash-4.4-r1.ebuild b/app-shells/bash/bash-4.4-r1.ebuild
index 3a1e9b0a4c6c..caed46fb36c2 100644
--- a/app-shells/bash/bash-4.4-r1.ebuild
+++ b/app-shells/bash/bash-4.4-r1.ebuild
@@ -4,7 +4,7 @@
EAPI="5"
-inherit eutils flag-o-matic toolchain-funcs multilib
+inherit eutils flag-o-matic toolchain-funcs multilib prefix
# Official patchlevel
# See ftp://ftp.cwru.edu/pub/bash/bash-4.3-patches/
@@ -84,6 +84,9 @@ src_prepare() {
sed -ri -e 's:\$[(](RL|HIST)_LIBSRC[)]/[[:alpha:]]*.h::g' Makefile.in || die
fi
+ # Prefixify hardcoded path names. No-op for non-prefix.
+ hprefixify pathnames.h.in
+
# Avoid regenerating docs after patches #407985
sed -i -r '/^(HS|RL)USER/s:=.*:=:' doc/Makefile.in || die
touch -r . doc/*
@@ -176,7 +179,7 @@ src_install() {
insinto /etc/bash
doins "${FILESDIR}"/bash_logout
- doins "${FILESDIR}"/bashrc
+ doins "$(prefixify_ro "${FILESDIR}"/bashrc)"
keepdir /etc/bash/bashrc.d
insinto /etc/skel
for f in bash{_logout,_profile,rc} ; do