summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-07-15 08:42:31 +0200
committerJeroen Roovers <jer@gentoo.org>2016-07-15 08:43:57 +0200
commit75c4f1a702738177389f591c8311df708ff70bd0 (patch)
treede63d7c37234af4ce50b9c699faec3c8624f0433
parentsys-apps/tuned: fix missing dev-python/pygobject dep (diff)
downloadgentoo-75c4f1a702738177389f591c8311df708ff70bd0.tar.gz
gentoo-75c4f1a702738177389f591c8311df708ff70bd0.tar.bz2
gentoo-75c4f1a702738177389f591c8311df708ff70bd0.zip
net-analyzer/wireshark: Version bump.
Package-Manager: portage-2.3.0
-rw-r--r--net-analyzer/wireshark/Manifest1
-rw-r--r--net-analyzer/wireshark/wireshark-2.1.1.ebuild260
2 files changed, 261 insertions, 0 deletions
diff --git a/net-analyzer/wireshark/Manifest b/net-analyzer/wireshark/Manifest
index 53cdf9297534..df5f9e9c61bc 100644
--- a/net-analyzer/wireshark/Manifest
+++ b/net-analyzer/wireshark/Manifest
@@ -1,3 +1,4 @@
DIST wireshark-2.0.2.tar.bz2 31073440 SHA256 e921fb072085a5654d899949bb561d0687f4819f7b63ba35777bb949a9b6b9c1 SHA512 a3645f0c2600091d3af76d12db4b73f83e6af4686a1bd7a336a420e4d7505ed281dfabb05c05cd6f58084fa3f25b6b9014b6f273b875c713ee39c77b4c5c715f WHIRLPOOL 4041698412d96ce495e2b564c897b4d770eea1851e431b43b2ef1bc6834bf57460ace5cc2e3f9ae6e05babbbec85e096ee1a87bc68211677202215c4dd0b53e5
DIST wireshark-2.0.4.tar.bz2 31121258 SHA256 9ea9c82da9942194ebc8fc5c951a02e6d179afa7472cb6d96ca76154510de1a5 SHA512 f86c41ba9fb25ea61f3947819676417f7af64301cdd37c91666d59b179c45d76c1d0e8739ef6bcf3bb077d3216a65458b3d56755dd08f1fb05cc87cb810f8a07 WHIRLPOOL 2a495221cc1e28283ca19c181fb531fbd01194dd9a0ce9ab6df2a50ce0e19dc21ff5fe023d08a88ebcbb2bfe2a55d47e173401bc09ff8f5356e695fb4cacb12b
DIST wireshark-2.1.0.tar.bz2 32605482 SHA256 f73bd7660056c0910c8a89f480f61ab9fe62866eadf1af49e3374da3fe16b4cc SHA512 9882014f4cb4f78034c4471f7667f9accdc32dd4c22b8ea799da7a0f2ad1bb7aaa47308ece503cd4e1955903138c06f219f309c8c6216f64d1e9c8747f118154 WHIRLPOOL 0ba0cca898bf4f302fabbe0f8dbc0fb7ff050c4dfb988d9d9622b97ae48fc3ca342f260136b1d2fc667407633817c09f5b5d7624081c2c59bdf7559339f03164
+DIST wireshark-2.1.1.tar.bz2 32212684 SHA256 8f5e604e8e0bc1f5562b166818f7a247f1b4d1f2ed15614138cc82fedad607e5 SHA512 216a0f661d271361d6388c74d52add917ec8701f58ae1a7b0ea115c4028240ad1c911fd74e9d8fe78bca4088228afcbcfb5a610827683552b3bc2bc1c77a249e WHIRLPOOL 83f1941146b8487f1644b1e8e8b8ced8ded1b16d53db9c4316808474f11121acd704f66c2f97d456a0a817f5b127380c834ed9924f58421ad3c9ef2b0e9cd70f
diff --git a/net-analyzer/wireshark/wireshark-2.1.1.ebuild b/net-analyzer/wireshark/wireshark-2.1.1.ebuild
new file mode 100644
index 000000000000..66e32b8fac7d
--- /dev/null
+++ b/net-analyzer/wireshark/wireshark-2.1.1.ebuild
@@ -0,0 +1,260 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils fcaps flag-o-matic multilib qmake-utils qt4-r2 user
+
+DESCRIPTION="A network protocol analyzer formerly known as ethereal"
+HOMEPAGE="http://www.wireshark.org/"
+SRC_URI="${HOMEPAGE}download/src/all-versions/${P/_/}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="
+ adns androiddump +caps cpu_flags_x86_sse4_2 crypt doc doc-pdf geoip +gtk
+ kerberos lua +netlink +pcap portaudio +qt4 qt5 sbc selinux smi ssl tfshark
+ zlib
+"
+REQUIRED_USE="
+ ssl? ( crypt )
+ ?? ( qt4 qt5 )
+"
+
+S=${WORKDIR}/${P/_/}
+
+CDEPEND="
+ >=dev-libs/glib-2.14:2
+ netlink? ( dev-libs/libnl:3 )
+ adns? ( >=net-dns/c-ares-1.5 )
+ crypt? ( dev-libs/libgcrypt:0 )
+ caps? ( sys-libs/libcap )
+ geoip? ( dev-libs/geoip )
+ gtk? (
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/pango
+ x11-misc/xdg-utils
+ )
+ kerberos? ( virtual/krb5 )
+ lua? ( >=dev-lang/lua-5.1:* )
+ pcap? ( net-libs/libpcap )
+ portaudio? ( media-libs/portaudio )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4[accessibility]
+ x11-misc/xdg-utils
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ x11-misc/xdg-utils
+ )
+ sbc? ( media-libs/sbc )
+ smi? ( net-libs/libsmi )
+ ssl? ( net-libs/gnutls:= )
+ zlib? ( sys-libs/zlib !=sys-libs/zlib-1.2.4 )
+"
+# We need perl for `pod2html`. The rest of the perl stuff is to block older
+# and broken installs. #455122
+DEPEND="
+ ${CDEPEND}
+ dev-lang/perl
+ !<virtual/perl-Pod-Simple-3.170
+ !<perl-core/Pod-Simple-3.170
+ doc? (
+ app-doc/doxygen
+ app-text/asciidoc
+ dev-libs/libxml2
+ dev-libs/libxslt
+ doc-pdf? ( dev-java/fop )
+ www-client/lynx
+ )
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${CDEPEND}
+ gtk? ( virtual/freedesktop-icon-theme )
+ qt4? ( virtual/freedesktop-icon-theme )
+ qt5? ( virtual/freedesktop-icon-theme )
+ selinux? ( sec-policy/selinux-wireshark )
+"
+
+pkg_setup() {
+ enewgroup wireshark
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.99.8-qtchooser.patch \
+ "${FILESDIR}"/${PN}-2.1.0-sse4_2-r1.patch \
+ "${FILESDIR}"/${PN}-99999999-androiddump.patch
+
+ epatch_user
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # Workaround bug #213705. If krb5-config --libs has -lcrypto then pass
+ # --with-ssl to ./configure. (Mimics code from acinclude.m4).
+ if use kerberos; then
+ case $(krb5-config --libs) in
+ *-lcrypto*)
+ ewarn "Kerberos was built with ssl support: linkage with openssl is enabled."
+ ewarn "Note there are annoying license incompatibilities between the OpenSSL"
+ ewarn "license and the GPL, so do your check before distributing such package."
+ myconf+=( "--with-ssl" )
+ ;;
+ esac
+ fi
+
+ # Enable wireshark binary with any supported GUI toolkit (bug #473188)
+ if use gtk || use qt4 || use qt5; then
+ myconf+=( "--enable-wireshark" )
+ else
+ myconf+=( "--disable-wireshark" )
+ fi
+
+ if ! use qt4 && ! use qt5; then
+ myconf+=( "--with-qt=no" )
+ fi
+
+ if use qt4; then
+ export QT_MIN_VERSION=4.6.0
+ fi
+
+ if use qt5; then
+ export QT_MIN_VERSION=5.3.0
+ append-cxxflags -fPIC -DPIC
+ fi
+
+ # Hack around inability to disable doxygen/fop doc generation
+ use doc || export ac_cv_prog_HAVE_DOXYGEN=false
+ use doc-pdf || export ac_cv_prog_HAVE_FOP=false
+
+ # dumpcap requires libcap
+ # --disable-profile-build bugs #215806, #292991, #479602
+ econf \
+ $(use androiddump && use pcap && echo --enable-androiddump-use-libpcap=yes) \
+ $(use_enable androiddump) \
+ $(use_enable tfshark) \
+ $(use_with adns c-ares) \
+ $(use_with caps libcap) \
+ $(use_with crypt gcrypt) \
+ $(use_with geoip) \
+ $(use_with gtk gtk 3) \
+ $(use_with kerberos krb5) \
+ $(use_with lua) \
+ $(use_with pcap dumpcap-group wireshark) \
+ $(use_with pcap) \
+ $(use_with portaudio) \
+ $(usex qt4 --with-qt=4 '') \
+ $(usex qt4 MOC=$(qt4_get_bindir)/moc '') \
+ $(usex qt4 RCC=$(qt4_get_bindir)/rcc '') \
+ $(usex qt4 UIC=$(qt4_get_bindir)/uic '') \
+ $(usex qt5 --with-qt=5 '') \
+ $(usex qt5 MOC=$(qt5_get_bindir)/moc '') \
+ $(usex qt5 RCC=$(qt5_get_bindir)/rcc '') \
+ $(usex qt5 UIC=$(qt5_get_bindir)/uic '') \
+ $(use_with sbc) \
+ $(use_with smi libsmi) \
+ $(use_with ssl gnutls) \
+ $(use_with zlib) \
+ $(usex netlink --with-libnl=3 --without-libnl) \
+ $(usex cpu_flags_x86_sse4_2 --enable-sse4_2 '') \
+ --disable-profile-build \
+ --disable-warnings-as-errors \
+ --sysconfdir="${EPREFIX}"/etc/wireshark \
+ ${myconf[@]}
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ emake -j1 -C docbook
+ if use doc-pdf; then
+ addpredict "/root/.java"
+ emake -C docbook all-pdf
+ fi
+ fi
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ dohtml -r docbook/{release-notes.html,ws{d,u}g_html{,_chunked}}
+ if use doc-pdf; then
+ insinto /usr/share/doc/${PF}/pdf/
+ doins docbook/{developer,user}-guide-{a4,us}.pdf docbook/release-notes.pdf
+ fi
+ fi
+
+ # FAQ is not required as is installed from help/faq.txt
+ dodoc AUTHORS ChangeLog NEWS README{,.bsd,.linux,.macos,.vmware} \
+ doc/{randpkt.txt,README*}
+
+ # install headers
+ local wsheader
+ for wsheader in \
+ config.h \
+ epan/*.h \
+ epan/crypt/*.h \
+ epan/dfilter/*.h \
+ epan/dissectors/*.h \
+ epan/ftypes/*.h \
+ epan/wmem/*.h \
+ register.h \
+ wiretap/*.h \
+ ws_symbol_export.h \
+ wsutil/*.h
+ do
+ insinto /usr/include/wireshark/$( dirname ${wsheader} )
+ doins ${wsheader}
+ done
+
+ #with the above this really shouldn't be needed, but things may be looking in wiretap/ instead of wireshark/wiretap/
+ insinto /usr/include/wiretap
+ doins wiretap/wtap.h
+
+ if use gtk || use qt4 || use qt5; then
+ local c d
+ for c in hi lo; do
+ for d in 16 32 48; do
+ insinto /usr/share/icons/${c}color/${d}x${d}/apps
+ newins image/${c}${d}-app-wireshark.png wireshark.png
+ done
+ done
+ for d in 16 24 32 48 64 128 256 ; do
+ insinto /usr/share/icons/hicolor/${d}x${d}/mimetypes
+ newins image/WiresharkDoc-${d}.png application-vnd.tcpdump.pcap.png
+ done
+ fi
+
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ # Add group for users allowed to sniff.
+ enewgroup wireshark
+
+ if use pcap; then
+ fcaps -o 0 -g wireshark -m 4710 -M 0710 \
+ cap_dac_read_search,cap_net_raw,cap_net_admin \
+ "${EROOT}"/usr/bin/dumpcap
+ fi
+
+ ewarn "NOTE: To capture traffic with wireshark as normal user you have to"
+ ewarn "add yourself to the wireshark group. This security measure ensures"
+ ewarn "that only trusted users are allowed to sniff your traffic."
+}