summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-08-17 22:13:10 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-08-17 22:13:29 +0200
commit75f6041c30ba38fd1486a9843a246d585ed4f48c (patch)
tree1e9430d0ab072e869dc6d85955efae0b1d47f235
parentdev-db/mysql-connector-c: disable rpm call (diff)
downloadgentoo-75f6041c30ba38fd1486a9843a246d585ed4f48c.tar.gz
gentoo-75f6041c30ba38fd1486a9843a246d585ed4f48c.tar.bz2
gentoo-75f6041c30ba38fd1486a9843a246d585ed4f48c.zip
dev-db/mysql: disable rpm call
Closes: https://bugs.gentoo.org/692368 Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--dev-db/mysql/mysql-8.0.17.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-db/mysql/mysql-8.0.17.ebuild b/dev-db/mysql/mysql-8.0.17.ebuild
index d2e0717c4ab5..df67c9534ad5 100644
--- a/dev-db/mysql/mysql-8.0.17.ebuild
+++ b/dev-db/mysql/mysql-8.0.17.ebuild
@@ -164,6 +164,11 @@ src_unpack() {
}
src_prepare() {
+ # Avoid rpm call which would trigger sandbox, #692368
+ sed -i \
+ -e 's/MY_RPM rpm/MY_RPM rpmNOTEXISTENT/' \
+ CMakeLists.txt || die
+
if use jemalloc ; then
echo "TARGET_LINK_LIBRARIES(mysqld jemalloc)" >> "${S}/sql/CMakeLists.txt" || die
fi