summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-01-22 14:05:06 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-01-22 14:05:06 +0300
commit761556c1682af7d7a51a1fb706afce9324dfc93e (patch)
tree038627e194babdf74fb3dd892c34fa4ad55e0d7e
parentapp-arch/gzip: m68k stable wrt bug #674100 (diff)
downloadgentoo-761556c1682af7d7a51a1fb706afce9324dfc93e.tar.gz
gentoo-761556c1682af7d7a51a1fb706afce9324dfc93e.tar.bz2
gentoo-761556c1682af7d7a51a1fb706afce9324dfc93e.zip
app-arch/gzip: Drop old
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--app-arch/gzip/Manifest1
-rw-r--r--app-arch/gzip/files/gzip-1.4-asmv.patch30
-rw-r--r--app-arch/gzip/gzip-1.8.ebuild44
3 files changed, 0 insertions, 75 deletions
diff --git a/app-arch/gzip/Manifest b/app-arch/gzip/Manifest
index 021ce88ebac5..81f9c56bf5d5 100644
--- a/app-arch/gzip/Manifest
+++ b/app-arch/gzip/Manifest
@@ -1,3 +1,2 @@
DIST gzip-1.10.tar.xz 775144 BLAKE2B 431dc0fd11061eabd9db86594777b86510b124b124fd74799eacd67334631af60f638be2638413bee0153a9da35528d0aecc5b5083152c395223705400c9103b SHA512 e6ba9e3906cdb6a6235b213515093d02afa1722686f73eddacbacae628542b586b449829783b6a1701e9b9e0c4d4dfa6845904d3b6b010f5cf21aec4997c9299
-DIST gzip-1.8.tar.xz 728116 BLAKE2B 34b707bd403791aca8620de3520637c460dbd9167a4fb693c78438115862781350ef5e256ad0accce75b25515b82fcd3e405cc310d6ea36f2d2609b0a270c4db SHA512 efd3e2439476054badeb127d9156e24e9252129111219f13fd939596c057b2a96291630b2717181984b391abf249ac8699488bbd01ceeb8a70b121c500b10c55
DIST gzip-1.9.tar.xz 762516 BLAKE2B 4001fc7a770634916d52b026dab1b621fc96275bfb61ec2df2d0e7d7ec1c81414270d3c866034e6ef758870f38e9d4396a25832abe558915a7ded1f1511eb4b0 SHA512 c0852e7f7662141e79d14bc36e50f1940dba3e804feff3b0b8fa084ffec720ac245352282d2f1db117fadc95758424dd418d192b94621dac4367834ccf101fad
diff --git a/app-arch/gzip/files/gzip-1.4-asmv.patch b/app-arch/gzip/files/gzip-1.4-asmv.patch
deleted file mode 100644
index 1be1f63738b0..000000000000
--- a/app-arch/gzip/files/gzip-1.4-asmv.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-http://bugs.gentoo.org/show_bug.cgi?id=302773
-
---- a/tailor.h
-+++ b/tailor.h
-@@ -69,9 +69,6 @@
- # include <io.h>
- # define OS_CODE 0x00
- # define SET_BINARY_MODE(fd) setmode(fd, O_BINARY)
--# if !defined(NO_ASM) && !defined(ASMV)
--# define ASMV
--# endif
- #else
- # define near
- #endif
-@@ -182,7 +179,6 @@
- # define PATH_SEP2 ':'
- # define STDC_HEADERS
- # define OS_CODE 0x01
--# define ASMV
- # ifdef __GNUC__
- # define HAVE_DIRENT_H
- # define HAVE_FCNTL_H
-@@ -201,7 +197,6 @@
- #endif
-
- #if defined(ATARI) || defined(atarist)
--# define ASMV
- # define OS_CODE 0x05
- # ifdef TOSFS
- # define PATH_SEP2 '\\'
diff --git a/app-arch/gzip/gzip-1.8.ebuild b/app-arch/gzip/gzip-1.8.ebuild
deleted file mode 100644
index 03bc1b2ca591..000000000000
--- a/app-arch/gzip/gzip-1.8.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Standard GNU compressor"
-HOMEPAGE="https://www.gnu.org/software/gzip/"
-SRC_URI="mirror://gnu/gzip/${P}.tar.xz
- mirror://gnu-alpha/gzip/${P}.tar.xz
- mirror://gentoo/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="pic static"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.3.8-install-symlinks.patch"
- "${FILESDIR}/${PN}-1.4-asmv.patch"
-)
-
-src_prepare() {
- epatch "${PATCHES[@]}"
-}
-
-src_configure() {
- use static && append-flags -static
- # avoid text relocation in gzip
- use pic && export DEFS="NO_ASM"
- econf
-}
-
-src_install() {
- default
- docinto txt
- dodoc algorithm.doc gzip.doc
-
- # keep most things in /usr, just the fun stuff in /
- dodir /bin
- mv "${ED}"/usr/bin/{gunzip,gzip,uncompress,zcat} "${ED}"/bin/ || die
- sed -e "s:${EPREFIX}/usr:${EPREFIX}:" -i "${ED}"/bin/gunzip || die
-}