summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-01-05 09:41:01 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-01-05 09:41:01 +0200
commit771914408cdf8dc041b6c24e3b2ab789260050c8 (patch)
tree859f1c1b9aa6582bde45fbf17e415c23328963cf
parentx11-misc/splatmoji: use optfeature in 1.2.0 (diff)
downloadgentoo-771914408cdf8dc041b6c24e3b2ab789260050c8.tar.gz
gentoo-771914408cdf8dc041b6c24e3b2ab789260050c8.tar.bz2
gentoo-771914408cdf8dc041b6c24e3b2ab789260050c8.zip
sys-kernel/pf-sources: bump to 5.10-pf5
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.10_p5.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index aa1dd9103bd9..1ea64f28c2b5 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -9,4 +9,5 @@ DIST linux-5.9.tar.xz 115507140 BLAKE2B e8d11472d63a9f8409ca12a2e8c97c6963a3d451
DIST pf-sources-5.10_p2.patch 2555927 BLAKE2B 69684df6616e243f5bda273ce4fd30300cde82355e3e71ef3f265bbc2fe2f680d035875ce76e836c0ee432692b69736ada54026bedbfa4423826260b5c3e05a1 SHA512 cdcaa01a9b89b935ee7b3035516c38b69ed38b897e4566adc132416fdb1953f965c33471192a3e0c85187af8edc2f0645d65e324d7b591fb4e3cabda4b05126c
DIST pf-sources-5.10_p3.patch 2588302 BLAKE2B 47a3aaa429b773edfa4f1a2eeb046648f57204a8b1985710eaf11d95baceb92950352b03e819250d59614b52e8315758a78e72a646f4bedddc5674c2571a06ab SHA512 3701656ddb88b59bb816b96c8b986f9abf4087231dac7ef2c07f1a406e8edbffb7da6e0099ff0ce3a9f73557c96984e8e7b6a9cc69d4cd129d7f7e05535fee1f
DIST pf-sources-5.10_p4.patch 3769450 BLAKE2B 5f470380efe3224150267125022012553daa36aea6bcc62d7df28a78a0f091aef925f6a2964d11e68877750b25ef5449a7d87577db30068d417106e6a76dd396 SHA512 8c0f0f48ff19e2c93ab1a0ec0387ba59365c4b5dedd4d4b7f323ac0f24502862e6e2a50c8c3c5be911836392aefba3d1c99b2fe1bc2ec8849ffff9c72a4dff2d
+DIST pf-sources-5.10_p5.patch 3767157 BLAKE2B 7ea53839532d97225bbb95cd0e56c5e81d51cbe7e01bbfb09a5aea08fabbad7dee415da0ff79b6b248e2f88bb73434d53ba17808a8d62d403387cccc269e9f9d SHA512 2c07b1e66fad2e2ae1c279cfe9a41585c98ad0fe7d592a20d04e203e7a74ef9dddf6d8a970adb797727185dcbb28fa7a6a1faefcc2adb6a1eb0d309c43356f7e
DIST pf-sources-5.9_p7.patch 3027972 BLAKE2B 9247ea63b30f9d42d79303b73a900d468a71e703333932f7f15ae697cdba52c46358297023e037226c219fad5df912fb5d21e6f4b7190556ca799fa84924480e SHA512 c69e14f59bf98944b3329c65b7e2c271d74a756bc8c890130bf3cc68b4b96d31f1c33c4edb128580fcaefeb6e42dd04b1eb3d7f071b2d58bc764d26322bda8cd
diff --git a/sys-kernel/pf-sources/pf-sources-5.10_p5.ebuild b/sys-kernel/pf-sources/pf-sources-5.10_p5.ebuild
new file mode 100644
index 000000000000..223e79a03a51
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.10_p5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define what default functions to run
+ETYPE="sources"
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Just get basic genpatches, -pf patch set already includes vanilla-linux updates
+K_GENPATCHES_VER="1"
+
+# -pf already sets EXTRAVERSION to kernel Makefile
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security team
+K_SECURITY_UNSUPPORTED="1"
+
+# We want the very basic patches from gentoo-sources, experimental patch is
+# already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+inherit kernel-2 optfeature
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="${KERNEL_URI}
+ https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PVR}-pf"
+
+PATCHES=( "${DISTDIR}/${P}.patch" )
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ # kernel-2_src_prepare doesn't apply PATCHES().
+ default
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ elog "Optional features:"
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}