summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-14 00:15:16 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-14 00:26:29 +1200
commit773f7ad9ec4c08f2323f3ac19b4619b3709e8d11 (patch)
tree022689f68fcc3ce0cba3392c595b85b07b86b3b9
parentdev-db/postgresql: Cleanup old, insecure (diff)
downloadgentoo-773f7ad9ec4c08f2323f3ac19b4619b3709e8d11.tar.gz
gentoo-773f7ad9ec4c08f2323f3ac19b4619b3709e8d11.tar.bz2
gentoo-773f7ad9ec4c08f2323f3ac19b4619b3709e8d11.zip
dev-perl/Cache-Memcached-Fast: Bump to version 0.260.0
- EAPI7 - Correct license as best possible given upstream weirdness: Although its very unlikely an end user will use the C parts of this as a library, the possibility still exists that they will, and after installing/downloading this package from Gentoo mirrors, may attempt to crib some of its source code. Subsequently, the only thing that makes sense is to forward expose the LGPL-2.1+ part mandatorially, because we can't make assertions about how people will use this. - Do unconditional removal of annoying tests - Add warning about known test failure with bug #722848 ref, but this path only seems to affect code that tries to use the (new) methods, gat/gat_multi, so existing code is likely unaffected. Upstream: - Fix the stack when not returning anything - Add methods "->gat" and "->gat_multi" for updating expiration time while fetching a key/keys. Bug: https://bugs.gentoo.org/722848 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/Cache-Memcached-Fast/Cache-Memcached-Fast-0.260.0.ebuild49
-rw-r--r--dev-perl/Cache-Memcached-Fast/Manifest1
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-perl/Cache-Memcached-Fast/Cache-Memcached-Fast-0.260.0.ebuild b/dev-perl/Cache-Memcached-Fast/Cache-Memcached-Fast-0.260.0.ebuild
new file mode 100644
index 000000000000..71898415ab1f
--- /dev/null
+++ b/dev-perl/Cache-Memcached-Fast/Cache-Memcached-Fast-0.260.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=RAZ
+DIST_VERSION=0.26
+DIST_EXAMPLES=("script/*")
+inherit perl-module
+
+DESCRIPTION="Perl client for memcached, in C language"
+# License note: Perl 5.x or newer, + "when C parts used as standalone library"
+# Bug: https://bugs.gentoo.org/718946#c4
+LICENSE="|| ( Artistic GPL-1+ ) LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/0.230.0-parallel-make.patch"
+ "${FILESDIR}/${PN}-0.250.0-no-flto.patch"
+)
+RDEPEND="virtual/perl-Storable"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ net-misc/memcached
+ virtual/perl-Test-Simple
+ )
+"
+PERL_RM_FILES=(
+ "t/pod-coverage.t"
+ "t/pod.t"
+)
+
+src_test() {
+ ewarn "t/commands.t is known to fail: https://bugs.gentoo.org/722848"
+ local memcached_opts=( -d -P "${T}/memcached.pid" -p 11211 -l 127.0.0.1 )
+ [[ ${EUID} == 0 ]] && memcached_opts+=( -u portage )
+ memcached "${memcached_opts[@]}" || die "Can't start memcached test server"
+
+ local exit_status
+ perl-module_src_test
+ exit_status=$?
+
+ kill "$(<"${T}/memcached.pid")"
+ return ${exit_status}
+}
diff --git a/dev-perl/Cache-Memcached-Fast/Manifest b/dev-perl/Cache-Memcached-Fast/Manifest
index 2c2fdba34242..0f9d552b31e8 100644
--- a/dev-perl/Cache-Memcached-Fast/Manifest
+++ b/dev-perl/Cache-Memcached-Fast/Manifest
@@ -1 +1,2 @@
DIST Cache-Memcached-Fast-0.25.tar.gz 104313 BLAKE2B 09353d474208af1a57d8a91b1f18a9f2de8bf1e11d059588d24e3b3328f1b8f26c1acb68c97c815d73f7ee50be3f558147a35f5f28709f7bcf9423c42dd4d99f SHA512 385b58f9dd66f86c7f99859782f098101d0f6bce9e2b22552895ab22d775ed73a1886544a51904797812b77e6849d8f2d79e61fb999a11e30497c6ae6de8c5c0
+DIST Cache-Memcached-Fast-0.26.tar.gz 87887 BLAKE2B d7877a56ba94bd173290ccc66ea91d8ff86ee22a9d381a0a8be5049194ffae97b8084f7fdb464c377e632525a9f08084258153e7c358f32926b687f46ca94a53 SHA512 aea565be2d1aaae186c6d985d88e444fa39311338a851f7f05b013affcab0bfcabd258a3df08849b9429b7168ff0d1e59ab27b1e843b217093b2b64786e890b1