summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2021-08-27 17:09:42 +0100
committerIonen Wolkens <ionen@gentoo.org>2021-08-27 15:03:14 -0400
commit776ebddc04e9e262e6d187902cd914f821d230ea (patch)
tree1bd5a5c309423f5ee87c98fd3377a517201de461
parentdev-php/pecl-memcached: Enable more tests and note known broken (diff)
downloadgentoo-776ebddc04e9e262e6d187902cd914f821d230ea.tar.gz
gentoo-776ebddc04e9e262e6d187902cd914f821d230ea.tar.bz2
gentoo-776ebddc04e9e262e6d187902cd914f821d230ea.zip
games-puzzle/xbomb: various fixes, bump eapi
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://bugs.gentoo.org/710600 Closes: https://github.com/gentoo/gentoo/pull/22130 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-puzzle/xbomb/xbomb-2.2b-r3.ebuild (renamed from games-puzzle/xbomb/xbomb-2.2b-r2.ebuild)34
1 files changed, 18 insertions, 16 deletions
diff --git a/games-puzzle/xbomb/xbomb-2.2b-r2.ebuild b/games-puzzle/xbomb/xbomb-2.2b-r3.ebuild
index d43f0aec54a7..f5c0a4225bea 100644
--- a/games-puzzle/xbomb/xbomb-2.2b-r2.ebuild
+++ b/games-puzzle/xbomb/xbomb-2.2b-r3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit desktop toolchain-funcs
@@ -13,10 +13,15 @@ LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
-DEPEND="x11-libs/libXaw"
+DEPEND="
+ acct-group/gamestat
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXt
+"
RDEPEND="
${DEPEND}
- acct-group/gamestat
+ media-fonts/font-misc-misc
"
PATCHES=(
@@ -27,28 +32,25 @@ PATCHES=(
src_prepare() {
default
+ sed -i -e '/strip/d' Makefile || die
sed -i \
- -e '/strip/d' \
- -e '/^CC=/d' \
- -e "/^CFLAGS/ { s:=.*:=${CFLAGS}: }" \
- Makefile || die
- sed -i \
- -e "s:/var/tmp:/var/lib/${PN}:g" \
+ -e "s:/var/tmp:${EPREFIX}/var/games/${PN}:g" \
hiscore.c || die
}
-src_configure() {
- tc-export CC
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
}
src_install() {
- default
+ emake DESTDIR="${ED}" install
+ einstalldocs
- dodir /var/lib/${PN}
- touch "${ED}"/var/lib/${PN}/${PN}{3,4,6}.hi || die "touch failed"
- fperms 660 /var/lib/${PN}/${PN}{3,4,6}.hi
+ dodir /var/games/${PN}
+ touch "${ED}"/var/games/${PN}/${PN}{3,4,6}.hi || die "touch failed"
+ fperms 660 /var/games/${PN}/${PN}{3,4,6}.hi
- fowners root:gamestat /var/lib/${PN} /usr/bin/${PN}
+ fowners root:gamestat /var/games/${PN} /usr/bin/${PN}
fperms g+s /usr/bin/${PN}
make_desktop_entry xbomb XBomb