summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2020-10-22 01:39:44 +0300
committerGöktürk Yüksek <gokturk@gentoo.org>2020-10-28 18:17:14 -0400
commit77db7ced2582c9879a70419c7ff15a17a2ac853f (patch)
tree3013b1a95e94a5ffa91fd19807f835b3e98db48f
parentsys-apps/gentoo-systemd-integration: Stabilize 8 arm, #733582 (diff)
downloadgentoo-77db7ced2582c9879a70419c7ff15a17a2ac853f.tar.gz
gentoo-77db7ced2582c9879a70419c7ff15a17a2ac853f.tar.bz2
gentoo-77db7ced2582c9879a70419c7ff15a17a2ac853f.zip
sys-auth/pam_u2f: bump to 1.1.0
Tested FIDO2 on a YubiKey 5 NFC. Tested U2F on a YubiKey U2F. Closes: https://bugs.gentoo.org/743385 Closes: https://github.com/gentoo/gentoo/pull/17994 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
-rw-r--r--sys-auth/pam_u2f/Manifest1
-rw-r--r--sys-auth/pam_u2f/pam_u2f-1.1.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-auth/pam_u2f/Manifest b/sys-auth/pam_u2f/Manifest
index 25d09bf1c3cc..1ec410573809 100644
--- a/sys-auth/pam_u2f/Manifest
+++ b/sys-auth/pam_u2f/Manifest
@@ -1 +1,2 @@
DIST pam_u2f-1.0.8.tar.gz 384163 BLAKE2B 99767601027db25e6f8d2e59aad5f72b078cf7344ca10fa310a990d512c5e5a4c9ff7c24acb5b21b88b82aa47b4052b9164a422426d1f0889c8f6776526e5c80 SHA512 0bdbea6307428bbed2af69129af207304f7951418ad7df339563f47d678a2cfe6b80321552382e15771cfc06306fae746521850056376f533c430556d051ad36
+DIST pam_u2f-1.1.0.tar.gz 415677 BLAKE2B dba5cd195d390ba4537752549fa5e0f4487930637fedd64b2750424d21d968bf8be54b75dccba92ac13a18b4e2d44825ec18089e9c4f5dc8e11ac12c36b8d28c SHA512 0ffcc32f0bbee279ad02f9c1cd928e2cf1df2fdebe718d869c16b7fece8edafd73cf08c5dfd6a2bc08434ed1970e16e4f89b6dae3b027a961ab43b26818b634f
diff --git a/sys-auth/pam_u2f/pam_u2f-1.1.0.ebuild b/sys-auth/pam_u2f/pam_u2f-1.1.0.ebuild
new file mode 100644
index 000000000000..6d719d8985b6
--- /dev/null
+++ b/sys-auth/pam_u2f/pam_u2f-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic pam
+
+DESCRIPTION="PAM module for FIDO2 and U2F keys"
+HOMEPAGE="https://github.com/Yubico/pam-u2f"
+SRC_URI="https://developers.yubico.com/${PN/_/-}/Releases/${P}.tar.gz"
+
+LICENSE="BSD ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug libressl"
+
+DEPEND="
+ dev-libs/libfido2:0=
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sys-libs/pam"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-1.0.2-fix-Makefile.patch" )
+
+src_prepare() {
+ default
+ use debug || append-cppflags -UDEBUG_PAM -UPAM_DEBUG
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-pam-dir=$(getpam_mod_dir)
+}