summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2019-11-21 15:24:13 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-02 09:39:17 +0100
commit7812a333ffb5423ce132a5a70ac6d2ddfcac8d35 (patch)
tree8a1948f49e587eec2ca8c0a8922eb301e301e843
parentMove app-admin/{graylog2 → graylog} (diff)
downloadgentoo-7812a333ffb5423ce132a5a70ac6d2ddfcac8d35.tar.gz
gentoo-7812a333ffb5423ce132a5a70ac6d2ddfcac8d35.tar.bz2
gentoo-7812a333ffb5423ce132a5a70ac6d2ddfcac8d35.zip
app-admin/graylog: add version 3.1.3
Package-Manager: Portage-2.3.79, Repoman-2.3.17 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/13727 Signed-off-by: Joonas Niilola <juippis@gentoo.org> [combined with moved app-admin/graylog2] Closes: https://bugs.gentoo.org/701728 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/graylog/Manifest1
-rw-r--r--app-admin/graylog/files/graylog.confd12
-rw-r--r--app-admin/graylog/files/graylog.initd30
-rw-r--r--app-admin/graylog/graylog-3.1.3.ebuild83
-rw-r--r--app-admin/graylog/metadata.xml11
5 files changed, 137 insertions, 0 deletions
diff --git a/app-admin/graylog/Manifest b/app-admin/graylog/Manifest
index 43cea02cad9b..b1ce25380443 100644
--- a/app-admin/graylog/Manifest
+++ b/app-admin/graylog/Manifest
@@ -1 +1,2 @@
DIST graylog-2.5.1.tgz 123878927 BLAKE2B d168579be4d20e3a8081d608247e7101fc5d99ddd2b5f063f94d7e91d4095c6bd016a4bc1be0f0e08b5043b771070312286404ece5eacc51e4a8730dfc13dab1 SHA512 44e2ca00e47a34708cea94b74fdc0f56f3a381f161d25633bdf7685fbcd989937163508f8b47b0869c7daacec6c8bd2c874f9381e196ffb3194eb6e3f96b3ce9
+DIST graylog-3.1.3.tgz 120983897 BLAKE2B 68e1dd7b8de7ab9fb12fd2035bcf6f0901d8d9f5083ff8efef09736819ccd70ae4dd6f466cf2fa1eaebb24b4098a26d72524f9b9a47e8dd62d0224bad189bb62 SHA512 8eec2339db474b89fc717e693ec23ca32d9a018f9bb924aab895d1a1f4e90afa9fe9547e432d13b9d0bf5831f8772763f19de41ac66f3e09ebf7e96ebd6cbccf
diff --git a/app-admin/graylog/files/graylog.confd b/app-admin/graylog/files/graylog.confd
new file mode 100644
index 000000000000..f9c2230c0a00
--- /dev/null
+++ b/app-admin/graylog/files/graylog.confd
@@ -0,0 +1,12 @@
+GRAYLOG_CONFIG_FILE="/etc/graylog/graylog.conf"
+GRAYLOG_DATA_DIR="/var/lib/graylog"
+GRAYLOG_GROUP="graylog"
+GRAYLOG_INSTALL_DIR="/usr/share/graylog"
+GRAYLOG_LOG_DIR="/var/log/graylog"
+GRAYLOG_OPTIONS=""
+GRAYLOG_USER="graylog"
+
+JAVA_OPTS="-Djava.library.path=$GRAYLOG_INSTALL_DIR/lib/sigar -Xms1g -Xmx1g -XX:NewRatio=1 -server -XX:+ResizeTLAB -XX:+UseConcMarkSweepGC -XX:+CMSConcurrentMTEnabled -XX:+CMSClassUnloadingEnabled -XX:-OmitStackTraceInFastThrow"
+
+# Please adjust according to your bind address
+rc_need="net.lo"
diff --git a/app-admin/graylog/files/graylog.initd b/app-admin/graylog/files/graylog.initd
new file mode 100644
index 000000000000..d17267e9df22
--- /dev/null
+++ b/app-admin/graylog/files/graylog.initd
@@ -0,0 +1,30 @@
+#!/sbin/openrc-run
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+command="/usr/bin/java"
+command_args="${JAVA_OPTS} -jar ${GRAYLOG_INSTALL_DIR}/graylog.jar server -f ${GRAYLOG_CONFIG_FILE} --no-pid-file ${GRAYLOG_OPTIONS}"
+command_background="true"
+command_user="${GRAYLOG_USER}:${GRAYLOG_GROUP}"
+pidfile="/run/${RC_SVCNAME}.pid"
+
+output_log="${GRAYLOG_LOG_DIR}/graylog.stdout.log"
+error_log="${GRAYLOG_LOG_DIR}/graylog.stderr.log"
+directory="${GRAYLOG_INSTALL_DIR}"
+required_files="${GRAYLOG_CONFIG_FILE}"
+
+depend() {
+ use dns
+}
+
+start_pre() {
+ local d
+ for d in \
+ "${GRAYLOG_DATA_DIR}" \
+ "${GRAYLOG_DATA_DIR}/data" \
+ "${GRAYLOG_DATA_DIR}/data/journal" \
+ "${GRAYLOG_LOG_DIR}"; do
+
+ checkpath -d -o "${GRAYLOG_USER}":"${GRAYLOG_GROUP}" -m750 "${d}"
+ done
+}
diff --git a/app-admin/graylog/graylog-3.1.3.ebuild b/app-admin/graylog/graylog-3.1.3.ebuild
new file mode 100644
index 000000000000..632bb8a67fbe
--- /dev/null
+++ b/app-admin/graylog/graylog-3.1.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Free and open source log management"
+HOMEPAGE="https://www.graylog.org"
+SRC_URI="https://downloads.graylog.org/releases/graylog/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="strip"
+
+RDEPEND="!app-admin/graylog2
+ acct-group/graylog
+ acct-user/graylog
+ >=virtual/jdk-1.8"
+
+DOCS=(
+ COPYING README.markdown UPGRADING.rst
+)
+
+GRAYLOG_DATA_DIR="/var/lib/graylog"
+GRAYLOG_INSTALL_DIR="/usr/share/graylog"
+QA_PREBUILT="${GRAYLOG_INSTALL_DIR}/lib/sigar/libsigar*"
+
+src_prepare() {
+ default
+
+ # Stick to architecture of build host
+ if ! use amd64; then
+ rm -r lib/sigar/libsigar-amd64-*.so || die "Failed in removing AMD64 support libraries"
+ fi
+ if ! use ppc64; then
+ rm -r lib/sigar/libsigar-ppc64-*.so || die "Failed in removing PPC64 support libraries"
+ fi
+ if ! use x86; then
+ rm -r lib/sigar/libsigar-x86-*.so || die "Failed in removing X86 support libraries"
+ fi
+ # Currently unsupported platforms
+ # QA warning galore but testing/patches welcome
+ rm lib/sigar/libsigar-*freebsd*so \
+ lib/sigar/libsigar-*solaris*so \
+ lib/sigar/libsigar-*hpux*.sl \
+ lib/sigar/libsigar-*macosx*.dylib \
+ lib/sigar/libsigar-ia64-*.so \
+ lib/sigar/libsigar-ppc-*.so \
+ lib/sigar/libsigar-s390x*.so \
+ lib/sigar/*winnt* || die "Failed in removing unsupported platform libraries"
+
+ # gentoo specific paths
+ sed -i "s@\(node_id_file = \).*@\1${GRAYLOG_DATA_DIR}/node-id@g; \
+ s@\(message_journal_dir = \).*@\1${GRAYLOG_DATA_DIR}/data/journal@g;" \
+ graylog.conf.example || die
+}
+
+src_install() {
+ default
+
+ insinto /etc/graylog
+ doins graylog.conf.example
+
+ insinto "${GRAYLOG_INSTALL_DIR}"
+ doins graylog.jar
+ doins -r lib plugin
+
+ keepdir "${GRAYLOG_DATA_DIR}"
+
+ newconfd "${FILESDIR}/graylog.confd" graylog
+ newinitd "${FILESDIR}/graylog.initd" graylog
+}
+
+pkg_postinst() {
+ ewarn "Graylog does not depend on need.net any more (#439092)."
+ ewarn
+ ewarn "Please configure rc_need according to your binding address in:"
+ ewarn "/etc/conf.d/graylog"
+ ewarn
+ ewarn "Graylog requires Java >= 8"
+ ewarn "Elasticsearch 5.x or 6.x (does NOT work with 7.x)"
+ ewarn "and MongoDB 3.6 or 4.0 (does NOT work with 4.2)"
+}
diff --git a/app-admin/graylog/metadata.xml b/app-admin/graylog/metadata.xml
index 5087760546f6..84ba1f113f4d 100644
--- a/app-admin/graylog/metadata.xml
+++ b/app-admin/graylog/metadata.xml
@@ -5,4 +5,15 @@
<email>chainsaw@gentoo.org</email>
<name>Tony Vroon</name>
</maintainer>
+ <maintainer type="person">
+ <email>hydrapolic@gmail.com</email>
+ <name>Tomáš Mózes</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">graylog2/graylog2-server</remote-id>
+ </upstream>
</pkgmetadata>