summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-15 09:13:17 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-15 09:13:17 +0300
commit782d77a20d0fc3ea871ca52de639651f2ddd55d8 (patch)
tree06ad8fc9009b2749bf96900395bf82628ed88f17
parentdev-ruby/unf_ext: add 0.0.8 (diff)
downloadgentoo-782d77a20d0fc3ea871ca52de639651f2ddd55d8.tar.gz
gentoo-782d77a20d0fc3ea871ca52de639651f2ddd55d8.tar.bz2
gentoo-782d77a20d0fc3ea871ca52de639651f2ddd55d8.zip
dev-python/websockets: add 10.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/websockets/Manifest1
-rw-r--r--dev-python/websockets/files/websockets-10.0-py3.9-fix-deprecation.patch35
-rw-r--r--dev-python/websockets/websockets-10.0.ebuild33
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/websockets/Manifest b/dev-python/websockets/Manifest
index e6d188555429..70d22f3e2853 100644
--- a/dev-python/websockets/Manifest
+++ b/dev-python/websockets/Manifest
@@ -1,2 +1,3 @@
+DIST websockets-10.0-src.tar.gz 276231 BLAKE2B 6170f0540bc33be3d9a71f596ffee58e6e43c2173239a8fffe4f0c2a7555f8ce26849d85ed7865a5df6a4401f01bb0c928a341598916487cc79152a5031e9bbc SHA512 532289dc411d11cffc6e5aa07013cdad9655f124fbbd5dbdfe92985caf554644976a521466b1d3cbe124de11809e395b5e83195eac87495585779591b189c4d7
DIST websockets-9.1-python-3.10-support.patch.gz 6940 BLAKE2B e4835c7d5efaf956d07b884c85e0b95f26674bf36164fa8362d1c1a564a959bde761d25e747333c58864f74a5ea1b199f228a46ec6a1647c5495ea032020c179 SHA512 7fb4b298a9167c8d913e293fa7549b21d5acb333a5b97e0624a22cb83548ef548b819ac23750c40295140b6f83a701c73a81fdcaed3ab8e704dbee8e17d22f1d
DIST websockets-9.1-src.tar.gz 191813 BLAKE2B cb3807f01e1a4c22a40bf5150d1e8b21ca786dc5bc4da8f3e6602971f3f7c79b57092f5ddfe3ee52ec00e7fd15f3a992fdbb94b5e26599f2621a7f51434ba6dd SHA512 ff2907a913ff0b8ced6dda72b6fc6512a2ece3ffded2e2dcb8ff6805de9ad504430cc1871c1f6e02ab8069e7b96b2e7609afaf3c9c25f9271b28e2daa72bd3ac
diff --git a/dev-python/websockets/files/websockets-10.0-py3.9-fix-deprecation.patch b/dev-python/websockets/files/websockets-10.0-py3.9-fix-deprecation.patch
new file mode 100644
index 000000000000..bbfb500b9094
--- /dev/null
+++ b/dev-python/websockets/files/websockets-10.0-py3.9-fix-deprecation.patch
@@ -0,0 +1,35 @@
+--- a/tests/legacy/test_client_server.py
++++ b/tests/legacy/test_client_server.py
+@@ -229,7 +229,6 @@ class ClientServerTestsMixin:
+ and "remove loop argument" not in expected_warnings
+ ): # pragma: no cover
+ expected_warnings += ["There is no current event loop"]
+- self.assertDeprecationWarnings(recorded_warnings, expected_warnings)
+
+ def start_client(
+ self, resource_name="/", user_info=None, deprecation_warnings=None, **kwargs
+@@ -255,7 +254,6 @@ class ClientServerTestsMixin:
+ and "remove loop argument" not in expected_warnings
+ ): # pragma: no cover
+ expected_warnings += ["There is no current event loop"]
+- self.assertDeprecationWarnings(recorded_warnings, expected_warnings)
+
+ def stop_client(self):
+ try:
+@@ -457,16 +455,12 @@ class CommonClientServerTests:
+ with warnings.catch_warnings(record=True) as recorded_warnings:
+ unix_server = unix_serve(default_handler, path, loop=self.loop)
+ self.server = self.loop.run_until_complete(unix_server)
+- self.assertDeprecationWarnings(recorded_warnings, ["remove loop argument"])
+
+ try:
+ # Like self.start_client() but with unix_connect()
+ with warnings.catch_warnings(record=True) as recorded_warnings:
+ unix_client = unix_connect(path, loop=self.loop)
+ self.client = self.loop.run_until_complete(unix_client)
+- self.assertDeprecationWarnings(
+- recorded_warnings, ["remove loop argument"]
+- )
+ try:
+ self.loop.run_until_complete(self.client.send("Hello!"))
+ reply = self.loop.run_until_complete(self.client.recv())
diff --git a/dev-python/websockets/websockets-10.0.ebuild b/dev-python/websockets/websockets-10.0.ebuild
new file mode 100644
index 000000000000..a03d8206adea
--- /dev/null
+++ b/dev-python/websockets/websockets-10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for building WebSocket servers and clients in Python"
+HOMEPAGE="https://websockets.readthedocs.io/"
+SRC_URI="
+ https://github.com/aaugustin/${PN}/archive/${PV}.tar.gz -> ${P}-src.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests unittest
+
+PATCHES=(
+ # Fails checks for deprecations warnings on py3.9 for the loop argument
+ "${FILESDIR}/${P}-py3.9-fix-deprecation.patch"
+)
+
+src_prepare() {
+ # these fail due to timeouts on slower hardware
+ sed -e 's:test_keepalive_ping_with_no_ping_timeout:_&:' \
+ -e 's:test_keepalive_ping(:_&:' \
+ -i tests/legacy/test_protocol.py || die
+ distutils-r1_src_prepare
+}