summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-11-30 23:49:28 +0100
committerUlrich Müller <ulm@gentoo.org>2017-11-30 23:53:05 +0100
commit79772767e7aeeb7cc121280bfbe524fc5656c7d7 (patch)
tree6b6544dac0c0295b8127cda42c50357f877a4b49
parentdev-ruby/rspec-expectations: stable 2.99.2 for sparc, bug #634508 (thanks to ... (diff)
downloadgentoo-79772767e7aeeb7cc121280bfbe524fc5656c7d7.tar.gz
gentoo-79772767e7aeeb7cc121280bfbe524fc5656c7d7.tar.bz2
gentoo-79772767e7aeeb7cc121280bfbe524fc5656c7d7.zip
dev-db/qt5-sqlcipher: Initial import.
New dependency of net-im/openmittsu. Package-Manager: Portage-2.3.16, Repoman-2.3.6
-rw-r--r--dev-db/qt5-sqlcipher/Manifest1
-rw-r--r--dev-db/qt5-sqlcipher/files/qt5-sqlcipher-install-path.patch12
-rw-r--r--dev-db/qt5-sqlcipher/metadata.xml7
-rw-r--r--dev-db/qt5-sqlcipher/qt5-sqlcipher-0.1.1_pre20171123.ebuild33
4 files changed, 53 insertions, 0 deletions
diff --git a/dev-db/qt5-sqlcipher/Manifest b/dev-db/qt5-sqlcipher/Manifest
new file mode 100644
index 000000000000..44f139914051
--- /dev/null
+++ b/dev-db/qt5-sqlcipher/Manifest
@@ -0,0 +1 @@
+DIST qt5-sqlcipher-0.1.1_pre20171123.tar.xz 14160 BLAKE2B 9cd35540e2e8945f7c227c3237670771462ca5e42461c4abd65c4095324305fea35ef25c7ad19337e000101d65b2fb1323e60847082ad48de83a0e181d4cf422 SHA512 9d9f41949a728e6da28bb644b8ad70a63e156744970602c87640c894aba4fb2267a9b622b9b09175b51909cebf29f941b6b2e6ea3e9e823b78f2be9f32acc1b2
diff --git a/dev-db/qt5-sqlcipher/files/qt5-sqlcipher-install-path.patch b/dev-db/qt5-sqlcipher/files/qt5-sqlcipher-install-path.patch
new file mode 100644
index 000000000000..d5eb79f5f04e
--- /dev/null
+++ b/dev-db/qt5-sqlcipher/files/qt5-sqlcipher-install-path.patch
@@ -0,0 +1,12 @@
+--- qt5-sqlcipher-orig/CMakeLists.txt
++++ qt5-sqlcipher/CMakeLists.txt
+@@ -120,8 +120,7 @@
+ INSTALL(TARGETS qsqlcipher DESTINATION lib/i386-linux-gnu/qt5/plugins/sqldrivers)
+ endif()
+ else()
+- message(WARNING "Packaging is not set up for this platform, either submit a ticket or change/add pathes yourself, if packaging is required.")
+- INSTALL(TARGETS qsqlcipher DESTINATION sqldrivers)
++ INSTALL(TARGETS qsqlcipher DESTINATION @LIBDIR@/qt5/plugins/sqldrivers)
+ endif()
+ else()
+ INSTALL(TARGETS qsqlcipher DESTINATION sqldrivers)
diff --git a/dev-db/qt5-sqlcipher/metadata.xml b/dev-db/qt5-sqlcipher/metadata.xml
new file mode 100644
index 000000000000..c665e48637be
--- /dev/null
+++ b/dev-db/qt5-sqlcipher/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>ulm@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-db/qt5-sqlcipher/qt5-sqlcipher-0.1.1_pre20171123.ebuild b/dev-db/qt5-sqlcipher/qt5-sqlcipher-0.1.1_pre20171123.ebuild
new file mode 100644
index 000000000000..75caf3f0bb1a
--- /dev/null
+++ b/dev-db/qt5-sqlcipher/qt5-sqlcipher-0.1.1_pre20171123.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Qt SQL driver plugin for SQLCipher"
+HOMEPAGE="https://github.com/blizzard4591/qt5-sqlcipher"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="LGPL-2.1" # version 2.1 only
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-db/sqlcipher-3.4.1
+ >=dev-qt/qtcore-5.7.1:5=
+ >=dev-qt/qtsql-5.7.1:5=[sqlite]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+DOCS=(README.md)
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-install-path.patch
+ sed -i -e "s/@LIBDIR@/$(get_libdir)/" CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ ./qsqlcipher-test || die
+}