summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-05 23:01:07 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-05 23:07:29 -0400
commit79e2115d8a44bbec89f09f7b328313ee3dc86a16 (patch)
tree985fda1606811c1348487c66c81751d03c864240
parentapp-editors/focuswriter: version bump (diff)
downloadgentoo-79e2115d8a44bbec89f09f7b328313ee3dc86a16.tar.gz
gentoo-79e2115d8a44bbec89f09f7b328313ee3dc86a16.tar.bz2
gentoo-79e2115d8a44bbec89f09f7b328313ee3dc86a16.zip
app-laptop/tp_smapi: new version 0.42.
This adds a new version 0.42, and updates the ebuild a bit. First, the ebuild was updated to EAPI=6. Then the RESTRICT=userpriv was removed, as it no longer seems to have any effect: I can install the package fine with FEATURES=userpriv. Next, an obsolete kernel version check was removed. Every version of every flavor of Linux sources we have in the tree is already newer than 2.6.19. Finally, einstalldocs (from EAPI=6) was used to install the current set of docs as well as a TODO that had been omitted. I have added myself as the maintainer of this package, since I still have hardware that it supports. Gentoo-Bug: 516570 Gentoo-Bug: 583206 Package-Manager: portage-2.2.28
-rw-r--r--app-laptop/tp_smapi/Manifest1
-rw-r--r--app-laptop/tp_smapi/metadata.xml9
-rw-r--r--app-laptop/tp_smapi/tp_smapi-0.42.ebuild (renamed from app-laptop/tp_smapi/tp_smapi-0.41-r2.ebuild)26
3 files changed, 18 insertions, 18 deletions
diff --git a/app-laptop/tp_smapi/Manifest b/app-laptop/tp_smapi/Manifest
index 425ca7eb52d3..d6d974e18464 100644
--- a/app-laptop/tp_smapi/Manifest
+++ b/app-laptop/tp_smapi/Manifest
@@ -1 +1,2 @@
DIST tp_smapi-0.41.tar.gz 38852 SHA256 6aef02b92d10360ac9be0db29ae390636be55017990063a092a285c70b54e666 SHA512 924a11cdf64bc151d069d4f61ca476cf006773291f363b21a80ce091f560a78c4828d2e522e646a5b133c58149a37cb5c2432a165e92e6980eb510b9488c728e WHIRLPOOL 10c74811148934a49b2d2b65cd65d366c58de03682c02d6b82694b4831634a25f2da9986b0493e28b372abf7ada692ee8ea85b2881b823b0cb7b35b73f348d6e
+DIST tp_smapi-0.42.tgz 39867 SHA256 7b8d9f488c3859805f1f292bf4d518cc5b32ebb69b0ebe96367d0852dd792d27 SHA512 1004b7ef961a9908c2144b26ea60b6dddabd83d60c11421a03e3b810f5b635415ef52656d6980915512d68f809f7bc3d662328f25d111537bd7e175d252cf83b WHIRLPOOL 7d03aaf2bb4de3aabbc38fba62f126e6f2976ea1964d85da2fffbbcd63bb4c3884a152851cae116438b859c13d59fd4e41be126683f660f9b8322d7fc40ddc28
diff --git a/app-laptop/tp_smapi/metadata.xml b/app-laptop/tp_smapi/metadata.xml
index dc1f3c903006..2f944f633c24 100644
--- a/app-laptop/tp_smapi/metadata.xml
+++ b/app-laptop/tp_smapi/metadata.xml
@@ -1,12 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+
<use>
<flag name="hdaps">Install a compatible HDAPS module</flag>
</use>
+
<upstream>
<remote-id type="github">evgeni/tp_smapi</remote-id>
<remote-id type="sourceforge">tpctl</remote-id>
</upstream>
+
</pkgmetadata>
diff --git a/app-laptop/tp_smapi/tp_smapi-0.41-r2.ebuild b/app-laptop/tp_smapi/tp_smapi-0.42.ebuild
index e32c1f3b639b..ed4b4a57df4d 100644
--- a/app-laptop/tp_smapi/tp_smapi-0.41-r2.ebuild
+++ b/app-laptop/tp_smapi/tp_smapi-0.42.ebuild
@@ -2,13 +2,13 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit flag-o-matic linux-mod
DESCRIPTION="IBM ThinkPad SMAPI BIOS driver"
-HOMEPAGE="https://github.com/evgeni/tp_smapi/ http://tpctl.sourceforge.net/"
-SRC_URI="mirror://github/evgeni/${PN}/${P}.tar.gz"
+HOMEPAGE="https://github.com/evgeni/${PN}"
+SRC_URI="${HOMEPAGE}/releases/download/tp-smapi/${PV}/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
@@ -16,23 +16,14 @@ KEYWORDS="~amd64 ~x86"
IUSE="hdaps"
-RESTRICT="userpriv"
-
-# We need dmideode if the kernel does not support DMI_DEV_TYPE_OEM_STRING
-# in dmi.h
+# We need dmideode if the kernel does not support
+# DMI_DEV_TYPE_OEM_STRING in dmi.h.
DEPEND="sys-apps/dmidecode"
RDEPEND="${DEPEND}"
pkg_pretend() {
linux-mod_pkg_setup
- if kernel_is lt 2 6 19; then
- eerror
- eerror "${P} requires Linux kernel 2.6.19 or above."
- eerror
- die "Unsupported kernel version"
- fi
-
MODULE_NAMES="thinkpad_ec(extra:) tp_smapi(extra:)"
BUILD_PARAMS="KSRC=${KV_DIR} KBUILD=${KV_OUT_DIR}"
BUILD_TARGETS="default"
@@ -40,6 +31,7 @@ pkg_pretend() {
if use hdaps; then
CONFIG_CHECK="~INPUT_UINPUT"
WARNING_INPUT_UINPUT="Your kernel needs uinput for the hdaps module to perform better"
+ # Why call this twice?
linux-info_pkg_setup
MODULE_NAMES="${MODULE_NAMES} hdaps(extra:)"
@@ -69,7 +61,7 @@ src_compile() {
src_install() {
linux-mod_src_install
- dodoc CHANGES README
- newinitd "${FILESDIR}"/${PN}-0.40-initd smapi
- newconfd "${FILESDIR}"/${PN}-0.40-confd smapi
+ einstalldocs
+ newinitd "${FILESDIR}/${PN}-0.40-initd" smapi
+ newconfd "${FILESDIR}/${PN}-0.40-confd" smapi
}