summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-06-11 21:15:35 +0200
committerMichael Palimaka <kensington@gentoo.org>2016-06-17 03:56:24 +1000
commit7a7179a3a8acf9a582b50ca4b0334f349815cb5c (patch)
tree88ccbfa5e1c87b63788d2f7307544d215eacb2c1
parentkde5.eclass: remove KDE_DOXYGEN and KDE_DOX_DIR (diff)
downloadgentoo-7a7179a3a8acf9a582b50ca4b0334f349815cb5c.tar.gz
gentoo-7a7179a3a8acf9a582b50ca4b0334f349815cb5c.tar.bz2
gentoo-7a7179a3a8acf9a582b50ca4b0334f349815cb5c.zip
kde5.eclass: >=Plasma-5.6.5 depends on >=Qt-5.6.1
-rw-r--r--eclass/kde5.eclass9
1 files changed, 9 insertions, 0 deletions
diff --git a/eclass/kde5.eclass b/eclass/kde5.eclass
index 64dacfaacec..a48cc0d49b6 100644
--- a/eclass/kde5.eclass
+++ b/eclass/kde5.eclass
@@ -146,6 +146,15 @@ case ${KDE_AUTODEPS} in
RDEPEND+=" >=kde-frameworks/kf-env-3"
COMMONDEPEND+=" $(add_qt_dep qtcore)"
+ if [[ ${CATEGORY} = kde-plasma ]]; then
+ if [[ $(get_version_component_range 2) -eq 6 && $(get_version_component_range 3) -ge 5 ]]; then
+ QT_MINIMAL=5.6.1
+ fi
+ if [[ $(get_version_component_range 2) -ge 7 || ${PV} = 9999 ]]; then
+ QT_MINIMAL=5.6.1
+ fi
+ fi
+
if [[ ${CATEGORY} = kde-frameworks || ${CATEGORY} = kde-plasma && ${PN} != polkit-kde-agent ]]; then
local blocked_version=15.08.0-r1