summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-06-03 20:55:26 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-06-03 20:55:26 +0200
commit7a9911a81631be80d5473a53e82fd9065d16580c (patch)
tree3d2046c98b74461ce627d0e87b24a2241156a12c
parentsys-kernel/gentoo-kernel-bin: Bump to 5.4.124 (diff)
downloadgentoo-7a9911a81631be80d5473a53e82fd9065d16580c.tar.gz
gentoo-7a9911a81631be80d5473a53e82fd9065d16580c.tar.bz2
gentoo-7a9911a81631be80d5473a53e82fd9065d16580c.zip
dev-ada/gnatcoll-core: bump to 2021
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ada/gnatcoll-core/Manifest1
-rw-r--r--dev-ada/gnatcoll-core/gnatcoll-core-2020-r1.ebuild2
-rw-r--r--dev-ada/gnatcoll-core/gnatcoll-core-2021.ebuild75
3 files changed, 77 insertions, 1 deletions
diff --git a/dev-ada/gnatcoll-core/Manifest b/dev-ada/gnatcoll-core/Manifest
index d6fb26ddb5a8..d230879259d9 100644
--- a/dev-ada/gnatcoll-core/Manifest
+++ b/dev-ada/gnatcoll-core/Manifest
@@ -1 +1,2 @@
DIST gnatcoll-core-2020-20200429-19B7C-src.tar.gz 1396475 BLAKE2B 329e7f799ad62dfc6f71ca78a736bfc8c768a576f817d03b0d73e25b6e97ae0de0ad5a055bb800f7b83d7449ef8fe703c2779f73fc13a09bbcc1d3d8cc880fd1 SHA512 320878335f2ea1ce91a7770cc181e9cc228c80b1f7a3926a4e27c3822eb8f58726c62a014e2fa4c3f8699851ea87424be26d619ab4931b2e969e3a2e96e58b73
+DIST gnatcoll-core-2021-20210518-19ADF-src.tar.gz 1460647 BLAKE2B 42954ed9dfc41914f34973fcfe950b4415af455d8319e802a213994107c7d7a45a6a42b2d260f165fe5ec6589873a7a2c75665b68b97431b13d7694f48273b8c SHA512 6a58920a057dee656df9f64f610f9f1398bc3cbc4ed74a740e8693f2b45da83628c3ce8f76f624bdb101d348603a24bccb47aa770ade1ffbf24da806f4d1de20
diff --git a/dev-ada/gnatcoll-core/gnatcoll-core-2020-r1.ebuild b/dev-ada/gnatcoll-core/gnatcoll-core-2020-r1.ebuild
index 625f0692fdc0..b7350caaeb9f 100644
--- a/dev-ada/gnatcoll-core/gnatcoll-core-2020-r1.ebuild
+++ b/dev-ada/gnatcoll-core/gnatcoll-core-2020-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-ADA_COMPAT=( gnat_201{6,7,8,9} gnat_2020 )
+ADA_COMPAT=( gnat_201{6..9} gnat_2020 )
inherit ada multiprocessing
MYP=${P}-20200429-19B7C
diff --git a/dev-ada/gnatcoll-core/gnatcoll-core-2021.ebuild b/dev-ada/gnatcoll-core/gnatcoll-core-2021.ebuild
new file mode 100644
index 000000000000..37e4d267930d
--- /dev/null
+++ b/dev-ada/gnatcoll-core/gnatcoll-core-2021.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ADA_COMPAT=( gnat_202{0..1} )
+inherit ada multiprocessing
+
+MYP=${P}-${PV}0518-19ADF
+ADAMIRROR=https://community.download.adacore.com/v1
+ID=425b044d5cb112f096c7ac5ebbafb0d8e5297913
+
+DESCRIPTION="GNAT Component Collection Core packages"
+HOMEPAGE="http://libre.adacore.com"
+SRC_URI="${ADAMIRROR}/${ID}?filename=${MYP}-src.tar.gz -> ${MYP}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+shared static-libs static-pic"
+
+RDEPEND="
+ >=dev-ada/libgpr-2021[${ADA_USEDEP},shared?,static-libs?,static-pic?]
+"
+DEPEND="${RDEPEND}
+ dev-ada/gprbuild[${ADA_USEDEP}]"
+
+REQUIRED_USE="${ADA_REQUIRED_USE}"
+
+S="${WORKDIR}"/${MYP}-src
+
+PATCHES=( "${FILESDIR}"/${PN}-2018-gentoo.patch )
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:@GNATLS@:${GNATLS}:g" \
+ src/gnatcoll-projects.ads \
+ || die
+}
+
+src_configure() {
+ emake setup
+}
+
+src_compile() {
+ build () {
+ gprbuild -p -m -j$(makeopts_jobs) \
+ -XBUILD=PROD -v -XGNATCOLL_VERSION=${PV} \
+ -XLIBRARY_TYPE=$1 -XXMLADA_BUILD=$* -XGPR_BUILD=$1 \
+ gnatcoll.gpr -cargs:C ${CFLAGS} -cargs:Ada ${ADAFLAGS} || die
+ }
+ if use shared; then
+ build relocatable
+ fi
+ if use static-pic; then
+ build static-pic
+ fi
+ if use static-libs; then
+ build static
+ fi
+}
+
+src_install() {
+ if use shared; then
+ emake prefix="${D}"/usr install-relocatable
+ fi
+ if use static-pic; then
+ emake prefix="${D}"/usr install-static-pic
+ fi
+ if use static-libs; then
+ emake prefix="${D}"/usr install-static
+ fi
+ rm -r "${D}"/usr/share/gpr/manifests || die
+ einstalldocs
+}