summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2016-05-31 14:34:08 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2016-05-31 14:34:32 +0200
commit7a9f821787a21db585ae1bee8c5f1facda2d3254 (patch)
tree77f303c3373d9eee345250bbb544b4ffdc33651e
parentnet-misc/icaclient: Took over maintenance. (diff)
downloadgentoo-7a9f821787a21db585ae1bee8c5f1facda2d3254.tar.gz
gentoo-7a9f821787a21db585ae1bee8c5f1facda2d3254.tar.bz2
gentoo-7a9f821787a21db585ae1bee8c5f1facda2d3254.zip
media-video/raspberrypi-omxplayer: applied patch by Ahmet Inan <xdsopl@googlemail.com> from bug #421683 and bumped to the latest sources
Package-Manager: portage-2.3.0_rc1
-rw-r--r--media-video/raspberrypi-omxplayer/Manifest1
-rw-r--r--media-video/raspberrypi-omxplayer/patch26
-rw-r--r--media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-0_p20160528.ebuild54
-rw-r--r--media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-9999.ebuild10
4 files changed, 88 insertions, 3 deletions
diff --git a/media-video/raspberrypi-omxplayer/Manifest b/media-video/raspberrypi-omxplayer/Manifest
index 754420f865b4..5c024cd14003 100644
--- a/media-video/raspberrypi-omxplayer/Manifest
+++ b/media-video/raspberrypi-omxplayer/Manifest
@@ -1 +1,2 @@
DIST raspberrypi-omxplayer-0_p20160217.tar.gz 1204486 SHA256 eba2c6ea0843db8105fe4fe9c1f345db38952e4b96bf83ba15b1a3fd0e05effa SHA512 5137ba534ce3b0698c6ace8f570594c97ef978aaa97e6cc902f7895412c5d0282c7c4fa1f7b03f043d5281f0a282caf494602e45aae6a12d6d35bc26aaa4000f WHIRLPOOL 377b53ab0f4308ff600c8cf7af5939e79a942cca22d458b00fb38cebac8cb8760a3be22ad6ad0719890b61f7aa131e623067c96d1846b4aff8e38210e39770b6
+DIST raspberrypi-omxplayer-0_p20160528.tar.gz 1207624 SHA256 8c53d309144e9668092d1c51d32d0719cbc19295f714349655b17c9aa2a71d7f SHA512 c7b00908f52159745dda94f35b9150122ca1e4e97ad1578a89f6db917b1579a8ed94c4ef1592a7c2590240e0fd1e7e0617e3ee8dec7f532368205ee63ce42572 WHIRLPOOL 38d59c1ef076933466acd01186734d44b3d0f1602d415cb51ff82934ad69eac379c24f6d731c79b1cb8daea96148ff96e99c8f74577edbfaaf751fad434f4b18
diff --git a/media-video/raspberrypi-omxplayer/patch b/media-video/raspberrypi-omxplayer/patch
new file mode 100644
index 000000000000..d9b5b6b6d086
--- /dev/null
+++ b/media-video/raspberrypi-omxplayer/patch
@@ -0,0 +1,26 @@
+--- raspberrypi-omxplayer-9999.ebuild 2016-03-09 00:09:34.000000000 +0100
++++ raspberrypi-omxplayer-9999.ebuild 2016-05-31 10:01:58.335198495 +0200
+@@ -14,7 +14,7 @@
+ LICENSE="GPL-2"
+ SLOT="0"
+ KEYWORDS="~arm"
+-IUSE=""
++IUSE="X"
+
+ RDEPEND="dev-libs/libpcre
+ media-fonts/freefont
+@@ -22,8 +22,12 @@
+ sys-apps/dbus
+ sys-apps/fbset
+ virtual/ffmpeg
+- x11-apps/xrefresh
+- x11-apps/xset"
++ dev-libs/boost
++ media-libs/freetype:2
++ X? (
++ x11-apps/xrefresh
++ x11-apps/xset
++ )"
+ DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
diff --git a/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-0_p20160528.ebuild b/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-0_p20160528.ebuild
new file mode 100644
index 000000000000..4a29459b284e
--- /dev/null
+++ b/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-0_p20160528.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs flag-o-matic
+
+GIT_COMMIT="791d7df"
+DESCRIPTION="Command line media player for the Raspberry Pi"
+HOMEPAGE="https://github.com/popcornmix/omxplayer"
+SRC_URI="https://github.com/popcornmix/omxplayer/tarball/${GIT_COMMIT} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm"
+IUSE="X"
+
+RDEPEND="dev-libs/libpcre
+ media-fonts/freefont
+ || ( media-libs/raspberrypi-userland media-libs/raspberrypi-userland-bin )
+ sys-apps/dbus
+ sys-apps/fbset
+ virtual/ffmpeg
+ dev-libs/boost
+ media-libs/freetype:2
+ X? (
+ x11-apps/xrefresh
+ x11-apps/xset
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/popcornmix-omxplayer-${GIT_COMMIT}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/Makefile-0_p20160217.patch \
+ "${FILESDIR}"/fonts-path.patch
+
+ cat > Makefile.include << EOF
+LIBS=-lvchiq_arm -lvcos -lbcm_host -lEGL -lGLESv2 -lopenmaxil -lrt -lpthread
+EOF
+
+ tc-export CXX
+}
+
+src_compile() {
+ emake omxplayer.bin
+}
+
+src_install() {
+ dobin omxplayer omxplayer.bin
+ dodoc README.md
+}
diff --git a/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-9999.ebuild b/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-9999.ebuild
index 18fa556da19d..18d5bbb54c6b 100644
--- a/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-9999.ebuild
+++ b/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-9999.ebuild
@@ -13,7 +13,7 @@ EGIT_REPO_URI="https://github.com/popcornmix/omxplayer.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE=""
+IUSE="X"
RDEPEND="dev-libs/libpcre
media-fonts/freefont
@@ -21,8 +21,12 @@ RDEPEND="dev-libs/libpcre
sys-apps/dbus
sys-apps/fbset
virtual/ffmpeg
- x11-apps/xrefresh
- x11-apps/xset"
+ dev-libs/boost
+ media-libs/freetype:2
+ X? (
+ x11-apps/xrefresh
+ x11-apps/xset
+ )"
DEPEND="${RDEPEND}
virtual/pkgconfig"