summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-09 20:25:31 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-09 20:25:31 +0100
commit7aa474bd39c35e9906a85bffde0f7eaab3958b7b (patch)
treedaca1c9269a8b13cdfe9a69932f0fa0715bed060
parentdev-python/identify: Bump to 2.4.9 (diff)
downloadgentoo-7aa474bd39c35e9906a85bffde0f7eaab3958b7b.tar.gz
gentoo-7aa474bd39c35e9906a85bffde0f7eaab3958b7b.tar.bz2
gentoo-7aa474bd39c35e9906a85bffde0f7eaab3958b7b.zip
dev-python/pygraphviz: Bump to 1.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pygraphviz/Manifest1
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.9.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pygraphviz/Manifest b/dev-python/pygraphviz/Manifest
index 868e2686912e..27a35e94beb5 100644
--- a/dev-python/pygraphviz/Manifest
+++ b/dev-python/pygraphviz/Manifest
@@ -1,2 +1,3 @@
DIST pygraphviz-1.7.zip 118754 BLAKE2B 36507fc862bec45a33bee3f89e7593a15639e7d98067e1c4ddf917558b7bc037b9d7607f7f017ad5980ba0e6805e63f05464efe8fd416ef70cb95709151714e3 SHA512 09438931d1930a70f7da94b0a12b449c0836ad707c6c8abed49bae0db162c136002d170398ed02dc56a5029269490ce3156d2d4b0f30602a11165bc0038998ea
DIST pygraphviz-1.8.zip 119640 BLAKE2B a5c035085c503a06b0496a7ea4db0861e703d2811ab415f2d528dbc6c342d0fab1e9294f818cc4e49bdebba1b98456d6f34eea5628735193a6dde2c37035afce SHA512 f59d9452867167ba406d0e352700ec6bc80364318413a982eadb324c7817f92b9d09922b5fd90b603e2cf6f408390f862e003ef3f1fd3230390944f7d6ee7228
+DIST pygraphviz-1.9.zip 119946 BLAKE2B a399742ae5e8323eec0b6890858cc9158c2942c4f0adb8c74fbfb9745321ae013b93227540e5c328f5dd22d8fba2cf9217a9079f99a14feb983d7188e07084c9 SHA512 0a963b2cfe526c5444379b037797504380898c300256ab3b4800687f46b6230d8bc0adb5f499004a8009544c6cc804221689921c08a4f4b71b86ae01dc39cb7e
diff --git a/dev-python/pygraphviz/pygraphviz-1.9.ebuild b/dev-python/pygraphviz/pygraphviz-1.9.ebuild
new file mode 100644
index 000000000000..96a80374fe2b
--- /dev/null
+++ b/dev-python/pygraphviz/pygraphviz-1.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
+HOMEPAGE="https://pygraphviz.github.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~x86-linux ~ppc-macos ~x64-macos"
+
+# Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
+RDEPEND="media-gfx/graphviz"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/unzip
+ dev-lang/swig:0
+ test? ( dev-python/doctest-ignore-unicode[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ swig -python pygraphviz/graphviz.i || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/install || die
+ epytest
+}
+
+python_install_all() {
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+
+ distutils-r1_python_install_all
+}