summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-02-11 10:34:44 +0000
committerMarek Szuba <marecki@gentoo.org>2022-02-11 10:43:11 +0000
commit7ad2d8743788c51998183a3d4d12674c27010739 (patch)
tree55b8f0d224e27c3a68056b3d27e364ae62458942
parentdev-python/trimesh: initial import (diff)
downloadgentoo-7ad2d8743788c51998183a3d4d12674c27010739.tar.gz
gentoo-7ad2d8743788c51998183a3d4d12674c27010739.tar.bz2
gentoo-7ad2d8743788c51998183a3d4d12674c27010739.zip
media-gfx/cura: add 4.12.1
Featuring py3.10 support along with the three previously disabled plug-ins. Invoking maintainer time-out on both this and all the ~-${PV} dependencies, it has been months. Note that the latest version upstream is now 4.13.1, however that version would diverge quite far from ~-${PV} for Ultimaker dependencies - the latest tag for libarcus, libsavitar and fdm-materials is 4.13.0 and pynest2d has got NO non-beta 4.13 tags. Will leave it to the maintainers to decide what to do with this. Closes: https://bugs.gentoo.org/812935 Closes: https://bugs.gentoo.org/815406 Closes: https://bugs.gentoo.org/822714 Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--media-gfx/cura/Manifest1
-rw-r--r--media-gfx/cura/cura-4.12.1.ebuild77
-rw-r--r--media-gfx/cura/files/cura-4.12.1-code-style-test.patch18
3 files changed, 96 insertions, 0 deletions
diff --git a/media-gfx/cura/Manifest b/media-gfx/cura/Manifest
index 165ec2a1e2b6..66fb25368e66 100644
--- a/media-gfx/cura/Manifest
+++ b/media-gfx/cura/Manifest
@@ -1 +1,2 @@
+DIST cura-4.12.1.tar.gz 50021408 BLAKE2B 114bbe0cc022e33125486228db2eeaeacd9f4abeac8e65f3ed70231e05f4429062ce1cd49e1649959beb827b7a2d245f61c106529a18bd0cebbd0e8b9b8f883f SHA512 397048e1ed93d2e3ec326a3b0564db2b6ee2b239843346e2dd44470b11b5aea86f3f519534270789e020261c87a0100bf3bba39ddbd3a1d8be0e38e68fd7e0c0
DIST cura-4.9.1.tar.gz 47870392 BLAKE2B 2471c8461f73ad2343f4c3315994c5f63781ae1e49cb4699cd66e7e77c25a93916931fbaa6598c4144707dbc7778c902dad3a25839c0523aaf51ed39aacd2463 SHA512 436b8e33514de67d6d680fe59ab9599a75a86caa7e63fbcd05297b12a435483ec0c9ca90557fe23f25590a24e533294915fc18a665fd5cdb77fcc3a05a9076bf
diff --git a/media-gfx/cura/cura-4.12.1.ebuild b/media-gfx/cura/cura-4.12.1.ebuild
new file mode 100644
index 000000000000..7c12eee664b8
--- /dev/null
+++ b/media-gfx/cura/cura-4.12.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake desktop python-single-r1 xdg
+
+MY_PN=Cura
+# No fdm-materials-4.12.1 upstream, 4.12.0 is followed by 4.13.0
+FDM_PV="4.12.0"
+
+DESCRIPTION="A 3D model slicing application for 3D printing"
+HOMEPAGE="https://github.com/Ultimaker/Cura"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug +usb zeroconf"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="sys-devel/gettext"
+RDEPEND="${PYTHON_DEPS}
+ ~dev-libs/libarcus-${PV}:=[python,${PYTHON_SINGLE_USEDEP}]
+ ~dev-libs/libcharon-${PV}[${PYTHON_SINGLE_USEDEP}]
+ ~dev-libs/libsavitar-${PV}:=[python,${PYTHON_SINGLE_USEDEP}]
+ ~dev-python/pynest2d-${PV}[${PYTHON_SINGLE_USEDEP}]
+ ~dev-python/uranium-${PV}[${PYTHON_SINGLE_USEDEP}]
+ ~media-gfx/curaengine-${PV}
+ ~media-gfx/fdm-materials-${FDM_PV}
+ dev-qt/qtquickcontrols[widgets]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/PyQt5[-debug,${PYTHON_USEDEP}]
+ dev-python/PyQt5-sip[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/sentry-sdk[${PYTHON_USEDEP}]
+ dev-python/trimesh[${PYTHON_USEDEP}]
+ sci-libs/shapely[${PYTHON_USEDEP}]
+ usb? ( dev-python/pyserial[${PYTHON_USEDEP}] )
+ zeroconf? ( dev-python/zeroconf[${PYTHON_USEDEP}] )
+ ')"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.12.1-code-style-test.patch
+)
+
+DOCS=(README.md)
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ sed -i -e "s:lib\${LIB_SUFFIX}/python\${Python3_VERSION_MAJOR}.\${Python3_VERSION_MINOR}/site-packages:$(python_get_sitedir):g" CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCURA_BUILDTYPE="ebuild"
+ -DCURA_VERSION=${PV}
+ -DCURA_DEBUGMODE=$(usex debug)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ doicon icons/*.png
+ python_fix_shebang "${D}/usr/bin/cura"
+ python_optimize "${D}${get_libdir}"
+}
diff --git a/media-gfx/cura/files/cura-4.12.1-code-style-test.patch b/media-gfx/cura/files/cura-4.12.1-code-style-test.patch
new file mode 100644
index 000000000000..dd17c6e6188a
--- /dev/null
+++ b/media-gfx/cura/files/cura-4.12.1-code-style-test.patch
@@ -0,0 +1,18 @@
+This is a test for developers, not end users.
+
+--- a/cmake/CuraTests.cmake
++++ b/cmake/CuraTests.cmake
+@@ -50,13 +50,6 @@
+ endfunction()
+
+
+-#Add code style test.
+-add_test(
+- NAME "code-style"
+- COMMAND ${Python3_EXECUTABLE} run_mypy.py
+- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
+-)
+-
+ #Add test for import statements which are not compatible with all builds
+ add_test(
+ NAME "invalid-imports"