summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-04-04 16:07:12 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2016-04-04 16:08:03 -0700
commit7b7346b36c7632a7ddaa74e7cf77fdd323e15b25 (patch)
tree47f5e841f4a609f7dd5832ac26e777e269ff4dbe
parentdev-lang/php: new versions of all three series with security fixes. (diff)
downloadgentoo-7b7346b36c7632a7ddaa74e7cf77fdd323e15b25.tar.gz
gentoo-7b7346b36c7632a7ddaa74e7cf77fdd323e15b25.tar.bz2
gentoo-7b7346b36c7632a7ddaa74e7cf77fdd323e15b25.zip
dev-vcs/cvs-fast-export: bump.
Package-Manager: portage-2.2.28
-rw-r--r--dev-vcs/cvs-fast-export/Manifest1
-rw-r--r--dev-vcs/cvs-fast-export/cvs-fast-export-1.38.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-vcs/cvs-fast-export/Manifest b/dev-vcs/cvs-fast-export/Manifest
index 716ca1ee7c59..dce6015a97f0 100644
--- a/dev-vcs/cvs-fast-export/Manifest
+++ b/dev-vcs/cvs-fast-export/Manifest
@@ -1 +1,2 @@
DIST cvs-fast-export-1.26.tar.gz 668913 SHA256 ebca4b19ba9045bc1b733f729042d7a98dd6675dac3030239f718b13a99949ed SHA512 81d240ae387b4231415335b4a0d294ae81f6ecbc97077d92a1738aca17642b9a7e7ee3f7806890ceafc5c65c50d4370c39c36ee21c927a4fcd30ebfa3bbe472e WHIRLPOOL 1a59b9e5e0b30d935f463a58873c3554315d0d512b4d9482d5fc2341bdb194b16bd017a444f9e21f8ce2181a3bcf6e85aa09584467b1a9e6845ed92b8a75c4f8
+DIST cvs-fast-export-1.38.tar.gz 396524 SHA256 7106c2e85b9fca680230879547dc102186637bd1fbcc5a913127483603d9731a SHA512 ed2aabc417b093c1742ea15bd21855c600a46a5ab72758d15bab24672b6e648531416a6b28c17e6faedd67b4c697b004ba3316cd65cb0ec638566c26878e9428 WHIRLPOOL aba8deba5f3ef8ef7bf38dedf7cd941c24ba709083ff94cfa6c45ae8ebd42f789d1c44276521a752a7b3869d20537964bd05a0689d0ba90a7b180abcc5384bd1
diff --git a/dev-vcs/cvs-fast-export/cvs-fast-export-1.38.ebuild b/dev-vcs/cvs-fast-export/cvs-fast-export-1.38.ebuild
new file mode 100644
index 000000000000..e8943ec2b493
--- /dev/null
+++ b/dev-vcs/cvs-fast-export/cvs-fast-export-1.38.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="fast-export history from a CVS repository or RCS collection"
+HOMEPAGE="http://www.catb.org/~esr/cvs-fast-export/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-text/asciidoc"
+
+RESTRICT=test # upstream does not ship them in tarball
+
+src_prepare() {
+ tc-export CC
+ export prefix=/usr
+
+ # respect CC, CFLAGS and LDFLAGS. don't install cvssync
+ sed \
+ -e 's/cc /$(CC) $(LDFLAGS) /' \
+ -e 's/^CFLAGS += -O/#&/' \
+ -e 's/CFLAGS=/CFLAGS+=/' \
+ -e 's/$(INSTALL).*cvssync/#&/g' \
+ -i Makefile || die
+}
+
+src_install() {
+ default
+ dodoc README
+}