summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-22 19:09:57 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-22 22:40:07 +0200
commit7c811ac74dfcbcea8ff6033efe6608f32581f372 (patch)
tree53051f4c757bd3c4c2b8270e4f73b1eaa1a2b69e
parentsys-libs/libomp: Bump to 11.0.0-rc3 (diff)
downloadgentoo-7c811ac74dfcbcea8ff6033efe6608f32581f372.tar.gz
gentoo-7c811ac74dfcbcea8ff6033efe6608f32581f372.tar.bz2
gentoo-7c811ac74dfcbcea8ff6033efe6608f32581f372.zip
sys-devel/clang-runtime: Bump to 11.0.0-rc3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/clang-runtime/clang-runtime-11.0.0_rc3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-11.0.0_rc3.ebuild b/sys-devel/clang-runtime/clang-runtime-11.0.0_rc3.ebuild
new file mode 100644
index 000000000000..2713d1f397ff
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-11.0.0_rc3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"