summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Schollmeyer <nex+b-g-o@nexadn.de>2022-09-10 22:40:14 +0200
committerSam James <sam@gentoo.org>2022-10-12 23:58:16 +0100
commit7cd6d1ec5d2a11511dcb8e336062947b63d26ca2 (patch)
tree0355cdcab8881d2f4f17778de562490f938f8832
parentapp-emulation/libvirt: add 8.8.0 (diff)
downloadgentoo-7cd6d1ec5d2a11511dcb8e336062947b63d26ca2.tar.gz
gentoo-7cd6d1ec5d2a11511dcb8e336062947b63d26ca2.tar.bz2
gentoo-7cd6d1ec5d2a11511dcb8e336062947b63d26ca2.zip
dev-libs/libpqxx: add 7.7.4
Note that this commit also introduces a subslot following the SONAME version of libpqxx to enable automatic subslot rebuilds. Signed-off-by: Adrian Schollmeyer <nex+b-g-o@nexadn.de> Closes: https://bugs.gentoo.org/876451 Closes: https://github.com/gentoo/gentoo/pull/27200 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/libpqxx/Manifest1
-rw-r--r--dev-libs/libpqxx/libpqxx-7.7.4.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-libs/libpqxx/Manifest b/dev-libs/libpqxx/Manifest
index 5370aa930b28..8b49e6f0dfa0 100644
--- a/dev-libs/libpqxx/Manifest
+++ b/dev-libs/libpqxx/Manifest
@@ -1 +1,2 @@
DIST libpqxx-7.4.1.tar.gz 702581 BLAKE2B 9190b62eaf4cee188e32611acfc938a4111e5ea510df50e424ebd3b6c73fe91dfc8fecd5f889dc2af95756f04c87a410a136cd4b4d6d1f276ce2e5fc26906df3 SHA512 a30a9f5ca87944922c9a3bd92d53392855ac3b2760cb7c21411caf364e443c25d1b2d4b4022e60ff7b30bc530fc3223ab3983325217d47fd7d71375c165c8c21
+DIST libpqxx-7.7.4.tar.gz 745900 BLAKE2B 2306ca1481cb36d32a5911452944404d90760890dfa1f78eca1f9bd0aa8b194484f4a82f15eca2bb37ea9dc80baa81dba5dee45255c04ed7df7aaa01920747ad SHA512 dd8fc9887eec81356d3c6cbcd11543e76bda8caebc770851bb6cf6e3eb5284ef33fc45f6de54c4cc902e07b06a8064f141841ad041addcc0e669d19486b7b4e1
diff --git a/dev-libs/libpqxx/libpqxx-7.7.4.ebuild b/dev-libs/libpqxx/libpqxx-7.7.4.ebuild
new file mode 100644
index 000000000000..83a2e36b0f4f
--- /dev/null
+++ b/dev-libs/libpqxx/libpqxx-7.7.4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-any-r1
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="Standard front-end for writing C++ programs that use PostgreSQL"
+SRC_URI="https://github.com/jtv/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="http://pqxx.org/development/libpqxx/"
+LICENSE="BSD"
+# SONAME version is equal to major.minor
+SLOT="0/$(ver_cut 1-2)"
+IUSE="doc static-libs"
+
+RDEPEND="dev-db/postgresql:="
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ doc? (
+ app-doc/doxygen
+ app-text/xmlto
+ )
+"
+
+DOCS=( AUTHORS NEWS README.md )
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable doc documentation) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ einfo "The tests need a running PostgreSQL server and an existing database."
+ einfo "Test requires PGDATABASE and PGUSER to be set at a minimum. Optionally,"
+ einfo "set PGPORT and PGHOST. Define them at the command line or in:"
+ einfo " ${BROOT}/etc/libpqxx_test_env"
+
+ if [[ -z $PGDATABASE || -z $PGUSER ]] ; then
+ if [[ -f ${BROOT}/etc/libpqxx_test_env ]] ; then
+ source "${BROOT}/etc/libpqxx_test_env"
+ [[ -n $PGDATABASE ]] && export PGDATABASE
+ [[ -n $PGHOST ]] && export PGHOST
+ [[ -n $PGPORT ]] && export PGPORT
+ [[ -n $PGUSER ]] && export PGUSER
+ fi
+ fi
+
+ if [[ -n $PGDATABASE && -n $PGUSER ]] ; then
+ local server_version
+ server_version=$(psql -Aqtc 'SELECT version();' 2> /dev/null)
+ if [[ $? = 0 ]] ; then
+ cd "${S}/test" || die
+ emake check
+ else
+ eerror "Is the server running?"
+ eerror "Verify role and database exist, and are permitted in pg_hba.conf for:"
+ eerror " Role: ${PGUSER}"
+ eerror " Database: ${PGDATABASE}"
+ die "Couldn't connect to server."
+ fi
+ else
+ eerror "PGDATABASE and PGUSER must be set to perform tests."
+ eerror "Skipping tests."
+ fi
+}
+
+src_install () {
+ use doc && HTML_DOCS=( doc/html/. )
+ default
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}