summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-06-21 15:04:24 -0400
committerMike Frysinger <vapier@gentoo.org>2016-06-21 15:04:39 -0400
commit7d0c90e27adbcfc0f88123b559d586e618364d55 (patch)
tree9f63fb2594e44ad1308be5a33f8ae4124306fee1
parentdev-lang/elixir: Bump (diff)
downloadgentoo-7d0c90e27adbcfc0f88123b559d586e618364d55.tar.gz
gentoo-7d0c90e27adbcfc0f88123b559d586e618364d55.tar.bz2
gentoo-7d0c90e27adbcfc0f88123b559d586e618364d55.zip
sys-block/parted: fix building w/newer glibc #580022
-rw-r--r--sys-block/parted/files/parted-3.2-sysmacros.patch28
-rw-r--r--sys-block/parted/parted-3.2-r1.ebuild3
2 files changed, 30 insertions, 1 deletions
diff --git a/sys-block/parted/files/parted-3.2-sysmacros.patch b/sys-block/parted/files/parted-3.2-sysmacros.patch
new file mode 100644
index 000000000000..a29e7619b148
--- /dev/null
+++ b/sys-block/parted/files/parted-3.2-sysmacros.patch
@@ -0,0 +1,28 @@
+https://bugs.gentoo.org/580022
+
+From dec8995fe80508374beba6356f6ecbba8ef6b18b Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 21 Jun 2016 15:01:08 -0400
+Subject: [PATCH] include sysmacros.h for major/minor/makedev
+
+Linux C libs are moving away from including this header implicitly via
+sys/types.h, so include it explicitly.
+---
+ libparted/arch/linux.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/libparted/arch/linux.c b/libparted/arch/linux.c
+index 326b95619d31..e5c168be3c68 100644
+--- a/libparted/arch/linux.c
++++ b/libparted/arch/linux.c
+@@ -37,6 +37,7 @@
+ #include <dirent.h>
+ #include <sys/ioctl.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <sys/utsname.h> /* for uname() */
+ #include <scsi/scsi.h>
+--
+2.8.2
+
diff --git a/sys-block/parted/parted-3.2-r1.ebuild b/sys-block/parted/parted-3.2-r1.ebuild
index 7b07c237f71c..0180e45b8e55 100644
--- a/sys-block/parted/parted-3.2-r1.ebuild
+++ b/sys-block/parted/parted-3.2-r1.ebuild
@@ -34,7 +34,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${PN}-3.2-devmapper.patch \
"${FILESDIR}"/${PN}-3.2-po4a-mandir.patch \
- "${FILESDIR}"/${PN}-3.2-fix-resizing-FAT16.patch
+ "${FILESDIR}"/${PN}-3.2-fix-resizing-FAT16.patch \
+ "${FILESDIR}"/${PN}-3.2-sysmacros.patch
eautoreconf
}