summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-01-23 22:23:16 -0800
committerMatt Turner <mattst88@gentoo.org>2022-01-23 22:23:16 -0800
commit7d72436360f944ff65a6d763b0a09055cc2072a8 (patch)
tree9aed0e819b96cb5cc83564ae564a5b2e7db077a3
parentwww-client/epiphany: Version bump to 41.3 (diff)
downloadgentoo-7d72436360f944ff65a6d763b0a09055cc2072a8.tar.gz
gentoo-7d72436360f944ff65a6d763b0a09055cc2072a8.tar.bz2
gentoo-7d72436360f944ff65a6d763b0a09055cc2072a8.zip
x11-drivers/xf86-input-libinput: Version bump to 1.2.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-drivers/xf86-input-libinput/Manifest1
-rw-r--r--x11-drivers/xf86-input-libinput/xf86-input-libinput-1.2.1.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-libinput/Manifest b/x11-drivers/xf86-input-libinput/Manifest
index a879a90a5f14..5c4eb4fefbe3 100644
--- a/x11-drivers/xf86-input-libinput/Manifest
+++ b/x11-drivers/xf86-input-libinput/Manifest
@@ -1 +1,2 @@
DIST xf86-input-libinput-1.2.0.tar.bz2 358985 BLAKE2B f6fc97c4cb81ae61604d2a56063127a5a9a548c529eda9c506a77d8591b9a439cd0fac9c471e7429fddac6e8c4c043087e53d5113ac62c8bdb5b11381f3d5dce SHA512 ebff9490d33fd7495df2e03203060a76b3274f0e638bc92f3d95257fac57cdb9dac308e90e54006fe9522b6de3b1f1c38fd5f0b0b75b7051e5422290f43de52d
+DIST xf86-input-libinput-1.2.1.tar.xz 312324 BLAKE2B 2ce0419b19306f38cd8adb4159270b3943893032480325243066800cb1256dc1e497756da004f42510a6f6c78b1a3b73a41feccc66d5ce9c7cf40595008abebc SHA512 3decf694861d1aa3c02d090e66c5ed5513818cb18e9863f1790e0c8122a972230fb903705062b8291e1709db9098623f1205c63ccfb68e552e104813414589c7
diff --git a/x11-drivers/xf86-input-libinput/xf86-input-libinput-1.2.1.ebuild b/x11-drivers/xf86-input-libinput/xf86-input-libinput-1.2.1.ebuild
new file mode 100644
index 000000000000..bdc7d73ecf16
--- /dev/null
+++ b/x11-drivers/xf86-input-libinput/xf86-input-libinput-1.2.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+XORG_TARBALL_SUFFIX="xz"
+
+inherit linux-info xorg-3
+
+DESCRIPTION="X.org input driver based on libinput"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND=">=dev-libs/libinput-1.11.0:0="
+DEPEND="${RDEPEND}
+ >=x11-base/xorg-proto-2021.5"
+
+DOCS=( "README.md" )
+
+pkg_pretend() {
+ CONFIG_CHECK="~TIMERFD"
+ check_extra_config
+}