summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-29 19:41:14 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-29 19:41:48 +0200
commit7df0dba820d628b4b7224692a5cb188799097c40 (patch)
treeb84acde2b02eb02a9cd25dd9f07c0fe7a92f028e
parentsci-libs/scikit-learn: bump to 0.24.2 (diff)
downloadgentoo-7df0dba820d628b4b7224692a5cb188799097c40.tar.gz
gentoo-7df0dba820d628b4b7224692a5cb188799097c40.tar.bz2
gentoo-7df0dba820d628b4b7224692a5cb188799097c40.zip
sci-libs/scikit-learn: drop 0.23.2
Closes: https://bugs.gentoo.org/754333 Bug: https://bugs.gentoo.org/758323 Bug: https://bugs.gentoo.org/788592 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-libs/scikit-learn/Manifest1
-rw-r--r--sci-libs/scikit-learn/scikit-learn-0.23.2.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/sci-libs/scikit-learn/Manifest b/sci-libs/scikit-learn/Manifest
index dafc45c07bb4..ca041d4e5182 100644
--- a/sci-libs/scikit-learn/Manifest
+++ b/sci-libs/scikit-learn/Manifest
@@ -1,3 +1,2 @@
DIST scikit-learn-0.22.2_p1.tar.gz 7034850 BLAKE2B 41c362ef6594e837a9fc798837e666fbb51e33954fdf700292650204fd9d1ab4fc4d1695890d02a24ad68f4dcc2d3cde8f0827eca70c6fb9a6f0e5c0d9c04fd5 SHA512 20bcda5c65f76bce9b71c5b5fb1b499f7f3a7a3f6fa5fade80a38dc658cb434e16e9d5a4906a9657157a5cc90a6d51080575d6e510207baa9f8b06c4fa761d5b
-DIST scikit-learn-0.23.2.tar.gz 7190564 BLAKE2B db90e3d05d9b563c6cd98a6820c27b541e757e3fb6c25262b720842811b9e26d41a4a9c1d73e675714573d84dab799a0c450e768f4a41a39a6a61f6930c4c79a SHA512 e9797185b1b9def3ee5525e9b72742784aeb78fe8b069bb5aeab1d0f4513cf738c4489ed894274606dea9d6a32ccd3df26170ce1951e443dc77f9287c372e8c5
DIST scikit-learn-0.24.2.tar.gz 7589697 BLAKE2B a5a32db690e76d6ecfcb12d57a7f84ebcc7e67ecb73258c1d923f9b98a9d87c46aac96918ef7c3d8741f5dbeb46f169c73a7744fb7b92e6ab5cf42101a6bc2f1 SHA512 2159baf63414b9594918b40e1b72af2ab47349335ad4e3afd9756921f786737ed41d6deb333881e8c5c6e1f7ce9cfa10691b966dc2476c48c051621f9049d2ee
diff --git a/sci-libs/scikit-learn/scikit-learn-0.23.2.ebuild b/sci-libs/scikit-learn/scikit-learn-0.23.2.ebuild
deleted file mode 100644
index 4d66f60873c2..000000000000
--- a/sci-libs/scikit-learn/scikit-learn-0.23.2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=no
-inherit distutils-r1
-
-DESCRIPTION="Machine learning library for Python"
-HOMEPAGE="https://scikit-learn.org/stable/"
-SRC_URI="https://github.com/scikit-learn/scikit-learn/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-IUSE="examples"
-
-DEPEND="
- virtual/blas:=
- virtual/cblas:=
-"
-RDEPEND="
- ${DEPEND}
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/joblib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/threadpoolctl[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # scikits-learn now uses the horrible numpy.distutils automagic
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
-
- # remove bundled cblas
- rm -rf sklearn/src || die "failed to remove bundled cblas"
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile ${SCIPY_FCONFIG}
-}
-
-python_test() {
- distutils_install_for_testing ${SCIPY_FCONFIG}
- pushd "${TEST_DIR}/lib" >/dev/null || die
- pytest -vv || die "testing failed with ${EPYTHON}"
- popd >/dev/null || die
-}
-
-python_install() {
- distutils-r1_python_install ${SCIPY_FCONFIG}
-}
-
-python_install_all() {
- find "${S}" -name \*LICENSE.txt -delete
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- fi
-}