summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-28 06:41:24 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-28 06:47:46 -0800
commit7e16982e4fdc7a725f945b21a524ccafb7a26ced (patch)
tree1a8e8806ce98688179739aa714838a86d36fc874
parentsci-mathematics/cadical: new package; add version 1.5.2 (diff)
downloadgentoo-7e16982e4fdc7a725f945b21a524ccafb7a26ced.tar.gz
gentoo-7e16982e4fdc7a725f945b21a524ccafb7a26ced.tar.bz2
gentoo-7e16982e4fdc7a725f945b21a524ccafb7a26ced.zip
app-misc/tty-clock: initial import
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--app-misc/tty-clock/Manifest1
-rw-r--r--app-misc/tty-clock/metadata.xml8
-rw-r--r--app-misc/tty-clock/tty-clock-2.3.ebuild31
3 files changed, 40 insertions, 0 deletions
diff --git a/app-misc/tty-clock/Manifest b/app-misc/tty-clock/Manifest
new file mode 100644
index 000000000000..6bfeefe284aa
--- /dev/null
+++ b/app-misc/tty-clock/Manifest
@@ -0,0 +1 @@
+DIST tty-clock-2.3.tar.gz 7764 BLAKE2B 16e764c6321407ba1a4545de6f7aeb5b1b1f3e0d94d2e05ef9a95a20bc178b11962518a946aa292f35be0a293d12e3739353d2da80358e86d4bf9c29983a81d6 SHA512 ff3cfd5c6312377128b33c7e8c2138627b996d1b17730d8a8fdf55e95f2020e591e69317459aab8383d178f3cb71af046b84eeb81cabfa9b09a27008c5f4b626
diff --git a/app-misc/tty-clock/metadata.xml b/app-misc/tty-clock/metadata.xml
new file mode 100644
index 000000000000..2f82d0bb8eb7
--- /dev/null
+++ b/app-misc/tty-clock/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gyakovlev@gentoo.org</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-misc/tty-clock/tty-clock-2.3.ebuild b/app-misc/tty-clock/tty-clock-2.3.ebuild
new file mode 100644
index 000000000000..4118f7d9021e
--- /dev/null
+++ b/app-misc/tty-clock/tty-clock-2.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Displays a simple digital clock on the terminal"
+HOMEPAGE="https://github.com/xorg62/tty-clock"
+SRC_URI="https://github.com/xorg62/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+DEPEND="sys-libs/ncurses:=[unicode(+)]"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ # makefile does something with ncurses-config and calls old version
+ # let's just build it manually
+ $(tc-getCC) -Wall ${CFLAGS} ${PN//-/}.c \
+ $($(tc-getPKG_CONFIG) --libs ncursesw) \
+ -o ${PN} ${LDFLAGS} || die "Failed to build ${PN}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ einstalldocs
+}