summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-13 22:10:30 +0000
committerSam James <sam@gentoo.org>2023-03-13 22:10:30 +0000
commit7e4a5be6b444994aee29fa163ca0ee333107e78a (patch)
tree9212e031a31e54ae8bfc1b013e512e24c5098c39
parentsys-block/mbuffer: add 20230301 (diff)
downloadgentoo-7e4a5be6b444994aee29fa163ca0ee333107e78a.tar.gz
gentoo-7e4a5be6b444994aee29fa163ca0ee333107e78a.tar.bz2
gentoo-7e4a5be6b444994aee29fa163ca0ee333107e78a.zip
app-text/a2ps: add 4.15.1
Closes: https://bugs.gentoo.org/900743 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-text/a2ps/Manifest1
-rw-r--r--app-text/a2ps/a2ps-4.15.1.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/app-text/a2ps/Manifest b/app-text/a2ps/Manifest
index 6c5b905a04ee..666d17ee80e7 100644
--- a/app-text/a2ps/Manifest
+++ b/app-text/a2ps/Manifest
@@ -1,3 +1,4 @@
DIST a2ps-4.14-ja_nls.patch.gz 27576 BLAKE2B 7300971fb76f6c8d2b0e5ffa519cf6064519a33f24430b9894e43778dff5b78f7cf7e2b9fe1e98fb475f452b39ccc29f88f579bbe1922ac3ef70775a05591b32 SHA512 f02f553dd9d9dbd9dfe41ebfe103493000aa4e9de5634c94e7453f73b66d88fea6b0010095913a4a99c7285990a1df1ebcc39da451b2b34f96b0c191112b125f
DIST a2ps-4.14.tar.gz 2552507 BLAKE2B cd15a2b85f54f8bfb92adf9f4cf2c3c29091e528ae8072d0e905c58cc94caf55b76ac3e37891f8a0bc0909a177c5ee434fe5aaab3625a2c14127dabad8b506ed SHA512 fd6ac8ab47d789114c283e8ca508f7f56feabd1a189f4ac772cad9e6be7e3791e210892cfffd04ad1d39efe4b15386b2e61bf4cd56b70ed581c0554f36bfe06f
+DIST a2ps-4.15.1.tar.gz 3598826 BLAKE2B a205f1c5936329eda0768e1494aba62710ce6eccbdfc695f69d65e4c1cf0b84d6f52dd1c1b32b3aa55a037a37f783cb74cf9d2f3b63cffb07beb0bc15fe7303f SHA512 ed58bd03b9390f44b03ae2458bb94655ef0597f11aa89a2d778b14f03fba4d0e0272795d2f968ae304be46d7b862a2f0ce1dc82328d71a02b0293b23ec8b6fa5
DIST a2ps-4.15.tar.gz 3723299 BLAKE2B b68c3939ad7af5eeb48c85fe6e36e350ce9d0081181bec4374441a1ed9dea6cf716fd3c30a29c06e987d7c26304f2e21ba9b258bb6ca591a6c68180faca8edd8 SHA512 4d88ed4c65c636aa7640e01cf19c259775a810eb91495dc39726554c8ab3b89a105d947c3b357a5b16e5d120b5530587b1838a99829862c9c081b5ae1b354798
diff --git a/app-text/a2ps/a2ps-4.15.1.ebuild b/app-text/a2ps/a2ps-4.15.1.ebuild
new file mode 100644
index 000000000000..db63721729f2
--- /dev/null
+++ b/app-text/a2ps/a2ps-4.15.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools elisp-common
+
+DESCRIPTION="Any to PostScript filter"
+HOMEPAGE="https://www.gnu.org/software/a2ps/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cjk emacs latex nls static-libs vanilla"
+
+# a2ps-lpr-wrapper needs bash
+RDEPEND="
+ app-text/ghostscript-gpl
+ app-text/libpaper:=
+ >=app-text/psutils-1.17
+ app-text/wdiff
+ app-shells/bash:*
+ dev-libs/boehm-gc
+ >=sys-apps/coreutils-6.10-r1
+ emacs? ( >=app-editors/emacs-23.1:* )
+ latex? ( virtual/latex-base )
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-alternatives/yacc
+ >=dev-util/gperf-2.7.2
+ nls? ( sys-devel/gettext )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+
+ use vanilla || eapply "${FILESDIR}"/${PN}-4.15-stdout.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ export LANG=C LC_ALL=C
+
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ --sysconfdir="${EPREFIX}"/etc/a2ps \
+ $(use_enable nls) \
+ COM_netscape=no \
+ COM_acroread=no \
+ $(usev !latex COM_latex=no) \
+ $(usev !emacs EMACS=no)
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ lispdir="${EPREFIX}${SITELISP}"/${PN} \
+ install
+
+ newdoc "${ED}"/usr/share/a2ps/README README.a2ps
+ newdoc "${ED}"/usr/share/a2ps/ppd/README README.a2ps.ppd
+ newdoc "${ED}"/usr/share/ogonkify/README README.ogonkify
+
+ rm -f "${ED}"/usr/share/{a2ps,a2ps/ppd,ogonkify}/README || die
+
+ find "${ED}" -name '*.la' -delete || die
+
+ use emacs && elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+
+ dodoc ANNOUNCE AUTHORS ChangeLog FAQ NEWS README* THANKS TODO
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}