summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-18 16:53:49 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-19 20:09:37 +0200
commit7f0c9506e115eb23918e65386e83dd1d32b82b66 (patch)
tree7ea1fab76743fac0ff1c59886aa7b5712a7522dd
parentCPU_FLAGS_X86: Introduce 'sha' flag (diff)
downloadgentoo-7f0c9506e115eb23918e65386e83dd1d32b82b66.tar.gz
gentoo-7f0c9506e115eb23918e65386e83dd1d32b82b66.tar.bz2
gentoo-7f0c9506e115eb23918e65386e83dd1d32b82b66.zip
dev-libs/crypto++: [QA] Revert cpu_flags_x86_sha removal
Reverts: a1cd4b52d4fcb499ea4416c17dd2638e2362b70e Reverts: 57980c409d0770cf99b2b9ab89e1b02220c5a4fa Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-libs/crypto++/crypto++-8.2.0-r2.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-libs/crypto++/crypto++-8.2.0-r2.ebuild b/dev-libs/crypto++/crypto++-8.2.0-r2.ebuild
index 17988c377227..41b85ded0216 100644
--- a/dev-libs/crypto++/crypto++-8.2.0-r2.ebuild
+++ b/dev-libs/crypto++/crypto++-8.2.0-r2.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://www.cryptopp.com/cryptopp${PV//.}.zip"
LICENSE="Boost-1.0"
SLOT="0/8" # subslot is so version
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
-IUSE="+asm cpu_flags_x86_aes cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_pclmul cpu_flags_x86_sse2 cpu_flags_x86_sse4_2 cpu_flags_x86_ssse3 static-libs"
+IUSE="+asm cpu_flags_x86_aes cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_pclmul cpu_flags_x86_sha cpu_flags_x86_sse2 cpu_flags_x86_sse4_2 cpu_flags_x86_ssse3 static-libs"
BDEPEND="app-arch/unzip"
@@ -40,7 +40,7 @@ src_prepare() {
use cpu_flags_x86_avx || config_add CRYPTOPP_DISABLE_AVX
use cpu_flags_x86_avx2 || config_add CRYPTOPP_DISABLE_AVX2
use cpu_flags_x86_pclmul || config_add CRYPTOPP_DISABLE_CLMUL
- false || config_add CRYPTOPP_DISABLE_SHANI
+ use cpu_flags_x86_sha || config_add CRYPTOPP_DISABLE_SHANI
use cpu_flags_x86_sse2 || config_add CRYPTOPP_DISABLE_SSE2
use cpu_flags_x86_sse4_2 || config_add CRYPTOPP_DISABLE_SSE4
use cpu_flags_x86_ssse3 || config_add CRYPTOPP_DISABLE_SSSE3