summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-03-31 04:21:43 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-03-31 04:21:59 -0400
commit7f66870d913ad192d3ec1a8b5fc6d09e79e60d7a (patch)
tree00dbe25ea86a97b7649f42c59ee6f938164c0367
parentdev-go/go-crypto: src_test: add missing die (diff)
downloadgentoo-7f66870d913ad192d3ec1a8b5fc6d09e79e60d7a.tar.gz
gentoo-7f66870d913ad192d3ec1a8b5fc6d09e79e60d7a.tar.bz2
gentoo-7f66870d913ad192d3ec1a8b5fc6d09e79e60d7a.zip
games-emulation/gngeo: build with gcc5 (bug #571056); respect CFLAGS
Package-Manager: portage-2.2.26
-rw-r--r--games-emulation/gngeo/files/gngeo-0.8-cflags.patch41
-rw-r--r--games-emulation/gngeo/gngeo-0.8.ebuild8
2 files changed, 46 insertions, 3 deletions
diff --git a/games-emulation/gngeo/files/gngeo-0.8-cflags.patch b/games-emulation/gngeo/files/gngeo-0.8-cflags.patch
new file mode 100644
index 000000000000..1a4892abae9e
--- /dev/null
+++ b/games-emulation/gngeo/files/gngeo-0.8-cflags.patch
@@ -0,0 +1,41 @@
+--- configure.in.orig 2016-03-31 04:15:45.913917791 -0400
++++ configure.in 2016-03-31 04:16:23.447607551 -0400
+@@ -236,20 +236,12 @@
+ AC_DEFINE(PROCESSOR_INTEL, 1, [Define if you have an x86 processor])
+ ALIGNLONGS=0
+ proc_i386=true
+- CFLAGS="$CFLAGS -O3 -fstrength-reduce -frerun-loop-opt -Wall -Wno-unused -funroll-loops \
+- -ffast-math -falign-functions=2 -falign-jumps=2 -fexpensive-optimizations \
+- -falign-loops=2 -fschedule-insns2 -malign-double -fomit-frame-pointer -g \
+- -fno-strict-aliasing -pipe -mtune=$target_cpu -DCPU=$target_cpu"
+ ;;
+ x86_64)
+ AC_MSG_RESULT(Turning on x86_64 processor optimisations)
+ AC_DEFINE(PROCESSOR_ADM64, 1, [Define if you have an x86_64 processor])
+ ALIGNLONGS=0
+ proc_x64=true
+- CFLAGS="$CFLAGS -O3 -fstrength-reduce -frerun-loop-opt -Wall -Wno-unused -funroll-loops \
+- -ffast-math -fexpensive-optimizations \
+- -malign-double -fomit-frame-pointer -g \
+- -fno-strict-aliasing -pipe -DCPU=$target_cpu"
+ ;;
+ sparc*) AC_MSG_RESULT(Turning on sparc processor optimisations)
+ AC_DEFINE(PROCESSOR_SPARC, 1, [Define if you have a sparc processor])
+@@ -258,8 +250,6 @@
+ if test $target_cpu = sparc64 && test $CC_MAJOR -ge 3 ; then
+ CFLAGS="$CFLAGS -mcpu=v9"
+ fi
+- CFLAGS="$CFLAGS -O3 -Wall -Wno-unused -funroll-loops \
+- -ffast-math -fomit-frame-pointer -g"
+ ;;
+ arm) AC_MSG_RESULT(Turning on arm processor optimisations)
+ AC_DEFINE(PROCESSOR_ARM, 1, [Define if you have an ARM processor])
+@@ -273,8 +263,6 @@
+ *) AC_MSG_RESULT(Processor type unknown - Use generic optimisations)
+ ALIGNLONGS=1
+ optimum=no
+- CFLAGS="$CFLAGS -O3 -Wall -Wno-unused -funroll-loops \
+- -ffast-math -g"
+ ;;
+ esac
+
diff --git a/games-emulation/gngeo/gngeo-0.8.ebuild b/games-emulation/gngeo/gngeo-0.8.ebuild
index c6b76ced4f16..d994c7897b97 100644
--- a/games-emulation/gngeo/gngeo-0.8.ebuild
+++ b/games-emulation/gngeo/gngeo-0.8.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit eutils autotools games
+inherit eutils autotools flag-o-matic games
DESCRIPTION="A NeoGeo emulator"
HOMEPAGE="https://code.google.com/p/gngeo/"
@@ -23,9 +23,11 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-execstacks.patch \
"${FILESDIR}"/${P}-zlib.patch \
- "${FILESDIR}"/${P}-concurrentMake.patch
+ "${FILESDIR}"/${P}-concurrentMake.patch \
+ "${FILESDIR}"/${P}-cflags.patch
mv configure.in configure.ac || die
eautoreconf
+ append-cflags -std=gnu89 # build with gcc5 (bug #571056)
}
src_configure() {